mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik STM8S DISCOVERY Reset nach Programmierung?


Autor: Dirk H. (hodi)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute,

ich sitze gerade an meinem STM8S Discovery Board und schreibe ein erstes 
kleines Testprogramm.

Es funktioniert soweit alles prima und das Programm lässt sich auch ohne 
weiteres flashen.

Als Programmiertool kommt ST Visual Programmer V3.4.1 zum Einsatz, 
welches
mit dem integriertem ST-LINK auch zusammenarbeitet.



Das Programm startet allerdings nicht automatisch in der Ziel MCU 
sondern erst, nachdem ich das Discovery Board aus- und wieder 
eingeschaltet habe.
Nach dem Flashen bleibt die rote LED neben dem USB Stecker permanent 
rot.

Was muss ich tun, dass es nach dem Flashen einen automatischen RELEASE 
des
Reset gibt?

Gruß

Dirk

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.