mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik GPS Antenne für u-Blox


Autor: Paul Jensen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich habe mir bei eBay einen GPS-Empfänger und die passende Antenne
ersteigert. Der GPS-Empfänger ist ein u-Blox MS1E, zu dem ich auch die
entsprechende Dokumentation in Netz gefunden habe. Zur Antenne habe ich
bis jetzt nur eine Webseite gefunden:
http://www.maltepoeggel.de/html/gpsms1e/
Schaut man sich dort den Schaltpan an, sieht man das 3,3V auf den
Antennen Bias Pin gelegt werden. Leider wird nichts weiter zur Antenne
gesagt...
Hat zufällig jemand auch diese Antenne oder weiss wie ich
herausbekommen kann, ob es sich wirklich um eine 3,3V aktive Antenne
handelt?

Autor: Paul Jensen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ach ja, gleich noch eine Frage. In der Dokumentation des u-Blox MS1E
steht, dass man bei allen ungenutzten seriellen Ports die RX Leitung
auf  VCC legen soll. In allen Schaltplänen zu diesem Empfänger, die ich
bis jetzt gefunden habe, werden die ungenutzten RX Leitungen immer auf
GND gelegt. Kann es sein, dass die Schaltung weniger Strom verbraucht,
wenn man die ungenutzten RX Leitungen auf GND oder wieso machen das
alle anders als es im Datenblatt steht?

Autor: AxelR. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Rx auf VCC ist besser, da LOW Pegel am RX-Pin als Break interpretiert
werden könnte/wird. Die Antenne wird bei 3.3V spielen, ob diese
tatsächlich dafür ausgelegt ist? IdR waren Antennen in der Zeit eher
für 5Volt ausgelegt...
Was steht denn auf dem MMIC als TOP_MARK drauf?
Aus dessen Datenblatt könnte man was rauslesen.

Ich würde statt der BIAS-Brücke einen kleinen Widerstand einlöten. Ein
Kurzschluss am Antennenstecker und L11 im MS1 brennt ab! Man kann diese
zwar ersetzen, ist aber fummelig, den Deckel abzubekommen und die kleine
"Drossel" zu tauschen.

Viele Grüße
AxelR.

Autor: Paul Jensen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Axel,
also im Datenblatt des MS1E steht, dass die Bias-Spannung bis 12V geht.
Die Bauteile auf der Antenne kann ich mir heute Abend mal genauer
anschauen.. vielleicht finde ich da Datenblätter.

Dann verstehe ich nicht, wieso du den Antennen Bias nicht an die 3.3V
Spannungsversorgung hängen willst? Wenn ich einen Kurtzschluß an der
Antenne hätte, würde ein Widerstand zwischen Bias-Port und
Spannungsversorgug doch auch nicht mehr helfen oder? Der gesammte
Empfangsteil hängt ja genau dazwischen oder?

Autor: AxelR. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
"Der gesammte
Empfangsteil hängt ja genau dazwischen oder?"

Nein, hängt er nicht. Die Betriebsspanung für die ext. aktive Antenne
wird über eine Diode und eine 33nH-Drossel auf die Antennenbuchse
gegeben.(Phantomspeisung) Ein kleiner 33Ohm Widerstand begrenzt den
Strom auf ungefährliche Werte. Allerdings verwende ich 5Volt und eine
Hirschmann 5M Antenne. Hier stellen sich dann ca. 3,6Volt bei Nennstrom
(ca 30mA) ein.
5V abzgl. Flussspannung der Diode im MS1E und Spannungsabfall über dem
"Schutzwiderstand".
Wichtiger an dieser Stelle ist, das die Antennenspannung absolut
rauschfrei ist. Die Performance des MS1E ist eh nicht die beste. Da ist
das besonders wichtig. Es gibt spezielle rauscharme Linearregler für
diese Fälle. Das aber nur am Rande...

Autor: Paul Jensen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Axel,

also als Spannungsregler wollte ich erstmal einen LD1117V33 nehmen, da
ich den noch rumliegen habe. Ich hoffe, das es damit funktioniert.
Ohne das Datenblatt zur Antenne, ist es auch schwer den
Schutzwiderstand zu berechnen (wie bei einem LED-Vorwiderstand bräuchte
ich hier für ja die anfallende Spannung und den Strom). Hast du
vielleicht noch eine Idee, wie ich herausbekommen könnte, ob ich 3,3V
oder 5V für meine Antenne brauche?

Autor: AxelR. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du könntest mir sagen, was auf dem SOT23/5 Gehäuse draufsteht...

Autor: AxelR. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Dieses Teil im Anhng meine ich - habe noch mal meine Unterlagen der GAP
AG durchgesehen - sollte eine 3Volt Antenne sein. Aber sicher ist
sicher.

Autor: Paul Jensen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Axel,
wollte eigentlich ein Bild von der Platine machen, habe aber so fix
keine Digitalkamera bekommen. Also auf dem Chip steht GEL und er hat 5
Beinchen. Ich hoffe du kannst damit was anfangen.
Was macht die Elektronik auf der Rückseite eigentlich? Ist das wie beim
LNA für das Sat-Fernsehn? Wenn ich mich jetzt nicht irre wird da ja auch
ein Gleichstrom auf das Antennenkabel gelegt, um damit dann die
Verstärkerschaltung zu speisen, die wegen der Dämpfung und dem Rauschen
so nah wie möglich an der Antenne sein sollte. Ist der Sinn einer
aktiven GPS-Antenne der gleiche, oder werden da ganz andere Sachen
gemacht?

Autor: AxelR. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Genau so, wie Du sagts.
Das kleine Teil mit den 5Beinen "GEL" ist ein Verstärker.
LNA Low Noise Amplifier.
Dummerweise habe ich jetzt auf die Rasche nichts zum TOPMARK "GEL"
finden können. meine MAXIM-Teile heissen "AAA" und brauchen
(ca)3Volt.
Du kannst ja mal vorsichtig 3Vlt auf die Antenne geben und den Strom
messen. sollte so um die 20mA liegen.

Warum wolltest Du ein Bild von der Platine machen? Sieht die anders
aus, als die, welche Du im Netz gefunden hattest?

Ich suche nachher nochmal nach "GEL"...

Autor: Paul Jensen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Axel,
ich wollte ein Foto machen, damit du auch die anderen Bauteile besser
siehst... ich glaube das eine ist ein Filter, dann ist da ein 0 Ohm
Widerstand, noch etwas was wie ein Filter aussieht und dann halt ein
Haufen SMD Kondensatoren. Aber ganz sicher bin ich mir da auch nicht.
Meine suche nach "GEL" hat übrigens nur ergeben, dass es ein gel-pack
bei HF-Bauteilen gibt :/

Vorsichtig kann ich leider keine 3V auf die Antenne geben, da ich kein
Labornetzteil habe, oder meintest du damit was anderes als eine
Strombegrenzung?

Autor: AxelR. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
kein Labornetzteil? hmmm...
Ja meinte ich mit vorsichtig.

Autor: Hauke Radtki (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab mir das gleiche ding gekauft (war einfach unschlagbar günstig)
und werde sobald der empfänger da ist das ganze ausprobieren. Hab auch
n labornetzteil hier werde dann berichten!

Autor: Black Friday (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe mir eine komplette Platine von GAP bestellt, mit bereits
angeschlossener Antenne. Die Antenne arbeitet mit 3,3 V.
Nach GEL habe ich auch schon Stunden gesucht, aber bisher nichts
gefunden. Warum muss man den unbedingt Gel al bezeichnung nehmen :-(
Wärmeleitgel, Silikongel, ...

Autor: Axel R. (axelr) Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
könnte das Dings evtl. auch "6EL" heissen?

Autor: Black Friday (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Axel R. (axelr) Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hmm - die drei vierecke lassen nicht auf einen Hersteller schließen?
Irgentwo hatte ich mal einen Link, wo man die Logos abgleichen konnte.

Autor: Paul Jensen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
also recht gute Seiten zum Logos vergleichen sind z.B. die hier:

http://info.electronicwerkstatt.de/bereiche/bautei...
http://www.jumperz.de/logos.htm
http://www.elnec.com/iclogos_l.php
http://www.eworld.ru/ewg/icweb.htm
www.plasma-online.de/english/identify/picture/index.html

Leider habe ich nix mit 3 Vierecken gefunden.

Wenn ich jetzt meine rausarme Spannungquelle habe, sollte man die dann
ausschießlich zur Speisung des Antennen Bias nutzen oder kann ich da
auch noch andere Sachen dran hängen? Könnte ich ohne Bedenken an die
3.3V zusätzlich noch einen MSP430 zur Auswertung der GPS Daten und noch
ne Power LED usw... dranhängen oder sollte ich hier für eine 2te
Spannungsquelle nutzen und an der Rauscharmen nur die aktive Antenne
betreiben?

Autor: AxelR. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
an der Rauscharmen nur die aktive Antenne
betreiben?
Nur diese!

Ich habe nichts zum LNA "GEL" finden können, leider.
Probiers halt mit drei Volt und nimm eine Referenzantenne als
Vergleich.
Ich habe hier eine Hirschmann 5M...
Mit dem $GSV Datensatz hat man eine schöne Übersicht über die
Satelliten. Lässt sich aber auch komfortabel im uboxCenter anzeigen
lassen.

Autor: AxelR. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
"Lässt sich aber auch komfortabel im uboxCenter anzeigen
lassen."
Wasn das für ein Satz??? Sorry
etweder lässt man sich die Daten anzeigen oder
man kann sie sich anzeigen lassen.
Muss erstmal was essen gehen, glaube ich

Gruß und grins

AxelR.

Autor: Paul Jensen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also eine Referenzantenne habe ich leider auch nicht...
Ich werde mal mein Glück versuchen und berichten was passiert ist ;)

Autor: Luigi Roxxoro (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Im datasheet vom MS1E steht, das die aktive antenne 4.5V benötigt. Im
Netz hab ich eine Spanne von 3.3 bis 5 Volt gelesen, mit denen die
funktionieren.
Ich werde alles mal zusammenwurschteln wenn mein ganzer Kram endlich
mal da ist.

Autor: AxelR (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
"Im datasheet vom MS1E steht, das die aktive antenne 4.5V benötigt. "
Nun, kommt doch drauf an, welchen man verwendet. Oder bezieht sich das
Datenblatt vom MS1E auf eine bestimmte Antenne? Konnte nichts finden.
Bedenke: Zur Drucklegung des Datenblatts des MS1 (siehe u-blox
"Historisches Produkt") gingen die Antennen alle nur mit um die
5Volt.

Hier hat sich ja zum Glück einiges getan.  :-))

Autor: Uwe Nagel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe auch so eine 'GAP-Antenne'. An meinem Trimble Lassen SQ
funktioniert sie mit der Versorgungsspannung von 3,3V. Eine andere
Spannung kann man da nicht einspeisen. Am Labornetzteil messe ich einen
auffallend kleinen Strom von nur 1,9mA bei 3,3V. Die Original-Trimble
Antenne ist mit 13mA angegeben.
Ich vermute mal, dass die 'GAP-Antenne' auch eine höhere Spannung
verträgt.

Autor: Bernhard S. (bernhard)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich lese mich auch gerade in diese Materie ein.

Wenn ich es richtig verstanden habe, dann muss der µBlox-GPS-

Empfänger, vor der Erstinbetriebnahme, ersteinmal auf das NMEA-

Protokoll eingestellt werden?

Bernhard

Autor: Hauke Radtki (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja. Wie das geht erfährt man aber ganz gut auf
http://www.maltepoeggel.de/html/gpsms1e/

Autor: Nikias Klohr (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

ich habe hier auch diesen MS1E von Ebay mit sammt Antenne im Betrieb.
Ich hab die Antenne schon mit 3,3V und 5V betrieben...geht
beides...3.3V geht aber definitiv besser!
VIEL wichtiger ist aber die Glattheit der 3,3V ... Ich habe die
Spannung jetzt sogar extra nochmal mit nem LC Filter geglättet. Das hat
die Empfangsqualität meines MS1E um 10er Potenzen verbessert...hatte
aber auch eine relativ verauschte Umgebung, vor allem mein Atmega mit
8MHz und ein RS323 Pegelwandler mit Ladungspumpe (beides haben ja viele
auf ihrem Board) haben die Spannungsversorgung bei Batteriebetrieb total
versaut!
Jetzt komme ich im Freien ungefähr auf die Zeiten, die im Datenblatt
angegeben sind...und habe sogar noch hier in meiner Wohung unterm Dach
Empfang!

Gruß,
Nikias

Autor: Bernhard S. (bernhard)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also darf die 3,3Volt-Spannung nicht HF/NF verseucht sein. Guter Tipp.

Eigentlich könnte man den Pegel-Shifter (Max232 o.ä.) komplett
einsparen, wenn man nur das NMEA-Protokoll an einen µC senden möchte.

Vorsichtshalber je einen 100k Widerstand in die TXD und RXD
Datenleitung, damit der 5Volt-µC nicht Vss der GPS-Platine anhebt.

Bernhard

Autor: Nikias Klohr (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ein weiterer Punkt ist auch noch die Antennen-Kabel-Steckverbindung. Die
ist IMHO nur für einen EINZIGEN Steckvorgang und kein drehen um die
Hochachse ausgelegt...ich hab da beim Experimentieren ziemlich schnell
nen Wackler drinn gehabt. Das hat mich bestimmt nen ganzen Tag
gekostet, bis ich das raus hatte! Jetzt hab ich den Stecker runter- und
das Kabel direkt fest gelötet - klappt einwandfrei!

Gruß,
Nikias

Autor: Hauke Radtki (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielen dank für die tipps! Ich hoffe meiner kommt auch bald :)

Autor: AxelR (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Zitat aus:
http://www.mikrocontroller.net/forum/read-1-358089...
"Wichtiger an dieser Stelle ist, das die Antennenspannung absolut
rauschfrei ist."

Mein Reden :-))

Autor: Tobias Schneider (tobias)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
auf welchen Parameter des Spannungsreglers muss man den bei der Auswahl
fuer die Antenne achten?
Hat da vll. jemand ein paar gut erhaeltliche Typen parat?

Gruss Tobias

Autor: Bernhard S. (bernhard)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Tobias

>auf welchen Parameter des Spannungsreglers muss man den bei der
>Auswahl
>fuer die Antenne achten?

für 3,3 Volt:

http://www.mikrocontroller.net/forum/read-1-363842.html


Bernhard

Autor: Bernhard S. (bernhard)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich verdrahte gerade den Empfänger GPS-MS1E (µ-Blox)

Dabei ist mir etwas aufgefallen:

Alle VCC-PINS (1,19,32,42) sind intern miteinander verbunden.

Demzufolge würde es doch reichen, wenn nur auf einen PIN (z.B. Pin 1)
+3,3Volt anglegt wird.

Erspart ein paar Kabel, oder spricht etwas dagegen?

Bernhard

Autor: Hauke Radtki (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nunja ich denke es hat wohl einen Sinn, dass es mehrere VCC leitungen
gibt. Es könnte z.b. sein, dass die Leitungen unterschiedlich stark von
den einzelnen Komponenten beansprucht werden. So könnte es zu
spannungsabfällen kommen oder es könnten sich Störsignale auf die VCC
leitung auflagern. Verdrahte lieber alle, die drei Kabel mehr werden
dich nicht umbringen denke ich :)

Autor: Müller Reimund (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

hat schon jemand eine externe Antenne angeschlossen? Wenn ja, welcher
Stecker passt dort? Ist das ein MMCX oder MCX? Könnt ihr mir da
weiterhelfen.

Mfg

Reimund

Autor: Axel R. (axelr) Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
weder noch:
ist ein U.FL von Hirose (glaube ich). gibt aber fertige Kabel (meine
sind 10cm lang und blau) auf SMA.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.