mikrocontroller.net

Forum: PC-Programmierung Excem - wenn verschachteln


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: sven (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe 4 wenn Bedingungen in Excel, die auch an sich funktionieren:
=WENN(($A$1=Blatt1!A4);"Blatt1";"0")
=WENN(($A$1=Blatt2!A4);"Blatt2";"0")
=WENN(($A$1=Blatt3!A4);"Blatt3";"0")
=WENN(($A$1=Blatt4!A4);"Blatt4";"0")

Die Zeilen prüfen, ob sich der Wert in der Zelle A1 in einem anderen 
Blatt in der Excel Datei befinden und geben als Ergebnis das Blatt aus, 
in dem es sich befindet.
Jetzt möchte ich das ganze verschachteln, sodass die 4 Zeilen in einer 
Zelle stehen, sodass mir nur noch das Blatt ausgegeben wird, in dem der 
Wert an der Stelle steht, damit ich später in einer Formel darauf 
zugreifen kann.

Kann mir damit jemand weiterhelfen?
Ich habe auch von der Funktion SVERWEIS gelesen, allerdings nicht, wie 
ich diese Blätterübergreifend verwende.

Autor: Irgendwer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie wäre es damit im ELSE-Zweigs die jeweils nächste WENN zu verwenden:

=WENN(($A$1=Blatt1!A4);"Blatt1";
WENN(($A$1=Blatt2!A4);"Blatt2";
WENN(($A$1=Blatt3!A4);"Blatt3";
WENN(($A$1=Blatt4!A4);"Blatt4";"0"))))

Ergibt allerdings eine Priorisierung der Blätter wenn der Wert in 
mehreren Blättern vorkommt.

Autor: sven (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke "Irgendwer" !

Das habe ich auch so versucht, nur leider habe ich damit einen Fehler 
erzeugt. Wahrscheinlich Klammern vergessen, zu unübersichtlich 
geschrieben..

Weißt du zufällig auch, wie ich nun auf den Text in den Text aus der 
Ergebniszelle zugreifen kann?

Zum Beispiel soll es so sein:

=(Ergebnis aus Wenn Abfrage!A5" +5 )

Das soll bedeuten, dass das Ergebnis aus Wenn Abfrage in der Formel 
jetzt als xyz1!A5 stehen soll und mit 5 Addiert werden soll. ist dies 
möglich?
Damit möchte ich die Zelle A5 aus dem Blatt xyz1 ansprechen.
Das Blatt soll dabei variabel sein, also auch xyz2 oder xyz3 sein 
können.

Autor: sven (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich habe den Befehl gefunden.
Für die, die es wissen möchten:
=INDIREKT(A1&"!B2")

Damit ist die Fragestellung beantwortet!
Vielen Dank =)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.