mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Wiport and µC


Autor: Flo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
HI

Hab mir einen Wiport zugelegt, und möchte über diesen gerne die
serielle Schnittstelle meines mega32 auf den PC übertragen…
http://www.lantronix.com/device-networking/embedde...

Hab irgendwo gelesen, dass ich für diesen Signale im bereich von +- 3,5
V brauche, aus dem datenblatt kann ich allerdings erkennen, dass ich den
ganz normal (direkt) an meinen mega 32 anschließen kann

Ist es möglich, einfach nur rxd? txd? direkt anzuschließen?

Vielleicht hat ja schon wer Erfahrungen mit diesen teilen, und kann mir
da weiterhelfen

Flo

Autor: Der inoffizielle WM-Rahul (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ja, so habe ich das Datenblatt auch verstanden.
Der WiPort ist wie der XPort in erster Linie nur eine "verlängerte"
serielle Schnittstelle.

Autor: Flo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sehr gut...

dann sind wir wenigstens schon 2...

werde das ganze heute abend mal ausprobieren, und meine Erfahrungen mit
dem Teil posten...

Hätte gestern zwar schon versucht, den port zu initialisieren (über
WLAN) was allerdings an der WPA Verschlüsselung meines netzes
gescheitert ist, aber auch das kann man ja ausschalten...

einstweilen thx für die Mühe

greets flo

Autor: someone (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der wiport kann wpa bzw. er sollte es mit aktueller software können.

Autor: Flo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ja dass schon, aber ohne key wird er in das netzt wohl auch nicht rein
kommen, und mir ist es lieber mittels der installer Software und der
web Oberfläche zu konfigurieren, als über die serielle...
soviel ich gelesen habe sollte das ja kein Problem darstellen...

und die Verschlüsselung ist dann ja später auch noch einstellbar

Weiß jemand ob es reicht, nur einen von 2 3,3 V
Versorgungsspannungsports anzuschließen, und auch nur einen von ich
glaub 7 gnd ports, oder sollte ich auf Nummer sicher gehen, und alle
anschließen?

Autor: Flo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
OK also man MUSS alle grn bzw Vss anschlüsse am stecker belegen, dan
funktioniert das ding einwandfrei und wirklich ohne probleme...

greets flo

Autor: someone (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
nur so als anmerkung, du kannst die keys auch auf dem gerät fest
einstellen

Autor: mr.chip (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

Interessantes Gerät, diese WiPort. Nun eine Frage: Welche Protokolle
müsste man auf dem angeschlossenen Mikrocontroller noch implementieren?
Kann der WiPort direkt UART-Daten z.B. an einen TCP/IP Port schicken?

Gruss

Michael

Autor: someone (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, das geht.

Autor: Werner B. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Marco S. (masterof)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
man kann damit ein Webserver zur verfügungstellen.
Einfach den WiPORT so einstellen das der weiter geleitet port auf 80
Liegt und dan muss der atmega nur noch den Haeder und die Html und
evntuel noch bilder liefern.

Autor: mr.chip (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wow! Und wo kriegt man das Ding? So ganz billig ist es ja nicht ;-) -
Aber wenn man vergleichbare Funkmodule vom C anschaut, dann geht der
Preis in Ordnung...

Autor: Marco S. (masterof)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
www.segor.de

da bit es auch den XPORT der ist etwas billiger der kostet nur 65euro.

Autor: der inoffizielle WM-Rahul (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
[Witz]
>da bit es auch den XPORT der ist etwas billiger der kostet nur
>65euro.

Ne Antenne von nem alten Kofferradio dran, und schon ist der WiPort
fertig...

[/Witz]

IMHO ist der WiPort die preiswerteste Methode, einem Mikrocontroller
ein WLAN-Interface zu verpassen.
Von der restelichen "Handhabung" her, dürfte er sich analog zum xport
verhalten.

Autor: Flo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hi!

ist jetzt zwar ne weitere blöde frage, aber ich verzweifle
schönlangsam...

entweder es passt was mit meeinem wi port, oder ich schließe das ding
permanent falsch an....

kann mir wer helfen, an welche leitungen ich den bei meinem mega 32
anschließen muss, um einer serielle verbindung herstellen zu können,
oder brauch ich da noch einen zusätzlichen adapter?

bzw. kan vielleciht wer einen erfahrungsbericht posten, wie er das mit
dem wiport oder auch dem xport gemacht hat?

greets flo

Autor: Marco S. (masterof)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du must den den Dataout an den RX am mega32 anschliesen
und den Datain an TX. Und dein Programm mus die UART verwenden.

Autor: Bastian Stahmer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Ich hab mich dummerweise aus meinem WiPort ausgesperrt indem ich im
Web-Interface Ethernet als aktive verbindung ausgewählt habe. Mir
gelingt es jedoch nicht, über Ethernet drauf zuzugreifen obwohl ich
mittlerweile bestimmt schon 10x mein Platinenlayout mit den
Datenblättern etc. verglichen hab. Daher jetzt der Versuch über die
serielle Schnittstelle:

Hat jemand von euch schon mal versucht, den WiPort per Serieller
Verbindung zu konfigurieren?
Angeblich soll man in das Konfigurationsmenü gelangen, wenn man beim
starten/resetten des WiPorts "xxx" eingibt, bzw "x" gedrückt hält.
Das klappt leider nicht bei mir :-(
Als Pegelwandler verwende ich einen Max202cse, ob der vielleicht mit
den 3,3V vom WiPort probleme hat?

Gibt es ansonsten eine Möglichkeit, den WiPort in den
Auslieferungszustand zurück zu versetzen?
Ich hab gesehen, dass man die Configurable Pins als "Reset to
Default" belegen kann... ...über das Webinterface... Das hilft mir nur
ja leider in meiner jetzigen Situation nicht viel :-(


Wäre für Anregungen dankbar,

Bastian.

Autor: Profi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Den XPort habe ich schonmal über die Serielle konfiguriert. Hat auf
Anhieb funktioniert.

Welches Terminalprogramm verwendest Du am PC?
Du musst auf jeden Fall Handshake auf  Off  oder  None  einstellen, da
keine HandshakeLeitungen angeschlossen sind.
Empfängt der Wiport die Signale, auch mit der richtigen Baudrate?

Autor: Bastian Stahmer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Ich habs mit einem Terminalprogramm von CCS (PIC Compiler-Hersteller)
(siow.exe) und Hyperterminal versucht, Schnittstelleneinstellungen wie
im PDF beschrieben 9600baud, 8N1, Handshake aus.
In Ermangelung eines Oszilloskops kann ich das mit dem Empfang leider
nicht nachprüfen oder sollten die beiden Status-LEDs des WiPorts auch
bei Verkehr auf der seriellen Schnittstelle blinken?

Eine Fehlermöglichkeit, die ich gestern noch nicht in Betracht gezogen
hatte war der Max202cse, den ich verwendet hatte, der kann nämlich nur
5V, ist aber mittlerweile gegen einen max3232 ausgetauscht, der sich
auch auf 2,0 - 5,5V versteht.


Bastian

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.