mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Probleme mit Breadboard


Autor: Dirk Schlage (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
Ich bin gerade dabei einen Akkuentlader mit einem AVR aufzubauen.
Ich möchte dabei einen Akku über einen Widerstand entladen, bis seine
Spannung auf 1 V abgesunken ist, und währen des Vorganges die
Ladungsmenge aufsummieren.
Einen Teil der Schaltung habe ich auf einem Breadboard aufgebaut.
Momentan noch ohne Transistorschalter.
Die Zelle ist eine geladene 2100 mAh NiMH, sie hat eine
Leerlaufspannung von 1.35 V.
Der Entladewiderstand liegt einfach parallel zum Akku und hat 2.7 Ohm.
Jetzt habe ich mit dem Mikrocontroller teilweise sehr niedrige
Spannungen am Pluspol des Akkus gemessen. Ich habe die Schaltung
überprüft, dann mit dem Vielfachmessgerät nachgemessen und
festgestellt, dass trotz Entladestrom von ca. 100mA, die
Batteriespannung nicht einbricht, wenn ich direkt an den Polen der
Batterie messe. In meiner gesteckten Schaltung sind aber ausser dem
Widerstand noch drei Steckbrücken, an denen teilweise 0.3V abfallen.

Bisher hatte ich kaum Zweifel an den Steckbrettern, aber nun bin ich am
Zweifeln. Resultiert der hohe Spannungsabfall aus dem relativ hohen
Strom von 100mA und alles wird besser, sobald ich gelötete Verbindungen
habe?

servus
    Dirk

Autor: Frank (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
löte es einfach und du wirst es sehen. Wie faul kann man eigentlich
sein?

bye

Frank

Autor: Dirk Schlage (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich pflege das vor mir selbst immer mit einer Mischung aus
Umständlichkeit, Faulheit und Dummheit als Begründung zu
Rechtfertigen.

Ich setze mich dran.

ciao
    Dirk

Autor: Uwe Nagel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sorge einfach dafür, dass der Entladestrom **nicht** über die
Messleitungen fliesst. Da hilft vielleicht schon die Krokostrippen zum
Akku anders anzuklemmen (ja, ich kenne das Problem...).
Oder du führst 4 Leitungen zum Akku, 2 an den Widerstand und 2 zum
messen.

Uwe

Autor: Dirk Schlage (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Uwe
Danke, für den Hinweis, jetzt ist mein einziger Batteriehalter für AAs
schon in die Schaltung eingelötet. Aber ich glaube, ich habe den
Hinweis verstanden, und hoffe, dass ich daran denke, wenn ich ein
ähnliches Problem habe.

Draussen ist ein Bombenwetter, und ich hocke hier in der Bude...

Die gemessene Batteriespannung beträgt jetzt 1.26 V an 2,7 Ohm sind das
460mA der Widerstand ist für 2 Watt.
Ich habe momentan noch eine gesteckte Verbindung zwischen dem
Batterie-Plluspol und dem Widerstand. Ich wollte eigentlich einen pnp
im TO-92 Gehäuse einsetzen, aber momentan fliessen 460 mA durch den
zusätzlichen Wiederstand durch die 0.2V werden zwar dann etwas weniger
Amps fließen, aber mein Standard-TUN hatt im Datenblatt 200mA als
Collector-Stom stehen. Jetzt werde ich es wohl mit einem BUZ11
probieren. Leider gelötet und nicht gesteckt. Ich hätte das Ganze viel
lieber auf dem Steckbrett ausprobiert.

Dirk

Autor: Dirk Schlage (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Danke nochmal,
jetzt muss ich nur noch die Software schreiben.

Anlage - ein Photo von dem Board.

Dirk

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.