mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik 74LS90 Problem mit Zählerzuständen


Autor: David S. (scotty77)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe ein Problem mit den Signalausgängen des 74LS90.

Es geht um eine Zählerschaltung welche Impulse Zählen soll, dies möchte
ich mit dem 74LS90 realisieren und nachher über einen 74LS47 auf einer
7Segmentanzeige ausgeben.

Mein Problem dabei ist jetzt, wenn ich den Baustein 74LS90 wie im
Dateianhang abgebildet anschließe, bekomme ich keine Signalausgänge
(QA, QB, QC, QC), d.h. wenn z.B. 2Impulse an CKA angekommen sind,
sollte ja an QB ein High Signal stehen (BCD 0010). Es tut sich aber gar
nichts, egal wieviele Impulse ankommen.

Die TTL Spannungsversorgung habe ich über einen 7805 Stabilisiert.

Was mir aufgefallen ist, wenn ich an CKA noch nichts angeschlossen habe
kann ich dort eine Spannung von c.a. 1,3 Volt messen!?

Oder kann es sein das ich den Baustein falsch angeschlossen habe, wenn
ja wie wird er richtig angeschlossen, oder muss ich was bei meiner
Spannungsversorgung beachten?

Ich benutze ein Labornetzteil von Statron:

Typ           3231.1
Kurzdaten   0 - 32V / 0 - 6,4A Anzeigen digital
Beschreibung   Labor - Gleichspannungsregler
Anzeigen   3½-stellige LCD 13mm für Spannung und Strom,LED für CV und
CC
Eingangsspannung   230VAC 50-60Hz
Trennung Eingang/Ausgang   galvanisch getrennt, erdfrei
Ausgangsspannung   0... 32VDC
Ausgangsstrom   0... 6,4A

Autor: Jens Kielmann (digger71)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Schaltung sieht o.k. aus, ich tippe mal darauf das der Zähler mit
dem Eingangssignal nichts anfangen kann.(Spannung,Impedanz).
Wo kommt denn VCO her ?

gruss digger

Autor: Dietmar (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@David:

Das gleiche Netzgerät besitze ich, ist vom großen "C" aus den 1990-er
Jahren und für den Hobby-Bereich recht brauchbar, für ein ernsthaftes
Labor allerdings nicht (die Stellpotis sind mäßig gut für den
regelmäßigen Betrieb, da Billigstpotis, mechanisch grob schleifend,
eigentlich Trimmer, aber das sieht man erst nach der Bestellung viel
später so :-().

Immerhin, kann man es aber provisorisch mal als Ladegerät für eine im
Winter ausgefallene alte Autobatterie verwenden (Spannungsbegrenzung
13,8 V, Strombegrenzung über lange Zeit etwa 3 A, da sonst sehr hohe
Temperatur der Regeltransistoren).

Ist die Strombegrenzung vernünftig eingestellt?

Jetzt nochmal die Pinbelegung des 7490, aus einem alten Datenbuch:

Pin 1  --> Clock 1, Verbindung mit Ausgang Q0 = Pin 12
Pin 2  --> MR1, Low-Pegel
Pin 3  --> MR2, Low-Pegel
Pin 4  --> NC, = frei lassen
Pin 5  --> + 5 V
Pin 6  --> MS1, Low-Pegel
Pin 7  --> MS2, Low-Pegel
Pin 8  --> Q2, Ausgang
Pin 9  --> Q1, Ausgang
Pin 10 --> Masse
Pin 11 --> Q3, Ausgang
Pin 12 --> Q0, Ausgang
Pin 13 --> NC, = frei lassen
Pin 14 --> Clock 0, Takteingang

Stromaufnahme 74LS90: 9 mA
Min. Taktfrequenz FF 2-4: 16 MHz

Zählen tut der Baustein, wenn Pins 2 und 3 nicht auf High liegen, also
an Masse. Das wäre bei dir das Signal "High Signal zum Reseten". Ich
vermute mal, daß dies nicht auf Low liegt. Pins 6 und 7 liegen schon
richtig an Masse.

Die NC, not connected, Pin 4 und 13, sollen ganz offen bleiben.

>Was mir aufgefallen ist, wenn ich an CKA noch nichts angeschlossen
>habe kann ich dort eine Spannung von c.a. 1,3 Volt messen!?

Das ist nicht besorgniserregend, und durch die interne Schaltung der
LS-TTL bestimmt, die den Eingang ohne äußere Beschaltung in Richtung
High-Pegel zieht.

Bei einem Rechtecksignal an Pin 14, welches den TTL-Spezifikationen für
Eingangsspannungen an LS-TTL entspricht (LOW kleiner oder gleich 0,8V,
High größer oder gleich 2,4V), solltest du wenigstens mal an Pin 12 ein
Signal der halben Eingangsfrequenz erhalten.

Gruß

Dietmar

Autor: David S. (scotty77)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bin erst am Montag oder Dienstag wieder im Labor, dann werde ich das mal
mit den Pins 2 und 3 an Masse probieren ...

Zum VCO:
Den habe ich aus dem Buch Oszillator-Praxis von Nührmann nachgebaut ...
Dieser wird mit einer +/-12 Volt und GND Gleichspannung versorgt, am
ausgang bekomme ich ca. +/-Ub in entsprechend veränderbarer Frequenz.

So melde mich dann wenn ich es am Mo. oder Die. getestet habe ...
Danke erstmal für die schnelle Hilfe und schönes WARMES Wochenende
hechs

David

Autor: Jadeclaw Dinosaur (jadeclaw)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
+-12V ist nicht gerade TTL-Pegel. Entweder ist der Oszillatorausgang
strommäßig zu schwach, um den TTL-Eingang sauber auf 0 zu ziehen, oder
er ist zu stark, dann ist der TTL jetzt im Eimer. Mach dir mal Gedanken
über einen Impedanz/Pegelwandler. Geht evtl. schon mit einem
Transistor.

Gruss
Jadeclaw.

Autor: David S. (scotty77)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die +-12V benutze ich nur bei dem VCO und der arbeitet mit OP's, welche
bis 32V aushalten ... Es geht ja hauptsächlich um den Zähler ...

Autor: Peter Dannegger (peda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es ist völlig wurscht, womit der VCO arbeitet, er muß und darf nur
0V/+5V ausspucken, darauf kommts an !!!


Peter

Autor: Dietmar (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Recht so, der 7490 darf am Eingang nur TTL-Spannungen erhalten, sonst
Latch-Up-Gefahr.

Nührmann: Den hab ich auch zur Verfügung, ist für viele Zwecke ein
geniales Nachschlagewerk.

Gruß

Dietmar

Autor: David S. (scotty77)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Soooooo,

Also, habe es dann jetzt doch hinbekommen, es war folgendes:

Mit den TTL Bausteinen 74LS90 hat es nicht funktioniert, aber mit den
7490, so stand es zumindest auf den Chip's drauf, warum auch immer!?

Da ich aber von diesen nur 2 zur verfühgung habe werde ich das ganze
jetzt mit CMOS Bauteilen HEF4518BP machen, sind auch einfacher zu
verschalten und haben jeweils 2 Counter in einem Chip ...

Ich bedanke mich dann mal bei euch für die schnelle Hilfe und hoffe das
es mit den CMOS besser funktioniert, wenn nicht melde ich mich wieder
:-)

Gruß David

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.