mikrocontroller.net

Forum: HF, Funk und Felder WLAN Antennenanschluss


Autor: Frank F. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo.
Ich habe hier einen alten WLAN adapter (T Sinus 130 data). Leider hat
das din eine richtig schlehcte reichweite...(im gebäude viel. 10m) und
jetzt hab ich mir gedacht, da kann ich doch sicher eine andere antenne
anschließen...also hab ich das ding mal aufgemacht und habe einen
anschluss gefunden (siehe anhang). allerdings bin ich mir nicht sicher,
ob das ein antennenanschluss ist...und wenn es einer ist, was für ein
gegenstück muss ich dazu kaufen ?


Gruß, Frank

Autor: Frank F. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hab grad noch entdeckt, dass über dem anschluss noch lötaugen frei
sind...das sieht aus, als könnte man da noch einen stecker anchrüsten,
aber die standasrt SMB-Einbaubuchse haben doch 4 eckkontakte und 1nen
mittelkontakt!? und nicht nur 2 eckkontakte !?

Autor: Jörg S. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schau dir mal die U.FL oder H.FL Stecker/Buchsen von Hirose an.
Vielleicht passt da was.

http://www.hirose-connectors.com/catalog/pdf/04.pdf

Autor: Frank F. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo. Ich hab jetzt eine richtantenne an das teil angeschlossen, jedoch
fast keine änderung bemerkt. muss ich da viel noch was an der platine
umlöten um von der antenne die auf der platine ist auf den externen
antennenanschluss umzuswitchen ?

Gruß

Autor: Michael Wolf (mictronics) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Problem kann das Bauteil sein was mit U7 gekennzeichnet ist. So wie
ich das sehe geht einmal die interne Antenne dort dran, und auch die
Antennenbuchse.
Es könnte sein, das dieses Bauteil zum umschalten zwischen den Antennen
dient. Wenn dem so ist, kann es sein, das die Antennenbuchse im Moment
wahrscheinlich garnicht benutzt wird.

Gibts ein Browser Setup für das Gerät, wo man vielleicht die Antennen
umschalten kann?

Ansonsten die Pins von U7 mal messen, ob irgendwo Logikpegel drauf
liegen, bzw. die Leitungen verfolgen ob eine an den Controller geht.

Autor: Christian Schoch (kriki)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Bauteil mit der Kennzeichnung U7 (Marking S79) ist ein
Antennenswitcher.

Mehr zu dem Ding und Datenblatt gibts unter
http://www.skyworksinc.com/products_detailpop2.asp?pid=7121

Also ich würd mal schauen, ob der wirklich auch auf die externe Buchse
umschaltet. (standardmäßig würd ich behaupten nein)

mfg Kriki

Autor: mc.emi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
bei meiner PCI karte im PC war der empfang extrem schlecht - mit dem
laptop mit einer PCMCII-karte hervorragend. die lösung für einen etwas
besseren empfang (ein paar db) für die PCI-karte war, dass ich diese in
alufolie einpackte...

Autor: Frank F. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
sieht in der tat so aus, als ob der auf die externe antennenbuchse
umschalten...laut datenblatt ist nämlich ein ausgang der rechte, und
der geht auf die ext. antennenbuchse.
hab mir grad mal die anleitung runtergeladen...und natürlich steht
nichts darüber drin..aber irgendwie muss man des doch umswitchen
können, sonst hätten die sich ja die bauteile sparan können!?

Autor: Michael Wolf (mictronics) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Kriki

Wie bist Du auf das Datenblatt gekommen bzw. den Hersteller?

Autor: Axel R. (axelr) Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kanst ja mal einen OSZI an die Steuerpins (PIN4+6) vom Switch legen.
Dann kannst Du sicher beobachten, dass/ob der Switch hinundher
schaltet.

Autor: Hauke Radtki (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
zur not einfach mal gucken welche pegel der braucht und selbst dran
hängen.

Autor: Frank F. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hi michael...ich bin auch schon über das datenblatt gestolpert...hatte
bei google nach s79 und wlan gesucht und irgendwo gabs da auch n
datenblatt.
Also ich hab in der zwishenzeit mal die pegel an dem ant. switch
gemessen und rausbekommen, dass der switch immer auf der internen
antenne steht. Da ich zwischenzeitlich auch herausgefunden hab was da
sonst so für ics drauf sind und dass die platine auch noch in anderen
wlan mod. verwendung findet, denk ich, dass die antenne von dem
Hauptprozessor umgeschatlen wird (also firmwareabhängig). Da ich die
firmaware nicht ändern kann, hab ich einfach die alte chip-antenne
ausgelötet und meine richtantenne dran gemacht. Leider hat das fast
keine verbesserung gebracht. Hat noch jemand einen tipp ? in der
anleitung (http://www.vallstedt-networks.de/?Fotogalerien/Quad) stand,
dass ich 16 mm abstand brauch...den abstand hab ich nicht genau
eingehalten, sin ca 17mm. ist das so schlimm ? und als verbindugnskabel
hab ich ein coax-kabel (ca 8cm) genommen. (ist das auch ok?)

Gruß, Frank

Autor: Michael Wolf (mictronics) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also wenn du so eine Quad richtig nachgebaut hast sollte es auf jeden
Fall eine Verbesserung bringen. Ich hab sowas mal fürs E-Netz gebaut um
den Handyempfang zu verbessern, die hat super funktioniert.

Ob die Quad allerdings anstatt der Chipantenne eine Verbesserung bringt
ist eine Frage der Anpassung. Möglicherweise ist hinter dem
Antennenswitcher noch eine Anpassglied, was mit der Quad zu
Fehlanpassung führen kann.

Probier doch mal, ob du den Antennenswitcher mit fixen Logikpegeln
umschalten kannst. Also das Signal vom Prozessor trennen, und selbst
einen Pegel anlegen. Dann probier die Quad an der Koaxbuchse, bzw. den
Lötaugen.

Autor: Hauke Radtki (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also ich hab mir das Ding auch gebaut und die maße auch nur "grob"
eingehalten ... funzt auf jeden fall um einiges besser als die olle
kleine stabantenne. Dabei bin ich auch zu faul sie exakt auszurichten.
Das mit der Anpassung kann gut sein, da so ne kleine platinenantenne
nich so das optimum darstellt.

Autor: Frank F. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ok...werd ich morgen gleich mal versuchen...wird zwar schwer des mit
meinem lötkolben hinzubekommen aber versuchen kann ichs ja mal.

Autor: Unbekannter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich glaube kaum, dass die interne Antenne die gleiche Impedanz wie die
externe hat. Von daher verwundert es micht nicht, wenn es keine
Verbesserung bringt. Du solltest schon an die Systemimpedanz anpassen.
Also Smith Diagramm rausholen und los geht's. ;-)

Autor: Frank F. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hab jetzt den s79 von der platine runter gelötet und mit nem draht ne
brücke zu der externen antenne gelötet...und jetzt hats gleub ich
wirklich ne verbesserung gebracht. Muss mein laptop nur noch aufladen,
damit ich ne runde laufen kann und sehen obs wirklich was gebracht hat.
kann ich eigentlich irgendwie den antennengewinn messen ?

Autor: Jörg S. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es gibt WLAN-Sniffer die sowas können, ja. Mir fällt nur gerade der Name
nicht ein.

Autor: Jörg S. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es müsste Netstumbler gewesen sein:
http://www.netstumbler.com/

Autor: Frank F. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
netstumbler hab ich scho...und damit kann man auch gut die signalstärke
verfolgen. aber ich traue den werden nicht ganz, weil die bei jedem
wlan modul anders sin und die signalstärke doch eigentlich gleich ist.

Autor: Frank F. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
aber besonders viel hat das teil bis jetzt au nicht gebracht. ich komm
nur n paar meter weiter als vorher...ahb ich noch irgendwas falsch
gemacht...hab hinter dem bi-quad noch n alu-folien reflektor
angebracht...hat auch nochmal ein wenig gebracht...aber irgendwas läuft
noch nicht so ganz

Autor: Hauke Radtki (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist dein Kabel gut geschirmt? Und dir ist shcon klar, dass das ne
richtantenne ist oder?

Autor: Frank F. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, ich weiss, dass das ne richtantenne is und das kabel is irgendein
coax kabel, dass ich im keler gefunden hab...aber es ist eh nur ca 8cm
lang ist denn da die schirmung so kritisch ?
Jetzt kann ich mein laptop schon im wohnzimmer beutzen (paar meter
weiter als früher) aber im garten gehts immer noch nicht (ca. 3 meter
weiter als das wohnzimmer)
und im keller schon garnicht. könnt ich durch ein besseres kabel noch
ein paar dbi rausholen ?

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
"Irgendein Koaxkabel" - das kann durchaus das Problem sein. Wenn
dessen Impedanz nicht stimmt und es auch noch -ohne Dir dies
unterstellen zu wollen- suboptimal angelötet ist, dann kann das sehr
wohl jeden Antennengewinn zunichtemachen.
HF mit 2.4 GHz ist etwas komplizierter als -sagen wir mal- eine
UKW-Antenne.

Autor: Axel R. (axelr) Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das wollte ich vorhin schon schreiben...
Ist schliesslich kein CB-Funk.
Willst Du uns ein Foto von der Karte zeigen, wie sie jetzt belötet
ist?
Und vlt. eines von der Antenne?
Die Leistung, die Du zur Verfügung ist derart gering und die
Freifelddämpfung bei der Frequenz derart hoch, das es auf JEDES db
ankommt. Wie lang ist dein Antennenkabel? 8cm - ich weiss. Wenn Du Dir
da mal keine Impedanztransformation eingfangen hast. Jedenfalls passen
8cm ziemlich genau ins Wellenraster Lamda viertel oderso(Weiss ich
jetzt aber nich genau)

300.000km/2.45Ghz= 12.245cm Wellenlänge
12.245 x 0.66 (Verkürzungsfaktor fürs Kabel, üblicher wert)=8.08 cm.
Bei Lambda ganzes sollte aber nichts passieren.
Hast Du SAT-Kabel verwendet?

Wenn Du aus dem Berliner Raum kommst, könnte ich Dir anbieten für eine
Flasche Bier S11 deiner Antenne zu messen und zu korrigieren, also die
50Ohm Anpassung bei dieser Frequenz. Normgerechter Antennenstecker wäre
allerdings Vorraussetzung. Aber der ist ja eh auf der Karte. Hast Du
diesen auch verwendet? (Sicher nicht- hast das Kabel direkt angelötet,
oder?)

Viele Grüße
AxelR.

Kannst mir auch ein Päckchen schicken ;-))

Autor: Hauke Radtki (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Pass auf dann schickt der dir ne leere flasche Bier ... das kennt man
doch aus der Werbung ...

Autor: Frank F. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
also ich geb ja zu, das das ganze mit meinen mitteln nicht ganz so
sauber geworden ist...aber seht selbst. (anhang) auf dem bild von der
nahaufnahme vom coax kabel könnte man denken, dass der kleine draht
einen kurzschluss verursacht, dem ist aber nicht so.
Meint ihr ich sollt mir ein professionelles kabel zulgen und wenn ja,
bekomm ich das bei reichelt ?

Autor: AxelR. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Frank,
vielen Dank für deine Mühe. Die Fotos sind echt gut geworden.

Die Lötstellen sind alles in allem ok. Was dir fehlt ist einfach etws
Erfahrung auf dem Gebiet der hohen Frequenzen. Aber genau dafür ist das
Forum ja da.

Die Drahtbrücke ist zwar von hohem ästhetischen Anspruch, aber das sind
hier schon ein paar Nanohenry zuviel an Induktivität. Ich empfehle,
diese halbe Windung durch ein sehr kurzes Stückchen 0.2 CuL zu ersetzen
(direkte Luftlinie).
Am koaxkabel:
Die Seele nur max. 2mm herausschauen lassen.
Die Abschirmung weitere 2-4mm freilegen (Schwarze Isolierung mitm
skalpell entfernen. Hier wickelst Du dünnen blanken Kupferdraht
ordentlich um das vorhandene Geflecht und lötest diesen Draht dann
ebenfalls sehr kurz an den Massenkontakt deiner Karte.
An der Antennenseite analog dazu.

Den Draht mittig nehmen und ein paar Windungen aufs Geflecht. Dann hast
Du quasi zwei Enden, die dann in die beiden "Masselöcher" rechts und
links von der nicht vorhandenen Buchse eingelötet.

Habe heute tagsüber leider keine Zeit, melde mich heute abend
nochmal, lese aber mit.

Gruß
AxelR.

Autor: Frank F. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also ich hab mir heut eine neue antenne gebaut... diesmal mit einer
Platine als reflektor. Die Anschlüsse des Coax kabels hab ich auch
kürzer gemacht. Die Brücke Hab ich vorerst drin gelassen...war schon
schwer genug die so hinzubekommen. Oder sollt ich sie lieber doch
wieder raus machen und versuchen irgendwie die direktverbindung
hinzubekommen...?
Jetzt konnt ich glaub ein wenig herausholen...ein paar meter weiter
funktioniert das teil jetzt. Aber ich glaub da müsste immer noch was
drin sein. Meint ihr ich sollte das coax kabel gegen ein besseres
austauschen...(wo bekomm ich denn so ein kabel in kleinen mengen her?
so n meter viell.)

Autor: Axel R. (axelr) Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vlt. ist es ja schon gutes Kabel, wer weiss?
Manchmal steht was drauf...

Was ich beim Lesen eben bemerkt habe:
Den Draht nicht nur ums Geflecht wickeln, sondern auch dort anlöten.
Aber war klar, denke ich.
Alles was aus dem Kabel rauskommt, RICHTIG kurz und das Geflecht
Großflächig an Masse. Der Strom darf nicht "merken", das das Kabel zu
Ende ist. (Oh, sehr bildlich gesprochen)

Nebenbei wens interessiert:

wenn man nun garkeine Messtechnik hat (auch nichts zu Hause):
ich habe mir so einen VideoSender mit IR-Verlängerung zugelegt. Damit
teste ich die Antennen. Sieht masn sofort am TV, was Sache ist. In die
Antennenzuleitung habe ich aus einem alten (gaanz alten) Motorola Handy
eine Reflexionsmessbrücke "ausgebaut" (mit der Laubsäge). So lässt
sich sogar die Antenne grob abstimmen.

Oder eben auf Arbeit - da habe wir glücklicherweise Messtechnik, die
dafür geht.

Autor: bastler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
kannst du dass mit der messbrücke bitte näher beschreiben ?

Autor: AxelR. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ist aus einem Motorola 1000 (D-Netz Knochen) von 1991.
Ein Stückchen Platine mit 50Ohm Impedanz Streifenleitung und parallel
dazu ein kleiner, dünnerer Leiterzug. Das eine Ende des dünneren
Leiterzuges ist mit 100Ohm gegen Masse, am anderen Ende sitzt eine
kleine HP-Shottky Diode (und ein kleines C auf jeder Seite). Dort kann
man die Spannung der rücklaufenden Welle abgreifen.JE nach dem , wierum
man die Platine einbaut, auch die abgehende Leistung.
Das ganze habe ich mit RG316 und entsprechenden SMA-Buchsen und
Steckern versehen und dort an Stelle der Originalantenne
angeschlossen.
Wenig Zinn, 50Ohm Imoedanzverhältnisse beachten und -wichtiger-
einhalten ist Bedingung. Sauberes Arbeiten ist hier Grundvoraussetzung.

Muss mal sehen, wie weit meine neue OLYMPUS-810 im Supermakro rangeht,
dann kann ich ja mal ein Foto machen.
Die ausgesandte Leistung des AV-Senders reicht aus, um ein 50µA
Messwerk anzusteuern. Ist nicht supergenau, reicht aber zum spielen
aus.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.