mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik JTAGICE mkII : IDR event 0xff ?????


Autor: Neubi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hey,


bin einem fehler auf der spur und bekomme beim debuggen den fehler
"JTAGICE mkII: IDR event 0xff."

-> in der avrstudio-hilfe finde ich nur : "Enable I/O Debug Register
(IDR) in run mode". When checked this allow parts which share the same
I/O location for IDR/OSCCAL to output IDR events. IDR events are
generated when the application writes to the IDR register.

... das sagt mir jetzt genau GAR NICHTS ....


hat jemand eine ahnung was das sein kann ?


thx
Neubi

Autor: Holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Forum,

das gleiche Problem habe ich auch. Am alten PC haben meine Programme mit 
dem Debugger und JTAGICE mkII funktioniert, dort hatte ich eine etwas 
älter Studio-Version. Habe jetzt einen neuen PC. AVR Studio ist auch neu 
installiert mit neustem SP. Beim Debbugen wechselt mein µC fast sofort 
in den Sleep Mode und ich bekomme die Meldung "IDR event 0xff".
Der USART funktioniert auch nicht mehr (war am alten PC schon getestet).

Ich hoffe mir kann jemand helfen. Ich bin ziemlich ratlos.

Autor: Holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ok, mein System läuft wieder in der folgenden Konfiguration:

Hardware STK500 und JTAGICE mk II über USB.

AVR Studio 4.13 SP2 b 571 und WinAVR-20060421. Keine Fehlermeldungen, 
keine runtime errors.

Die Konfiguration

AVR Studio 4.12 SP1 b 498 und WinAVR-20071221 bricht beim Start in den 
Debug-Modus mit einen runtime error ab.

AVR Studio 4.13 SP2 b 571 und WinAVR-20071221 ergibt das oben genannte 
Problem mit "IDR event 0xff".

Vielleicht kann einem das ja helfen.

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Holger wrote:

> AVR Studio 4.13 SP2 b 571 und WinAVR-20071221 ergibt das oben genannte
> Problem mit "IDR event 0xff".

Seltsamerweise aber auch nur bei dir (und vielleicht ganz wenigen
anderen).

Könntest ja auch mal das 4.14-Beta von AVR Studio probieren.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.