Forum: Mikrocontroller und Digitale Elektronik FT232H im sync FIFO Mode


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Cdefg X. (siny)


Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Ich beschäfftige mich gerade einwenig mit dem UM232H. Ich habe im EEPROM 
und via D2xx Treiber die SYNC FIFO Mode aktiviert. Am Pin AC5 sehe ich 
nun ein 60MHz Signal. Allerdings ist dieses einwenig anders als ich 
erwarten würde:
Ich sehe am OSzi ein sehr wackeliges 1,5V + 0,5V Sin Signal.  Ich würde 
eher ein Rechteckförmiges Signal erwarten, oder zumindest, das der Sinus 
von 0V bis 3,3V geht.

Ist das bei euch auch zu beobachten?

von user (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Wieviel Bandbreite hat dein Oszi? Wenn es zu wenig hat, kann es daran 
liegen.

von Cdefg X. (siny)


Bewertung
0 lesenswert
nicht lesenswert
Ahh Ja das stimmt .. das Osci hat eine Bandbreite von 50MHz (RIGOL 
DS1052D).

Ich hatte außerdem das UM232H auf einem Breadboard stecken und ich 
scheine mir da noch andere langsamere Frequenzen zusätzlich einzufangen.

Den 245 Datenbus habe ich an das DE2-115 drangehangen. Der FPGA macht im 
grunde nix als im Takt vom UM232H (also die 60MHz) einen 8 bit Zähler zu 
incrementieren. Ja und diesen Wert wollte ich gern lesen.

Mein ergebnisse sehen so aus:


 13 14 14 16 16 18 18 16 20 22 23 24 24 26 26 24 28 30 31 32 32 34 34 32 
36 38 39 40 40 42 42 40 44 46 47 48 48 50 50 48 52 54 55 56 56 58 58 56 
60 62 63 64 64 66 66 64 68 70 71 72 72 74 74 72 76 78 79 80 80 82 82 80 
84 86 87 88 88 90 90 88 92 94 95 96 96 98 98 96 100 102 103 104 104 106 
106 104 108 110 111 112 112 114 114 112 116 118 118 120 120 122 122 120 
124 126 126 130 128 130 130 128 132 134 135 136 136 138 138 136 140 142 
143 144 144 146 146 144 148 150 151 152 152 154 154 152 156 158 159 160 
160 162 162 160 164 166 167 168 168 170 170 168 172 174 175 176 176 178 
178 176 180 182 183 184 184 186 186 184 188 190 190 192 192 194 194 192 
196 198 199 200 200 202 202 200 204 206 207 208 208 210 210 208 212 214 
214 216 216 218 218 216 220 222 222 224 224 226 226 224 228 230 231 232 
232 234 234 232 236 238 238 240 240 242 242 240 244 246 246 248 248 250 
250 248 252 254 254

Wenn man sich die Zahlenfolge anschaut dann glaube ich das mein FPGA 
immer zum richtigen Zeitpunkt auch die steigende Taktflanke mitbekommt. 
Weiterhin  sieht es so aus, als ob das Bit0 sehr oft kippt. Wenn ich nur 
das wahre Signal sehen könne .. schade das mein Oszi das nicht mehr 
packt.

von -gb- (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Massen verbunden? Wie wird das Signal zum Zählen verwendet? Ist das der 
Zähltakt oder eher ein Enable? Mach mal ein Bild und poste den Code.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.