mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Bewegungsmelder geht immer an, warum (Mit Schaltplan etc)


Autor: Mode (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Ich habe hier einen Bewegungsmelder der immer an und ausgeht. Im Moment
ist keine Lampe angeschlossen die Wärme erzeugen koennte. Auch wenn der
Poti fuer die Empfindlichkeit auf ganz unempfindlich gestellt wurde,
schaltet der Melder munter an und aus.

Ich habe mal einen Schaltplan von dem Melder gemacht:
<img
src="http://img387.imageshack.us/img387/451/bewegunsmel...;
border="0" alt="Image Hosted by ImageShack.us" />
(Achtung 1500x1000px - 240kb)
Nun habe ich an Pin 7 vom 4fach OAMP gemessen. Hier sieht man schoen
einen Spannungswechsel wenn man sich vor dem Melder bewegt. Wenn die
Störungen auftreten wird das Signal schlagartig nach unten gerissen.

Nun habe ich R10 ausgeloet und das Signal an Pin7 wird nichtmehr
runtergerissen und verhaelt sich normal. R10 wieder eingebaut.

Die Betriebsspannung ist stabil - auch beim Schalten des Relais

Nun habe ich an R14 gemessen. Hier auch wie erwartet eine Spannung um
2,5V die auf 0 oder 5V auschhlaegt sobald jemand ins Sichtfeld des
Sensors tritt. Auch hier sind die Störungen zu messen. Wenn der Melder
fälschlicherweise Schaltet wird die Spannung auf 5V gerissen. Wenn R14
entfernt wird, und man am Pin 8 vom OP misst, ist die Spannung so wie
gehabt nur ohne Störungen. R14 wieder eingebaut.

Also muss das Problem an IC1A oder IC1D liegen....

Spannung an Pin14 vom OP gemessen. Sobald jemand ins Sichtfeld des
Melders tritt oder eine Störung auftritt, wird der Ausgang kurz von 5V
auf 0V gezogen. C14 ausgebaut und wieder gemessen - das gleiche
Ergebniss - also muss der Fehler bei IC1D liegen. Nun habe ich noch D6
entfernt bzw. T1 C-E ueberbrueckt. Keine Aenderung.


Was kann das sein?

Kann es sein dass IC1D defekt ist? Warum spinnt wenn IC1D angeschlossen
ist die ganze Schaltung?


Ich hoffe, es gibt ueberhaupt jemand der diesen ganzen Text liest.


Gruss und Danke fuer alle Tipps


Mode

Autor: Profi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dasselbe Problem habe ich auch, nur noch nicht untersucht. Inzwischen
ist vom häufigen ein- und aus -trotz Lebensdauerverlängerungs-NTC- die
Birne ausgebrannt. Muss mal hinhören, ob das Relais immer noch klickt ,
d.h. ob es eine Wärmestrahlen-Rückkoppelung ist.

Könnte mir vorstellen, dass es HF-Einstreuungen (LW, MW, KW-Sender)
sind oder der OP-Amp einfache "einen Becker" hat. Evtl. auch die Cs
in der Gegenkopplung untersuchen. Oder Kriechströme durch Feuchtigkeit
auf der Platine --> kurz mit Alkohol und dann mit Aquadest waschen und
gut trocknen.

Meiner ist übrigens kein Baumarkt-Billig-Teil, hab gerade nachgeschaut,
Hersteller steht keiner drauf. Welche Marke hat Deiner?

Autor: Mode (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also meine sind absolute billigheimer aber leider habe ich 8 Stueck von
denen gekauft und erst einen aufgehaengt. Der hat auch 3 Tage
funktioniert nur jetzt macht er diesen Mist. Ich will den Fehler finden
und in den anderen vorsorglich den Fehler eliminieren. Fuer einen Melder
haette ich mir nicht so eine Arbeit gemacht.
Platine sieht ganz gut aus. Was meinst du mit "einen Becker hat"? 324
tauschen? Das werde ich wohl tun muessen.
Ich habe den Fehler ja schon auf IC1D eingekreist. Wenns ein Elko ist,
dann kanns nur C13 sein der sich kurzschliesst. Aber ich tippe eher auf
den 324.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.