mikrocontroller.net

Forum: Compiler & IDEs AVR Problem mit gcc?


Autor: Bastian Nagel (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe ein kleines Problem mit meinem Code.
Das Programm ist eine Uhr, wie der Name ja auch schon verrät. :p
Die Uhrzeit wird ueber einen DCF Empfänfger und dem Code von Ulrich
Rading gestellt, zumindest sollte sie das.
Da ich anfangs Probleme mit dem Emfang hatte wird die Amzeige, bzw der
Timer fuer das Updaten der Anzeige (6x7Seg multiplex) erst nach
erfolgreicher decodierung der Zeit empfangen.
Die Stunden, Minuten und Sekunden sollten jetzt in den Variablen hh, mm
und ss stehen.
Bei den Sekunden funktioniert das auch problemlos, bei den Stunden und
Minuten jedoch nicht.
Der Wert ist auch nach dekodierung des Signals 0, wird jedoch durch den
manuellen Sekunden Update mit weitergezählt.
Was mache ich hier falsch???

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.