mikrocontroller.net

Forum: Platinen PonyProg 2000


Autor: Shadow2708 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zu später Stunde.
Plage mich jetzt schon 2 Tage mit Poniprog herum.
Habe mehrere Prommer zusammengelötet,ohne Brücken oder Kurzschlüsse,auf
geätzten Platinen und sauber aufgebaut, aber PonyProg erkennt mir die
Brenner nicht am par.Port.
Auch die Einstellungen scheinen O.k. zu sein, denn Beim Test sagt er
jedesmal ok.
Auch an der ser. Schnittstelle das gleiche Problem, habe da den Mini
Sercon dran, erkennt keinen AVR, immer nur Fehler.
Spannung liegt an, die datenleitungen sind auch richtig angeschlossen.
Weiss von euch vielleicht jemand, woran es liegen könnte?
Mit PonyProg sollen doch fast alle Brenner laufen.
Am par. Port habe ich im Moment den Atmel AVR ISP.

http://rumil.de/hardware/pics/avrispsc.png

Ich hoffe, es kann mir einer weiterhelfen.

Mfg
Shadow2708

Autor: Telemeckel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Shadow2708

hatte ein ähnliches Problem, hatte dummerweise den 74er Baustein als
"LS" Type verbaut....
Zum Glück mit Sockel. Ein 74HCT244 löste mein Problem.

Gruß, Telemeckel.

Autor: Ritter Knolte II (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Shadow

......du bist im falschen Teil des Forums. Poste - falls noch Fragen da
sind in den "µC - Elektronik" Bereich des Forums. Der Platinen Bereich
ist scheinbar nicht so stark frequentiert, und hat ja letztendlich auch
eine andere Thematik.

 :-))

Autor: Johann Sohl (sodele)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Shadow2708

Serielle Schnittstelle:
PonyProg prüft mit"Probe", ob die Leitungen RTS (7, Eingang) und DSR
(6, Ausgang) miteinander verbunden sind. Mehr sagt die Prüfung nicht
aus.

Ich gehe davon aus, dass du alle Angebote der Schnittstellenzuordnung
(SI-Prog API geht bei mir bei allen Rechnern und Betriebsystemen 98 bis
XP) und Polarity systematisch durchprobiert hast.

Prüfe doch zunächst (am besten mit einem Oszi) die Funktion der Leitung
CTS, ob sie mit einem ausreichenden (etwa 5kOhm) Hochziehwiderstand
versehen ist. Der Widerstand fehlte bei meinem Prommer, im
(offiziellen) Schaltbild "Si-Prog - Serial Interface for PonyProg
Revision 2.2" ist keiner enthalten und bei vielen PCs ist auch keiner
drin (>100kOhm oder floating). Habe mich tagelang mit PonyProg
beschäftigt und dabei halb tot gesucht!

Parallelport: Es geht nur die Standard-LPT-Adresse.

Gruß, Sodele

Autor: Peter Quaiser (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe mich auch tagelang mit einem Atmel-evaluation-board von Pollin
herumgeplagt, bis es lief.
Erstens: Man muss die Verbindung COM1 oder COM2 zu J3 (ISP-Anschluss)
verwenden, nicht zum J6 am RS232-IC.
Verbunden sein müssen die Leitungen 3,4,5,6,7 und 8. Ponyprog liefert
über COMx nicht die RS232-Signale sondern die ISP-Signale.
Zweitens: In der Stückliste sind D1 und D3 vertauscht, der Schaltplan
stimmt.
Das von Pollin für den ATmega16 loadbare Testprogramm läuft auch mit
einem eingesetzten ATMEGA8535.

Viel Glück, Peter

Autor: Andreas Andi (andi_pda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Peter,

ich habe ebenfalls das Board 2.0 aufgebaut und habe es Dank Deiner 
Ausführung auch zu erten Laufen gebracht. Nur mit den Dioden ist mir 
noch nicht alles klar. D1 und D2 sind die 5,1V Dioden, D3-/ die !n4936 
Dioden, sollte doch eigentlich stimmen??

Viele Grüße
Andreas

Autor: E. M a t t h i a s (hias)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo ich habe auch Probleme mit dem AVR_Eval-Board v2.0 von Pollin.
PonyProg erkennt den ISP nicht.
Was habt ihr geändert?
Die Dioden stimmen, auch die Level Anpassung funktioniert. Trotzdem 
erkennt er ihn nicht.

Hias

Autor: romy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich habe bitte eine Frage.
Welleche Spannung kann man am IC-Max232 von Pollin-board messen,wenn die
Versorgungsspannung 6V ist?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.