mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Timer 0 mehrfach verwenden


Autor: Gerd (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich möchte den Timer0 vom AVR4433 mehrfach verwenden, d.h. ich möchte 
den Timer mit verschiedenen Zeiten betreiben.
Am Anfang möchte ich ca 12ms warten. Ich habe also das TCNT0 Register 
mit 00h geladen und den Timer loslaufen lassen. Das macht bei 4MHz 
4,096ms. Das wollte ich 3mal machen.
Meine Frage: Wenn ich jetzt hingehe und gleich danach nochmal das TCNT0 
Register mit 00h lade fängt der Timer doch wieder bei 0 an zu zählen. 
Wie kann man denn das lösen? Ich will also immer auf den Ablauf des 
Timers warten.

Grüße Gerd

Autor: Jangomat (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Timer fängt nach dem Überlauf automatisch wieder bei 0 an.
Lediglich das InterruptFlag wurde beim Überlauf gesetzt. Wenn Du den 
Interrupt erlaubst, wird zusätzlich zum Interruptvektor gesprungen. D.h. 
Du brauchst im Prinzip nur 3 x das Interruptflag zu überprüfen, solange 
bis es gesetzt ist. Danach mußt Du es jeweils innerhalb der nächsten 4ms 
von Hand zurücksetzen und dann wieder warten...

Autor: Gerd (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Jangomat,
das heisst also ich darf nicht Global Interrupt Enable setzen sondern 
nur im TIMSK Register das Overflow Interrupt Enable Bit setzen und in 
einer Schleife das Interrupt Flag überprüfen und wenn dieses gesetzt 
wurde von Hand zurücksetzen. Dann wird ja auch nicht in eine ISR 
gesprungen sondern im Programm weiter fortgefahren.
Ist das so richtig ???

Autor: Jangomat (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Gerd,
Du brauchst nicht einmal das T0IE setzen (wichtig, falls du andere 
Interrupts über das GIE abfangen mußt). Das Interrupt Flag wird immer 
gesetzt, unabhängig vom GIE und dem T0IE, es wird lediglich nicht vom 
AVR-Core beachtet, falls beide Bit nicht gleichzeitig gesetzt sind.

und unbedingt daran denken: Ein Interrupt Flag Bit wird beim AVR 
gelöscht, indem man es mit 1 beschreibt (kurios, aber so ist das - da 
lobe ich mir doch wieder den PIC...)!

Autor: Gerd (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Alles klar ich versuch mich einmal daran.
Vielen Dank für deine Hilfe
Grüße Gerd

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.