Forum: Mikrocontroller und Digitale Elektronik Hameg HMO20xx Encoderproblem


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Olaf (Gast)


Angehängte Dateien:

Lesenswert?

Moin Zusammen,

Vor ungefaehr acht Jahren hab ich mir einen HMO2022 gekauft. Seit etwa 
einem Jahr ist mir aufgefallen das die Encoder anfingen unsauber zu 
laufen. Man merkt das daran der Oszi beim drehen manchmal gar nicht mehr 
dreht, oder auch erstmal in die falsche Richtung. Also typische 
Kontaktprobleme in den Encoder. Das wird mit der Zeit immer nerviger!

Die Encoder selber sind von ALPS aus der Automotive Serie und haben 1k 
als Vorwiderstand. Von daher wuerde ich also sagen alles gute Qualitaet.

Ich hab den Oszi selber privat genutzt. Also sicherlich deutlich weniger 
wie in einer Firma, aber durchaus regelmaessig. Also eigentlich ein 
optimales Nutzungsszenario fuer eine lange Haltbarkeit.

Optimal waere es natuerlich die Encoder austauschen. Ich vermute das die 
drei grossen Encoder Alps EC11E1544504 sind. Die kleinen konnte ich 
nicht identifizieren.
Die Teile sind aber eher exotisch weil es SMD Typen sind mit kurzer 
geriffelter Achse. (siehe Bilder) Man kann da nur sehr schlecht etwas 
anderes einbauen.

Daher hab ich sie gereinigt. Erstmal ordentlich in alle Ritze Kontakt 60 
gesprueht und 30min einwirken lassen. Dabei immer mal etwas bewegt. 
Danach hab ich die Encoder mit grossen Mengen Rivolta SLX1000 behandelt 
um das saeurehaltige Kontakt60 zu entfernen. Das ist sehr wichtig. Auf 
Dauer zerstoert sonst Kontakt60 die Encoder. Dieser Reiniger ist 
rueckfettend sollte also auf den Kontakten im Encoder wieder eine 
Schutzschicht hinterlassen. Danach hab ich dann die Platine mit Kontakt 
LR gereinigt damit die Goldkontakte fuer die Gummimatte sauber ist.

Vor der Reinigung hatten die Encoder so zwischen 15 und 100R 
Schalterwiderstand. Nach der Reinigung sind es so <1R.

Jetzt funktioniert er wieder wie neu. Wie lange wird man sehen...

Olaf

von Olaf (Gast)


Lesenswert?

Tja, leider haelt die Reinigung der Encoder nicht ewig vor. Haette ja so 
schoen sein koennen....

Da ich die Originalencoder nicht bekommen habe, ich vermute das ALPS sie 
nicht mehr herstellt, habe ich andere besorgt.

Das sind PEC11S-9213K-S0015. Die gibt es z.B bei Mouser.

Die sind soweit (Footprint) 1:1 Kompatibel, allerdings ist die 
geriffelte Flaeche wo man den Knopf aufsteckt 2.5mm laenger. Da muss man 
vorher also was absaegen. (Proxon hilft)

Die neuen Encoder sind aber geringfuegig schlechter verarbeitet! wenn 
man sie so einzeln in der Hand hat dann merkt man das nicht, aber 
eingebaut im Oszi ist der Knopf etwas wackeliger und fuehlt sich beim 
drehen auch weicher an.
Vielleicht auch Gewoehnungssache.

Man kann die Originalencoder aber auch zerlegen indem man vorsichtig 
unten die Laschen aufbiegt. Dann kann man die Bahnen wo die Schleifer 
rubbeln saeubern. So funktionieren sie auch wieder. Ich hab jetzt aber 
erstmal die PEC11S drin.

Groesste Herausforderung ist natuerlich das abloeten. Ich hab dazu 
Alufolie auf die Front gemacht, ein kleines Loch an die Stelle wo man 
loeten muss und dann den Encoder mit Heissluft runtergenommen.

Und wo ich die Kiste schon mal auf hatte hab ich auch gleich die 2032 
fuer die interne Uhr ausgetauscht. Die war bei mir auf 2.9V. Das waer 
nicht mehr lange gut gegangen...

Olaf

Bitte melde dich an um einen Beitrag zu schreiben. Anmeldung ist kostenlos und dauert nur eine Minute.
Bestehender Account
Schon ein Account bei Google/GoogleMail? Keine Anmeldung erforderlich!
Mit Google-Account einloggen
Noch kein Account? Hier anmelden.