mikrocontroller.net

Forum: Platinen Versionskompatibilität von Eagle


Autor: Marco Schramm (hochfrequenz)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich besitze eine non-profit Lizenz (alle Module, Platinengröße
unbeschränkt) der Eagle Version 4.09  .

Mittlerweile gibt es ja Eagle Ver 4.1x .

Nun meine Frage: Wenn ich mit der 4.1x Freeware eine Platine (A < 80mm
mal 100mm) erstelle, kann ich diese dann mit 4.09 betrachten?

Wenn ich Platinen fertigen lasse, dann füge ich verschiedene Platinen
(meist je 2 Stück pro "Projekt") zu einem Fertigungsnutzen zusammen,
so daß ich in etwa immer auf 160mm mal 100mm komme. Der
Platinenhersteller betrachtet es als eine Platine und ich schneide sie
erst dann später auseinander.

Könnte ich jetzt mehrere mit 4,1x erstellte Platinen in 4.09
hineinkopieren und dort zusammenfügen? Wie verhält sich das mit den
Bibliotheken?

Oder gibt es elegantere Methoden?

Autor: John-eric K. (mockup)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nein.

die neuen sind bei mir zumindest nicht abwärtskompatibel.

warum kannst du die platinen nicht unter 4.09 erstellen?

mfg
MockUp

Autor: René König (king)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Nun meine Frage: Wenn ich mit der 4.1x Freeware eine Platine
> (A < 80mm mal 100mm) erstelle, kann ich diese dann mit 4.09
> betrachten?

Das geht natürlich nicht. In der neuen Version sind einige neue
Features hinzugekommen, die die "alte" Version eben noch nicht kennt.
Unter einem kompatiblen Mode speichern, wie Du das beispielsweise von
der Textverarbeitung kennst, kannst Du glücklicherweise nicht. Denn
wenn Du, um die Kompatibilität zu wahren, einfach alle neuen Features
herauslässt, gibt es spätestens dann die große Überraschung, wenn Du
die fertigen Leiterkarten in den Händen hälst. Unterschiedliche
Darstellung, wie sie bei der Textverarbeitung vielleicht nicht ganz so
schlimm ist, ist hier schlicht nicht zu gebrauchen.

Die anderen Richtung funktioniert aber problemlos (4.09 -> 4.1x).

Autor: Marco Schramm (hochfrequenz)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo MockUp,

die Bibliotheken sind leider nicht kompatibel. Der größte Teil der im
www. vorhandenen  Bauteilbibliotheken ist für 4.1x "hergestellt" un
damit kann ich sie nicht mit 4.09 nutzen. Zu deutsch: ich muß zu viele
Bauteile definieren. Und da geht immer eine Menge Zeit drauf.


Aber vielleicht hole ich mkir ja die non-profit 4.1x um ein halbes Jahr
später mich das erscheinen von 4.2x zu ärgern.

Kann jedem nur empfehlen der die aktuelle nonprofit.-Version hat, alle
Bibliotheken auf CD zu speichern, sonst hat er auch irgendwann das
Problem, daß die Bibliotheken von Nachfolger 4.2x inkompatibel zu
seiner dann alten Version 4,1x sind.


Mit besten Grüßen

Marco

Autor: Amateurfunker (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Marco,
in einem grossen Unternehmen werden immer Verträge gemacht beim Kauf
von Software wie eagle mit http://www.cadsoft.de/ . Dort wird in den
Pflichtenheften immer reingeschrieben das es import und export
Funktionen geben muss. Es gibt sie auch weil wenn das Unternehmen aus
irgendwelchen Gründen mal aufgekauft wird oder pleite geht oder... dann
kann man sich nicht drauf verlassen und der Geschäftsprozess darf nicht
leiden. Ein Standard Format ist immer drin. siehe Eagle,Target, OrCAD,
BAE, Protel, haben das auch. Das spricht für den Punkt IT Security und
Integrität des Unternehmens auf allen Ebenen. Also frag mal euren IT
Security Network Administrator der weis das oder frag einen
Amateurfunker der schaut in Packet Radio nach.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.