Forum: Mikrocontroller und Digitale Elektronik Arduino MKR 1500 Problem mit USB


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Marco S. (Gast)


Bewertung
-1 lesenswert
nicht lesenswert
Guten Tag

Bei Distrelec habe ich für ein Projekt 2 Stk. originale Arduino MKR NB 
1500 gekauft und wollte starten. Leider bekomme ich mittlerweile seit 
über 2 Tagen nicht einmal die Verbindung mittels USB zu den Arduinos 
hin. Ich habe es auf meinem Windows 7 Notebook sowie dem Hauptrechner 
mit Windows 10 versucht. Es ist eine neue Arduinoinstallation 1.8.12 
vorhanden.
Mittlerweile habe ich beide Arduinos mit jeweils 6 Kabeln auf 
unterschiedlichen Ports versucht. Auch habe ich das Ganze mit 
Fremdspeisung des Boardes versuch, ebenfalls mit negativem Ergebnis. 
Stecke ich das USB Kabel ein, so blinkt zuerst die Charger-LED, die 
ON-LED leuchtet und anschliessend leuchtet auch die BUILTIN-LED. Am 
Computer höre ich nicht den üblichen Ton, wie wenn ich ein anderes UBS 
Gerät schnliesse. Auch zeigt Windows keine Meldung an und es erscheint 
auch kein neues Gerät im Gerätemanager.
Stecke ich z.B. mein Arduino Mega 2560 Board an, so wird dies wie 
gewohnt mit COM-Port im der IDE angezeigt und kann auch ausgewählt 
werden. Also scheint die USB-Geschichte grundsätzlich zu funktinieren.

Hat jemand bereits ähnliche Erfahrungen gemacht oder kann mir einen Tipp 
geben, wo ich noch ansetzen könnte ?

Vielen Dank

von Rudolph R. (rudolph)


Bewertung
0 lesenswert
nicht lesenswert
Was sagt denn USBTreeView dazu?

von Marco S. (Gast)


Bewertung
-1 lesenswert
nicht lesenswert
Kannte ich bisher nicht, aber danke für den Tipp.
Also beim Atmega 2560 wird alles korrekt auf COM4 angezeigt, aber beim 
neuen Teil wird gar nichts angezeigt. So als ob alle 6 USB-Kabel 
lediglich die 5V zu Gerät transportieren könnten aber keine Daten 
übermittelt werden...

von Rudolph R. (rudolph)


Bewertung
0 lesenswert
nicht lesenswert
Da auf dem MKR1500 der ATSAMD21 direkt am USB hängt, fehlt diesem 
vielleicht der dazugehörige Bootloader.

: Bearbeitet durch User
von Marco S. (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Anscheinend kann man den Bootloader zurückspielen indem man den Button 2 
mal kurz Drückt. Habe ich getan, aber leider hat sich dennoch keine 
Besserung ergeben...
Auch im USB Device Tree Viewser ist alles beim Alten.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.