Forum: Mikrocontroller und Digitale Elektronik SMPS Chip rätsel, TOP258, TNY280 oder ähnliche


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Flip B. (frickelfreak)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich suche ersatz für einen Explodierten SMPS chip in einem Nedap PR50SB 
einen Ersatz. Der Deckel ist sauber weggeflogen und nicht mehr 
aufzufinden. einzig die Pinbelegung und Bauform hilft mir bei der suche. 
Ich hatte schon einen LNK304GN in der hand und festgestellt, dass dort 
schon die Pinlücke nicht passt. Suche bei Mouser zeigte TOP258GN oder 
TNY280GN als kandidaten. Die Stärkste variante vermute ich, weil der 
chip vor seinem ableben noch einem Mosfet sekundärseitig half, ein 5cm 
loch in die Platine zu brennen (im bild), das kann ein 3 oder 8W chip 
sicher nicht. Das war vermutlich auch auslöser der überlast und der 
Explosion.

Ich schaue mal ob ich einen der Oben genannten Chips anhand der 
schaltung verifizieren kann. Kennt ihr noch andere (Hersteller) mit 
exakt dieser Pinbelegung?
Dip8, Pin 1 & 2 Steuersignale/versorgung, 4 Drain, 5-8 Source.

https://www.mouser.de/ProductDetail/Power-Integrations/TNY280GN?qs=WS5Jv%252B%252Bx1qU6vc5TlLKsSg%3D%3D
https://www.mouser.de/ProductDetail/Power-Integrations/TOP254GN?qs=IooffJMZQA4G2DI5%252BLB9EQ%3D%3D

: Bearbeitet durch User
von Flip B. (frickelfreak)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hier noch bild vom eigentlichen Entdeckelten Chip und vom gereinigten 
nebenschauplatz.

von Andreas (Gast)


Bewertung
-4 lesenswert
nicht lesenswert
Sowas kann man nicht mehr repariren...

von Flip B. (frickelfreak)


Bewertung
0 lesenswert
nicht lesenswert
Danke für deinen Beitrag.

Ich habe die Schaltung die verkohlt ist rausgezeichnet und werde den 
teil nachbauen. Auch auf der Platine ginge das noch prima, Die 
isolationswiderstände sind noch >10M und es gibt in diesem bereich keine 
hochohmigen signale. Wenn man das eingeäscherte glasfilament wieder mit 
epoxy tränkt, hält das auch wieder ein paar jahre durch. Das  Gerät ist 
mehr als 2000€ wert, ersatzteile sind nicht erhältlich. Aber eigentlich 
suche ich nur den DIP8- Chip der als folge auch verstorben ist

von Ben B. (Firma: Funkenflug Industries) (stromkraft)


Bewertung
0 lesenswert
nicht lesenswert
Zeichne den Schaltplan von dem Netzteil ab, vor allem die Pinbelegung 
wäre interessant. Löte den Schaltkreis mal aus, vielleicht, gibt's auf 
der Unterseite noch Hinweise.

Könnte auch ein STR-A6069H oder so sein, Viper-irgendwas, das ist wie Du 
schon gesagt hast, ein reines Ratespielchen.

BTW. So ein teures Gerät und so ein Schaden? Kann man nur als Warnung 
verstehen, sowas besser nicht zu kaufen. Wie alt ist das Ding?

von Flip B. (frickelfreak)


Bewertung
0 lesenswert
nicht lesenswert
Ist von 2013, die sterben wie die fliegen. Keine einzige 
sicherung/sicherungswiderstand im 12V kreis, dabei geht der an 6 
steuermodule. Mit etwas glüch bekomme ich einen ersatzteilspender mit 
anderem fehlerbild, wo vorraussichtlich der chip heile ist.

von Ben B. (Firma: Funkenflug Industries) (stromkraft)


Bewertung
-1 lesenswert
nicht lesenswert
Bei dem Baujahr bin ich ja geneigt, am ehesten auf den TOPxxx zu
tippen. Die sind schon recht lange im Spiel.

von Flip B. (frickelfreak)


Angehängte Dateien:

Bewertung
-1 lesenswert
nicht lesenswert
Hier die grobe schaltung.

von Rolf B. (falker)


Bewertung
-1 lesenswert
nicht lesenswert
eher TNY xxx je nach Leistung

solong

von Ben B. (Firma: Funkenflug Industries) (stromkraft)


Bewertung
-1 lesenswert
nicht lesenswert
Damit ist der TOP258 raus.
Der STR-A6069H auch.
LNK304 ebenfalls.
Viper20A passt auch nicht.
tschüss TNY280...

Hat noch jemand Ideen?

von Arno H. (arno_h)


Bewertung
0 lesenswert
nicht lesenswert
Die Google-Suche mit "nedap defekt" fördert einige Leidensgenossen zu 
Tage.
Auf diesem Bild ist ein TNY280 eingebaut:
https://www.photovoltaikforum.com/thread/129814-nedap-power-router-50sb-bs-defekte-hauptplatine/
Mit Adblocker siehst du nur das erste Bild, dort klicken und dann bis 
zum 4. Bild weiterschalten.
Arno

von Flip B. (frickelfreak)


Bewertung
0 lesenswert
nicht lesenswert
Ich hab schon viel gesucht, aber VIELEN DANK ARNO!!!!.  Diese Info habe 
ich gebraucht und nicht gefunden. Es ist der TNY280, den bekomme ich am 
dienstag zugeschickt. Die restlichen Teile habe ich schon getauscht. Im 
gegensatz zu 99% der NölrgelMeckerAntworten des Forums ist deine 
sicherlich ein "paar" minuten Suche wert. Lass mich wissen,wie ich dir 
ein zwei Bier  oder AFG Limos spendieren kann. Der Nedap wird 
instandgesetzt und etwas Elektroschrott ist vermieden.

: Bearbeitet durch User
von Ben B. (Firma: Funkenflug Industries) (stromkraft)


Bewertung
-1 lesenswert
nicht lesenswert
Soviel dann zum Thema Schaltplan ^^

von Flip B. (frickelfreak)


Bewertung
0 lesenswert
nicht lesenswert
Die Schaltung passt doch gut. Der Opto für die Rückkopplung und der CAP 
für die einstellung der Strombegrenzung am Multifunction-pin. Wo ist die 
diskrepanz?

von basstler (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo,
möchte diesen Thread nochmal ausgraben, da ich selbst auch gerade einen 
der Nedaps zu flicken.
Das Fehlerbild bei mir war in etwa gleich, was die Bauteile angeht, 
glücklicherweise nur ohne Schaden an der Platine.
Das SNT läuft wieder und die Hilfsspannungen scheinen auch alle wieder 
da zu sein, allerdings will meiner nicht einspeisen.

Wie ist das Ganze bei dir ausgegangen? @frickelfreak

von Flip B. (frickelfreak)


Bewertung
0 lesenswert
nicht lesenswert
Ich habe noch die IGBT- Treiber IR2110  auf dem steuerboard erneuert und 
eins der Netzrelais, was abgebrannte kontakte hatte.

Bist du sicher, dass das Snt am Zwischenkreis läuft und nicht nur das 
von Netz gespeiste Snt neben dem Platform-Board?

von basstler (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ich schaue es mir heute abend mal noch genauer an. Hatte die Kiste schon 
wieder auf die Seite gestellt, nur da ich durch Zufall gerade auf diesen 
Thread gestoßen bin, stieg die Motivation wieder etwas :D

Soweit ich es noch im Kopf habe, ließ sich das Display starten sowohl 
bei Anschluss Nur-Netz, als auch Nur-Solar.
Die Zwischenkreisspannung ( ~460v ?) hat er auch in beiden Varianten 
aufgebaut.
Er versuchte teils auch zuzuschalten, brach aber immer wieder ab und 
startete nicht.


Habe außerdem noch einen zweiten Nedap (mit Batterie, der um den es oben 
geht ist rein solar.) hier. Der allerdings mit anderem Fehler (P115-H). 
Dort scheint optisch auch alles ok.

von Flip (Gast)


Bewertung
0 lesenswert
nicht lesenswert
P115h (ein Modul ist nicht ansprechbar)
Kann erstmal an fehlender Batterie liegen.

von basstler (Gast)


Bewertung
0 lesenswert
nicht lesenswert
War alles angeschlossen, (also ein Netzteil für Solar, eins für 
Batterie). Ohne die Spannung am Batterieanschluss kommt B047-S

Gruß

von Flip B. (frickelfreak)


Bewertung
0 lesenswert
nicht lesenswert
Dann bleibt nur das AC-Steuerboard. Ich denke das kannst du mal 
kreuztauschen zur eingrenzung.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.