mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Phasenanschnitt- Fehler


Autor: Richard S. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo an alle,

ich habe mir da einen Dimmer (Phasenanschnitt) u.A. für Ventilatoren
gebaut und mit einem ATmega16 angesteuert.

Nun zum Problem: der Oszi zeigt, dass beim Haarfön die untere
Spgs.-Halbwelle nach dem Phasen-Nulldurchgang regelrecht
"überschwingt",
und beim Betrieb eines Tischventilators schwingen sogar beide
Halbwellen über!

Ob es wohl am falsch dimensionierten Snubber liegt?

Hat da jemand eine Idee?
Ich wäre dafür sehr und sehr dankbar - denn mir blieb der Lichtblitz
ganz und gar aus...


Richard S.

Autor: HomerS (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wo sind die Meßpunkte?, und kannste mal die Zündimpulse in zeitlicher
Abhängigkeit mitliefern?



ts

Autor: Thilo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Phasenan- (ab-)schnitt wirkt sich bei ohmscher und induktiver last
unterschiedlich aus (Induktionsspannung, cos. phi). Hast Du eine
ordentliche Drossel drin?

Autor: capellone (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du darfst nur kurze (<100yS) Zündpulse senden wenn also deine Led3
leuchtet sind die Pulse zu lang.

Die "Stromnulldurchgangserkennung" ist eine Spannung<40Verkennung.
Led1 zeigt dir also an das der triac nicht gezündet hat und Netz
anliegt.

Für beliebige Lasten am Dimmer ist besser den Netznulldurchgang vom
Trafo oder deinen OK1 an L1 und N zur synchronisation zu verwenden.

R3 würde ich 180R 1/4W nehmen R4 und C1 weglassen besser ist 3052
(höhere Sperrspannung)

Drossel benötigt man bei induktiver Last nicht.

Autor: Richard S. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Im Anhang die Oszi-Bilder, die auch die Triac-Zündimpulse zeigen.

Die Drossel müßte ausreichen (1mm Drahtstärke, 50 Wind., 100µH).

Alle "rein" induktive Lasten (im 2. Bild eine Lichterkette) haben
dementsprechend kleinere Überschwinger.

Aber wo kommen die blöden Überschwinger her?

Und wieso läuft der Haarfön so komish:

Stufe 2:      Keine Überschwinger
Stufe 1:      Überschwinger nur an der unteren Halbwelle
Aus-Stellung: Überschwinger an beiden Halbwellen.

Schimmert jemandem vor, was hier vor sich geht?

Gruß Richard

Autor: Benedikt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Schimmert jemandem vor, was hier vor sich geht?
Ja, ist doch klar:

>Aus-Stellung: Überschwinger an beiden Halbwellen.
Nur Entstörkondensator an, also Überschwinger da Kondensator geladen.

>Stufe 2:      Keine Überschwinger
Ist halt eine rein ohmsche Last

>Stufe 1:      Überschwinger nur an der unteren Halbwelle
Die Leistung wird durch eine Diode halbiert. In der unteren Halbwelle
ist daher nur den Entstörkondensator aktiv -> Genauso wie Aus.

Autor: Richard S. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
An capellone:

soweit ich weiß, müssen gerade bei induktiven Lasten eine
Ringkerndrossel zur Entstörung  und ein Snubber (incl. R4 u. C1)
verwendet werden (s. Optokoppler-Datenblatt im Anhang, Seite 6)

Autor: Stefan Kaspar (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Zu Deiner Nulldurchgangerkennung:

Bei induktiven Lasten verlöscht der Triac nicht im Nulldurchgang der
Netzspannung, er leitet noch in der anderen Halbwelle. So wie Du den
Nulldurchgang mißt, verschiebt sich dieser dann in dem Fall. Miß den
Nulldurchgang direkt an L und N.

Hast Du den BTA16-600 verwendet, wie es im Schaltplan steht? So wie es
aussieht wird bei induktiven Lasten während der Dauer der Zünimpulse
der Haltestrom des Triacs nicht erreicht. Such mal einen Triac mit
niedrigerem Haltestrom, oder verlängere die Zünimpulse, bis der Triac
zündet. Du kannst ja eine zweite Nulldurchgangserkennung einbauen, die
den Nulldurchgang direkt an L und N mißt und mit deiner jetzigen
Nulldurchgangkennung detektierst du, ob der Triac gezündet hat. Dann
bricht die Spannun über dem Triac auf ein paar Volt zusammen. Löscht
der Triac wieder (Spannung an ihm steigt wieder an) dann triggerst du
ihn nochmal, und zwar so lange bis er zündet oder die momentane
Netzhalbwelle vorüber ist.

Autor: Richard S. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Ja, ist doch klar

Dann erzähle mir doch bitte, wie ich meine Kurvenform so "einstellen"
kann, dass sie auch bei induktiven Lasten erträglich bleibt?

Stimmt es, dass R3 zu groß ist (s. Beitrag v. capellone)?

Oder sind sogar all die Überschwinger ganz normal?


Gruß Richard

Autor: Stefan Kaspar (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nochmals zu den Oszibilder:
Ventilator -> induktive Last -> Triac erreicht Haltestrom nicht beim
Zünden

Lichterkette -> vorwiegend ohmsche Last -> Triac zündet, leichte
Überschwinger nach Nulldurchgang = normal

Fön Stufe 2 -> starke ohmsche Last -> Triac zündet, keine
Überschwinger

Fön Stufe 1 -> Heizung wird über Diode nur bei einer Halbwelle
bestromt, andere Halbwelle nur Motor=schwache induktive Last-> Triac
zündet nicht.

Fön aus = Kaltluft? Motor schwache induktive Last->Triac zündet nicht.

Lösungen wurden schon genannt. s.o.

Autor: Benedikt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
R4 und C1 sollten auf jedenfall weg. Für R3 wähle ich meist irgendwas um
die 100Ohm. Theoretisch kann man den auch ganz weg lassen, aber einige
10Ohm schützen den Triac und den Optokoppler doch etwas.

Einige der Überschwinger sind normal.

Einen wirklich universellen Dimmer, der mit allen Lasten klarkommt habe
ich auch noch nicht hinbekommen. Dazu braucht man eine intelligente
Steuerung, die sowohl den Nulldurchgang als auch den Schaltzustand des
Triacs kennt.

Autor: Richard S. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Aber ihr bringt doch meine ganze heile Welt komplett durcheinander!

>Triac zündet nicht.

Wenn Triac nicht zünden würde, dann bliebe ja die Spannung nach dem
Zündimpuls gleich Null - in vorliegenden Fällen steigt sie jedoch auf
ihren Sollwert an.


> R4 und C1 sollten auf jedenfall weg.

Wieso ist dann in jedem Optokoppler-Datenblatt abgebildet (S. Bild im
Anhang), dass diese Bauteile nur bei ohmschen Lasten entfallen (ich
will jedoch u.A. einen grossen Aussenläufer-Rohrventilator antreiben)?



> Fön Stufe 2 -> starke ohmsche Last

Sein Ventilator soll etwa eine kleinere induktive Last sein, als die
Glimmfäden der Weihnachts-Lichterkette (weil gar keine Überschwinger
bei Stufe 2)?!

> Miß den Nulldurchgang direkt an L und N.

Danke! Damit habt Ihr beide recht (ich hab's gerade um 2:00 nachts
ausprobiert), denn bislang ging meine Nulldurchgangserkennung mit OK
überhaupt gar nicht und ich musste es mit einem Transistor tun.


NEUESTE BEOBACHTUNG: Beim Betrieb des Ventilators mit noch kleinerer
Leistung formt sich der Überschwinger zur einer regelrechten
abklingenden Schwingung um die Nullinie (Bild im Anhang)!!!

Morgen (äh... heute schon) werde ich eure anderen Vorschläge
ausprobieren.

Danke vielmals,

Richard

Autor: Richard S. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hier der vergessene Dateianhang zum vorigen Thread!

Gruß Richard

Autor: Richard. S (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Oh weh - Oh weh!

NICHTS ist besser geworden, nach dem ich R4 und C1 weggenommen hatte
(und für R3 statt 750R 4W. einen 150R 1/4W. einsetzte).

Man sieht den beiden Bildern an, dass sich die Spg. nach dem Abschalten
des Triacs (am Fasen-Nulldurchgang) um die 0V-Linie abklingend SCHWINGT
(kleine Unterschiede evtl. rühren daher, dass das Bild 2 mit einem
zweiten Dimmkreis "generiert" wurde).

Das ganze ist doch nicht normal, oder?
Und ist es etwa nicht schädlich für Ventilatoren (und EMV)?

Ich will den Bush-Dimmern zwar keine Konkurrenz machen, aber es müsste
doch irgendwie möglich sein, einen passablen Ventilator-Dimmer zu
bauen!?

Dankbar für kochende Köpfe,
Richard

Autor: Michi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Richard,

durch diese Veränderungen konnte es nicht besser werden R4 und C1
dienen nur zum Schutz des Triacs (evtl. Fehlzündungen) es kommt auf den
Triac-Typ an ob du sie brauchst oder nicht (Datenblatt ;-)). BT___W sind
 snubberless da kannst du das ruhig weglassen.
Auch R3 kann nix helfen, die Elemente waren nur mit 4W hoffnungslos
überdimensieoniert angesichts der kurzen Zündimpulse. Dein Triac zündet
ja also ist der Zündstrom groß genug.

Verzeih die blöde Frage aber wo genau hängt dein Ventilator und wo
misst du die Spannung?

Nur so aus Neugier, welche Leistung nimmt eigentlich der Ventilator
auf?

servus
Michi

Autor: Richard S. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Moin Michi,

der Ventilator ist (bisher) nur ein Tischventilator, später möchte ich
aber einen grossen Außenläufer-Rohrventilator dranhängen (desw. ein
16A- Triac).

Die Spannung messe ich mit Oszilloskop ich direkt am Triac.
Die Nulldurchgangserkennung habe ich umgebaut (s. meinen letzten
Anhang). Tja, die geht zwar immer noch nicht, aber jetzt zurück zur
Sache:

Könnte der ganze Spuck irgendwie mit der Phasenverschiebung durch
induktive Lasten zusammenhängen?

Oder mit dem Snubber aus R1 und C2?
C2 ist ein dicker X2-Kondensator (s.Bild) für bis zu 1600V - auch der
wird wohl etwas ZU dick sein?

Schlaflos
Richard

Autor: Richard S. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>wo genau hängt dein Ventilator?

der Ventilator hängt an den Anschlüßen oben rechts (s. beliebigen
Schaltplan weiter oben).
Die tatsächliche Verteilung der Bauteile auf dem Board ist eigentlich
die gleiche, wie im Schaltplan (oder darf ich alles, was zueinander
Parallel ist, beliebig vertauschen?).

Gruß Richard

Autor: Michael L. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Guten Morgen,

probiers mal so wie im Anhang. Ob mit oder ohne R4 und C1 ist erstmal
egal. Ich verwend die nicht...

Ich bin mir nicht ganz sicher, was du mit heating meinst. Ist das die
Heizwicklung vom Fön?

Gruß,
Michael

Autor: Richard S. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Drei Tage, drei durchgeknallte Triacs, mehmals 'rausgeflogene
Haussicherungen und eine weggesprengte Leiterbahn später:

Hallo, Michael!
Tut mir leid für die späte Reaktion - ich hatte volle Hände anderweitig
zu tun.
Ich habe deinen Vorschlag ausprobiert.
Der Kurvenverlauf ist jedoch leider kein Pixel besser geworden.

>Ich bin mir nicht ganz sicher, was du mit heating meinst.

Das "heating" steht für meinen 2. Dimmkreis, (da will ich später ein
(überwiegend ohmsches?) Heißluftgebläse anschliessen.
(Hintergrund: Der weiße Rechteck, mit dem ich diese Anschlüße in
anderen Zeichnungen (s. frühere Anhänge) verdeckt hatte, ist verrutscht
;-)

Zu meinen Erkenntnissen:
Ich glaube, der Hund liegt unter C1/R4 begraben! Denn:
Ohne dem Snubber (mein BTA600-16 ist nicht "Snubberless") ist das
"Nachschwingen" fast völlig weg (es entsteht jedoch eine hohe
Spannungsspitze zum Zeitpkt. des Strom-Nulldurchgangs,  s. Anhang).

Das anfängliche Überschwingen ist wohl auf die Phasenverschiebung zw.
Strom und Spannung bei induktiven lasten zurückzuführen.

Wenn ich mit meiner vermutung richtig liege, dann muss ich die
Kombination aus C1 und R4 anders dimensionieren (wie?).

Einen guten kommerziellen Dimmer auseinander zu nehmen ist mir zu
billig (u. zu teuer ;-)
Also hoffe ich sehr, auf weise Köpfe hier im Forum zu geraten, die mir
den entscheidenden Tipp geben können (und evtl. werden?)...


Dankbar,
Richard

Autor: Michi (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Richard,

hast du an den Triacs einen Kühlkörper, sonst wären die hohen Verluste
daran eher ungewöhnlich. (Falls du eine Rechnung dafür willst, sag's
einfach).

Ich kann nicht ganz glauben das C1 und R4 an den "Überschwingern"
schuld sein sollten, wer weis ;-).
Aber ich glaube man kann am Bild schön sehen wofür die gut sind. Die
sollen im Grunde "nur" die Spannungsspitze löschen. Falls nämlich die
Spitze hoch genug ist, kann der Triac dadurch zünden (siehe Kennlinie).

In deinem Fall sind C1 und R4 sicher sinnvoll.

Was mir noch einfällt wäre:

1. Was passiert wenn du einen größeren Motor laufen lässt?
2. Wenn du im Augenblick ausschließlich einen Motor dran hast könntest
du L1 weglassen weil ja der Motor den Stromanstieg schon begrenzt.
3. R1 mal weglassen, den habe ich noch nie gesehen.
4. R4 = 1k und C1 = 2.2nF (R3 anpassen)
5. 2x 100nF Kondensator (unbedingt X2 Klasse!!!) "links" und
"rechts" der Spule mit 0.1mH sind wohl für ohmsche Lasten bis 1kW
etwa üblich.

Anbei eine Schaltung für ohmsche Last (R2 und R3 nicht zusammenfassen),
für Motore kann man theoretisch L1 und C2 weglassen.

Könntest du trotzdem mal die Anschlüsse für das Oszi mit in den Plan
zeichen?

servus
Michi

Autor: HomerS123 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

ohne jetzt alle Antworten zu lesen, vlt, isses schon genannt worden.

Gib dem Teil mal eine ordentliche ohmsche Grundlast, also 'ne
Glühlampe dazu, also nimm eine Steckdosenleiste, und häng' Lampe und
Haarfön gleichzeitig dran (sofern der Triac das aushält).

Dann klappt es auch mit der Steuerung!

guude
ts

Autor: Henne (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Heizungen und dicke Lüfter sind ziemlich träge Lasten. Wieso nicht auf
Phasenanschnitt verzichten und eine Wellenpaketsteuerung bauen? (Also
ganze Vollwellen durchlassen und dann wieder sperren als
'rumzuhacken'...)

Grüße, Hendrik

Autor: Richard S. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Danke, Michi, für den Schaltplan!

> Was passiert wenn du einen größeren Motor laufen lässt?

Der Spannungsverlauf wird glatter! (s. Anhang)
Ach deswegen darf man also bei dicken Motoren auf die Drossel
verzichten (oder klein wählen)?
Dann verstehe ich nicht, wieso im MOC-Datenblatt (s. Anhang weiter
oben, Abb. S.5) keine Spule bei ohmschen Lasten abgebildet wird
(dafür aber bei Induktiven!)

> 2x 100nF Kondensator (unbedingt X2 Klasse!!!) "links" und
"rechts" der Spule mit 0.1mH sind wohl für ohmsche Lasten bis 1kW
etwa üblich.

Aha, so "hart" sind also ohmsche Lasten, dass man sie "dämpfen und
abfedern" muss!
Und je größer die ohmsche Last, desto größer müßen dann die
Kondensatoren sein (ich will nämlich eine 3kW-starke Heizung
anschliessen)?

Frage: Wofür brauche ich C3/R4 (wohl auch X2/4W-Teile)?
Frage anders: Was würde diese Kombination an meinen beiden Dimmkreisen
(Ventilator+Heizung) verbessern?
Diese Teile müsste ich dann evtl. noch bestellen.

Hmm... Ob es überhaupt SO schlecht ist, wenn die Spannung überschwappt?

Was macht es eigentlich für Probleme?

Danke für alles
Richard

Autor: Richard S. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Gib dem Teil mal eine ordentliche ohmsche Grundlast, also 'ne
Glühlampe dazu, also nimm eine Steckdosenleiste, und häng' Lampe
und
Haarfön gleichzeitig dran (sofern der Triac das aushält).

Bitte alle Vorschläge begründen, denn was nutzt mir die ganze
Beschäftigung, wenn ich nichts dabei lerne?
(mit ohmschen Lasten hab' ich keine Probs - nur mit induktiven).
----------------------------------------------------------------------
> Heizungen und dicke Lüfter sind ziemlich träge Lasten. Wieso nicht
auf Phasenanschnitt verzichten und eine Wellenpaketsteuerung bauen?

Was für Probleme bereitet denn diese Trägheit und wodurch wird sie
verursacht? Ich komme beim besten Willen nicht drauf...

Danke für die Tipps,

Richard

Autor: Michael L. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ah, jetzt ists klar geworden. Ich konnte nicht ganz zuordnen, wo L und N
dran kommt.

Den zweiten Oszianschluss legst du auf die Netzseite der Last, oder?

Zu den Überschwingern, bitte korigier mich, wenn ichs falsch verstanden
hab:

- dein Oszi zeigt dir die Spannung an der Last
- die Last ist ziemlich induktiv, d.h. cosphi miserabe, z.B. 0,6 oder
noch schlechter.
- d.h. Strom eilt der Spannung hinterher
- Triac verlöscht erst, wenn der Strom den Haltestrom unterschreitet,
also fast Null ist
- erst dann misst du an der Last keine Spannung mehr

Schau dir mal die Spannung und den Strom in einem Bild an.

Noch als Anmerkung, dürfte aber klar sein:
Erst zünden, wenn der Triac wieder verlöscht ist.

Gruß
Michael

Autor: Richard S. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> hast du an den Triacs einen Kühlkörper, sonst wären die hohen Verluste
daran eher ungewöhnlich. (Falls du eine Rechnung dafür willst, sag's
einfach).

Hallo Michi, aber gerne würde ich alles berechnen, was "berechenbar"
ist! Was für Verluste meinst du denn? Die Verlustwärme? Ich baue später
eine fette Kühlschiene rein!

> Zu den Überschwingern, bitte korigier mich, wenn ichs falsch
verstanden hab

Hallo Michael, mit deiner Vermutung liegst du völlig richtig (hierzu
s. meinen Thread oben von 27.08.2006 01:16)

Es geht mir aber nicht um das anfängliche Überschwappen der
Spgs.-Kurve, sondern um deren Nachschwingen danach.

Vielleicht ist es aber auch ganz normal - bloß sagt keiner
was dazu ;-)

Gruß Richard

Autor: Michael L. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
...also gehts darum (im Anhang gelb eingekreist)?

Autor: PeterL (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo

hast du deine Schaltung schon mal ohne Drossel betrieben?
extl. hast du einen Schwingkreis Snubber- Motor-Drossel

Peter

Autor: Michael L. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Vergiss den snubber, als Ursache. Ich erkenn keinen Unterschied im
Spannungsverlauf mit und ohne. Habs mal geschwind nachgebaut... Kanal A
ist die Spannung, B der Strom. Last ist ein 850W Winkelschleifer.

Ich setz grundsätzlich den BTB16-600BW ein. Der hat den Snubber schon
drin. Ich habs mit einem TIC246 (ohne snubber, hab zumindest keine
Angabe im Datenblatt gefunden) getestet.

Autor: Michael L. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hab dir mal meine Schaltung angehängt. Lass dich nicht iritieren, das
der Triac verkehrtrum drin ist. Auf den µC gehts bei mir ohne
Optokoppler. Drei Pins gleichzeitig...

Wie Peter sagt, lass mal alles unnötige weg und fang mit einer
Minimalschaltung an.

Dein Oszi steht auf DC, ja?

Gruß,
Michael

Autor: Richard S. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo und vielen Dank für die Anregungen!

> Wie Peter sagt, lass mal alles unnötige weg und fang mit einer
Minimalschaltung an.

Habe die Spule überbrückt (u. R1, wie es Michi empfahl) - ohne, dass
sich der Spgs.Kurven-Verlauf geändert hätte (ja, Michael, es geht mir
um das Nachschwingen der Spannung nach dem erfolgten
Strom-Nulldurchgang).

Langsam dringt sich mir der Verdacht auf, dass der Spannungsverlauf
"Gerätespezifisch" ist und nicht auf die Schaltung zurückzuführen
ist! Was meint Ihr dazu?

Und weiss jemand, wie ein korrekter Spgs.-Verlauf bei einer
Phasenanschnitt-Gedimmten induktiven Last aussehen sollte?

> Habs mal geschwind nachgebaut... Kanal A
ist die Spannung, B der Strom.

Danke, Michael, für die Mühe!
Frage: Wo greifst du eigentlich den Strom ab (den will ich irgendwie
in einen Optokoppler mit AC-Eingang leiten, um den
_Strom_-Nulldurchgang zu detektieren!)

> Dein Oszi steht auf DC, ja?

Ja,der Steht auf DC - der eine Anschluss vor der Drossel (jetzt ist sie
weg), der andere erfasst die Triac-Zündimpulse, die der µC an den OK
sendet.

Gruß Richard

Autor: Michael L. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich würd auch fast sagen, dass das an der Last liegt...:-/
Haste mal was dickes >65W angeschlossen?
..hm.. 90°Anschnitt=ca. 150V-> 28W/150V*0,5(cos(phi) geschätzt)=0,093A
nicht gerade viel...sollte aber laut Datenblatt reichen (IH=50mA).

Den Strom mess ich über einen Shunt-Widerstand (siehe Anhang).

Und die Masse vom Oszi liegt wo?
Ähm als Anmerkung, meins hat potentialfreie Eingänge. Nicht dass du
dich über zwei unterschiedliche Massen wunderst...

Autor: Richard S. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
> Und die Masse vom Oszi liegt wo?

Hallo Michael, eigentlich verwende ich gar keine Masse (denn es zeigen
sich keine Unterschiede am Kurvenverlauf, wenn ich die Masse an PE lege
-
hab's gerade nochmal an meinen angeschnittenen Halbwellen
angeschaut).

Als ich gestern mit der Masse-Klemme an die Hochspannung ran kam,
knallte es hell und laut, die Haussicherungen flogen raus, eine
weitere  Leiterbahn verdampfte, woraufhin sich die entstandene
Kupferwolke auf die Platine in atomaren Strömen niederregnete und zu
einer "Haar"-dünnen Schicht um die Unfallstelle kondensierte.
Der Triac, der zufälig im Wege war, hat "sofort reagiert" und hat
gezündet - es war allerdings seine letzte aktive Handlung in seinem
kurzen Triacleben (jetzt ist er ein passiver 0V-Widerstand - was für
eine Reinkarnation!).

Kurz gesagt, ich habe Bedenken, dass es wieder genauso schlimm kommt
-wenn ich, so wie in deinem letzten Anhang abgebildet, mit meiner
Oszi-Masse wieder an den Triac ran gehe!

Ich möchte aber irgendwie die Stromkurve darstellen lassen!

Mein Oszi ist eine GoldStar 40MHz, Alter unbekannt (Foto: s. Anhang).


Gruß Richard

Autor: Michael L. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Richard

Oh lala :)
Du scheinst es aber gesund überlebt zu haben?!

Du solltest wissen, dass deine Oszimasse im Gerät mit dem PE verbunden
ist.
Wenn du dann deine Oszimasse mit L in der Schaltung verbindest, dann
machste einen satten Kurzschluss und die Lichter gehen aus.

D.b. du musst vor dem Anschließen wissen, wo in deiner Schaltung L und
wo N ist. Also wierum der Stecker drin ist. Müsste man eigentlich mit
einem Spannungsmesser herausfinden können. Spannung zwischen Oszimasse
und Messpunkt messen. Bei 0V kannste anschließen.
Da aber N und PE in deiner Hausinstalation wohl verbunden sind, haste
schon die Masse auf N...

Bald ist Weihnachten (schon wieder..) Lass dir einen Trenntrafo
schenken. Oder vielleicht haste ja schon einen. Dann kannste messen wo
du willst. Macht das basteln auch extrem viel sicherer!

Wie gesagt, mein Oszi hat keine Masseverbindung zum Netz. Deshalb sieht
das Bild vom 29.08.2006 08:44 ohne Masse etwas komisch aus (siehe
Anhang).

Gruß,
Michael

Autor: Richard S. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Michael und danke für den Tipp mit dem Trenntrafo!

ich glaube, ich lasse die ganze Geschichte mit dem Kurvenverlauf mal
sein - denn der Venti läuft ziemlich ruhig.
Ausserdem habe ich noch weitere Nüße zu knacken - oder, wenn mein
"Nussknacker" zu klein ist, jemanden (hier?) zu finden, der einen
Alle-Nüße-Knacker besitzt oder die gleichen Nüsse schon mal knacken
musste und um die Kerbe weiss, in die ich jetzt hauen soll :-)

Eines dieser Nüße (in diesem Thread bemängelt an meiner allerersten von
capellone und Stefan Kaspar) ist die Nulldurchgangserkennung der
induktiven Lasten - denn ich muss mich ja nach dem Strom richten, der
dort zur Spg. verschoben ist. Hierzu habe ich vor einiger Zeit den
Thread "Meine Strom-Nulldurchgangserkennung erkennt nur Spannung"
gestarten und bisher noch zu keinem brauchbaren Ansatz gelangt.

Danke für alle Anregungen - und für den Fall, dass jemandem noch etwas
zum Thema einfällt, werde ich diesen Thread im Auge behalten!

Danke nochmals!

Richard

Autor: Michi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Richard,

du wolltest noch die Berechnung für die Kühlkörper:


             T[J] - T[A]
P <= -----------------------------
      R[thJC] + R[thCH] + R[thHA]

wobei:

T[J] := maximale Sperrschichttemperatur (Datenblatt: BTA < 125°C)
T[A] := Umgebunstemperatur

R[thJC] := Wärmewiderstand von Sperrschicht zum Gehäuse (Datenblatt:
BTA 2.1K/W)
R[thCH] := Wärmewiderstand vom Gehäuse zum Kühlkörper (zwischen 0.5 und
0.8)
R[thHA] := Wärmewiderstand vom Kühlkörper zur Umgebung (Datenblatt vom
Kühlkörper)

P := am Triac anfallende (Wärme-)Leistung (Datenblatt: z.B. ~9W bei
9A)

servus
Michi

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Richard!
Ich habe das hier gerade erst entdeckt. Der Punkt ist, daß deine
Lüfter
keine induktiven Lasten im klassischen Sinne sind, sondern nach dem
Nulldurchgang als Generator arbeiten. Bei Lüftern ist das auch
extremer,
als bei anderen Motoren ohne Schwungmasse.
So richtig dimmen kann man den jedenfalls nur mit den Phasenwinkeln,
bei
denen in jeder Halbwelle Strom fließt. Sonst brennt er ab.
Du solltest dem Triac einen Widerstand (100Ohm) zwischen Gate und
Bezug
spendieren, dann kannst Du auch mit dem Snubber sparen.

Grüße
Michael

Autor: Richard S. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Michi

Besten Dank, Michi, für die Kühlkörperberechnung - vielleicht hast du
ja mir auf diese Weise meine ganze Bude gerettet ;-)
----

>> Der Punkt ist, daß deine Lüfter keine induktiven Lasten im
klassischen Sinne sind, sondern nach dem Nulldurchgang als Generator
arbeiten.

@Michael

Was meinst du damit? Wie verhält sich denn ein Dimmkreis mit einem
Lufter?

>> Du solltest dem Triac einen Widerstand (100Ohm) zwischen Gate und
Bezug spendieren, dann kannst Du auch mit dem Snubber sparen.

Oder sollte ich vielleicht gleich auf einen snubberlosen Triac
umsteigen (BTA16-600CW)?

Ich möchte, dass mein Triac mit allen 0,3...16A- Ventilatoren fertig
wird (denn ich verwende halt einen 16A-Triac!)
und würde das ganze gerne 100% richtig machen und dafür möglichst an
nichts "sparen" - denn sonst geht der ganze Lerneffekt flöten :-)!

Deswegen bin ich für jegliche Hinweise darauf dankbar,
wie man's "am besten" tun sollte.

Danke im Voraus,

Richard

Autor: Michael (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Richard!

Na ja, eine Induktivität erzeugt nur eine Phasenverschiebung. Ein Motor
erzeugt je nach Drehzahl eine Gegenspannung. U.U. kannst Du den Triac in
manchen Halbwellen nicht zum gewünschten Zeitpunkt einschalten, weil
kein Strom fließt, weil der Motor eben zuviel Spannung generiert.
Je nach Phasenanschnittswinkel passiert das regelmäßig, z.B. in jeder
dritten Halbwelle. Klingt grauenvoll! Noch habe ich dafür auch keine
Lösung, aber Deine Oszillogramme kommen mir sehr bekannt vor.

Mit der Schaltung im Anhang funktionierts gut. Setzt Du statt dessen
einen BTA 225-800 (3Q-Triac) ein, so kannst Du das RC-Glied auch
weglassen.

Ansonsten google mal bei ST nach AN308 und bei Philips nach Power
Semiconductor Applikations, Chapter 6.

Späße
Michael

Autor: Richard S. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

@Michael

Ein BTA 225-800 ?

Hmm... Bei Farnell "gibt" es lediglich den BTA225-600, aber dazu
heisst es dort lediglich "_Nicht mehr lieferbar, Produkt
abgekündigt_"!
Bei RS, beim Conrad und bei (der!) Reichelt gibt's das Teil auch
nicht.

Bei RS gibt es einen BTA216 - der tickt auch 3Q.
Werde evtl. mit dem probieren (den muss ich mir erst bestellen).

Frage: spielt die Wahl des Optokopplers irgend eine Rolle für die
"Leistungsbandbreite" (ich will ja Lüfter "beliebiger" Größe dran
hängen können, also 20mA...16A- Lasten!)

Danke Richard

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Richard!

Der Triac ist egal, muß halt für Deine Leistung passen. Ich denke der
BTA225 ist abgekündigt, weil der Nachfolger öko ist. Heißt aber
genauso. Die 800 deutet auf die höhere Spitzenspannung hin. Nimm
irgendeinen Q3-Triac.

Den Optokoppler solltest Du nach dem nötigen LED-Strom, der
Spannungsfestigkeit und dem zul. dU/dt aussuchen. M.E. sind BRT12/13
und MOC3052 gut geeignet. Eine Übersicht gibt es bei vishay.com (haben
die leider gerade zusammengestrichen) und faichildsemi.com.

Die Drossel ist übrigends SMCC 2,2M von Reichelt.

Autor: Michi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo allerseits,

ich bin mir nicht sicher ob ich gerade verstehe um was es hier geht.

Der Optokoppler hat nichts mit der Last zu tun sondern muss auf den
I[G] vom Triac dimensioniert werden.

Auch ist das kein Problem mit dem Triac an sich. Der BTA16/600 hält
Spitzen bis 600V aus, was den Oszillogrammen nach auch reichen sollte
und ist ausserdem bereits ein 3Q Triac. Ich würde da nicht rumtun.

Das mit der 100%igen Funktion ist ein löblicher Anspruch aber nicht zu
machen. Wir bereits irgendwo erwähnt, kannst du dich mit den
Zündpunkten und Parametern so spielen das du bei EINER genau bekannten
Last "optimales"!!!, nicht perfektes, Verhalten bekommst.

Was du sonst versuchst ist einen Motor zu bauen der heute ein Fahrrad
antreibt morgen zu Mars fliegen soll.

servus
Michi

Autor: Richard S. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo und danke für alle Vorschläge!

Mein neuer snubberloser 3Q-Triac ist zwar immer noch nicht da (ein
BTA216-600B von Philips, gibt's bei RS), aber der scheint meine
Ansprüche erfüllen zu können - denn er packt alle Lasten, die zw.
0,2...16A ziehen!

Werde berichten, ob's was geworden ist - z.Zt. bin ich aber mal wieder
in der Programmierwelt (und dort auf der Bug-Jagd) - und das kann bei
mir lange dauern!

Grüße
Richard

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.