mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Parallelport und LCD???


Autor: Björn (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich beschäftige mich erst seit kurzem mit Mikrocontrollern.
Bisher habe ich dem Tutorial gefolgt und eine menge gelernt.
Ich habe mittlerweile auch ein LCD am laufen, welches mir allerdings
noch ein wenig kummer bereitet.

Also ich nutze einen eigenbauboard wie in www.mikroconroller.net
beschrieben, bestückt mit einem atmega8.

Ich habe isp und den atmega8 auf einer platine untergebracht und über
eine Parallelport verlängerung angebunden.

Mein Problem:

Ich bekomme eine ausgabe vom LCD "Test" (wie im tuorial). Ich zieht
den Parallelport ab und der Text "Test" bleibt bestehen. Wenn ich
jetzt allerdings die Stromversorung trenne erscheint kein text mehr.
Sobald ich allerding den Parallelport wieder anschließe erscheint auch
sofort der Text "Test" wieder, wie im Programm vorgesehen.

Woran könnte das denn liegen?


Gruß Björn

Autor: Björn (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
korrektur:

Mein Problem:

Ich bekomme eine ausgabe vom LCD "Test" (wie im tuorial). Ich zieht
den Parallelport ab und der Text "Test" bleibt bestehen. Wenn ich
jetzt allerdings die Stromversorung trenne UND WIEDER ANSCHLIEßE
erscheint kein text mehr.
Sobald ich allerding den Parallelport wieder anschließe erscheint auch
sofort der Text "Test" wieder, wie im Programm vorgesehen.

Autor: Karl heinz Buchegger (kbucheg)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Wenn ich jetzt allerdings die Stromversorung trenne UND WIEDER
> ANSCHLIEßE erscheint kein text mehr.

Das beudeutet, dass dein ATMega8 das Programm nicht ausführt.

Moment: Was genau hängst du ab.

Du hast:

  PC
parallel Port
  Kabel mit ISP-Programmer
ISP Schnittstelle
  ATMega8

Welche Verbindung trennst du genau? Den 'parallel Port'
oder die 'ISP-Schnittstelle'?

Wenn schon, dann solltest du immer die ISP-Schnittstelle
aufmachen, da nicht klar ist, was der ISP-Programmer mit
der Reset-Leitung vom ATMega8 macht, wenn die Verbindung
zum PC gekappt wird. Welchen Programmer verwendest du überhaupt?

Im Moment deuten alle Anzeichen darauf hin, dass der Programmer
den ATMega8 in einem Duaer-Reset hält.

Autor: Björn (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Karl Heinz,

also du siehst das soweit richtig.

>Welche Verbindung trennst du genau? Den 'parallel Port'
>oder die 'ISP-Schnittstelle'?

Ich ziehe den parallel Port ab, da ich den isp und den atmega8 auf
einem Board augebaut habe. Könnte das evtl schon das problem sein?

Als programmer nutze ich bisher yaap, habe aber auch ponyprog und
bascom auf meinem Rechner.

Gruß Björn

Autor: Karl heinz Buchegger (kbucheg)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Könnte das evtl schon das problem sein?

Schnapp die ein Multimeter und miss die Spannung am
Reset-Pin vom Mega8. Wenn du da 0V misst, dann hast du
das Problem gefunden. Da muessen 5V anliegen.

Autor: Björn (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe den fehler gefunden!!! Besten Dank Karl Heinz.

Ich habe einen Taster zum Reset in die Schaltung gelötet und zum
entprellen ein 100nF Kondensator genommen.
Ich habe den jetzt gegen 10nF ausgetauscht und jetzt klappt es.

Vielen Dank nochmal.

Gruß Björn

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.