mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Phasenanschnitt- Fehler II


Autor: Richard S. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo, ich bin's wieder mit meinen "Problemkurven".

Leider muss ich Euch schon wieder um einen Weisen Rat bitten, denn
ansonsten wird's nix aus meinem Dimmerprojekt!

_Zum Problem_: Die angeschnittene Spannung (Last: ein Ventilator,
s. Anhang) baut sich nach dem Zünden des Triacs zwar wieder auf,
beschreibt dann aber eine viel flachere Kurve, als ein Sinus (->
geringere Leistung)!

Ist mir evtl. irgendein Bauteil zu schaden gekommen - hatte schon viele
explosive Abenteuer auf dem Board!
Gerade habe ich aber alles, was mir in der Sinn kam, ausgetauscht -
aber ohne nennenswertes Ergebnis)!

Bitte macht mir Augen auf |-(

Danke, Richard
_________________________________________________________________
PS.:*Tipp*: bei fast 100 Leistung (Bild 1) ist der Spannungsverlauf oft
in Ordnung (sprunghafte Besserung).

Autor: HomerS (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
1. wie immer, wo sind die Messpunkte?, Zündimpule mit auf's Bild

2. so soll es doch wohl nicht sein. Sieht so aus, als schaltet der
Triac nach Ende des Zündimpulses wieder aus. Haltestrom?


Na ja, bring erstmal Info.


ts

Autor: PeterL (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
hallo

nimm die Schaltung im Anhang die funzt 100%ig (als Optotriak deinen
3022
10mA oder besser einen 3023 5mA Zündstrom)
Der Widerstand vor dem Optotriak muss nicht so stark sein weil nach dem
Zünden fast kein Strom mehr fliesst, er muss aber impulsfest sein.

Peter

Autor: Richard S. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>> Sieht so aus, als schaltet der
Triac nach Ende des Zündimpulses wieder aus. Haltestrom?

Hallo HomerS und besten Dank für den rettenden Tipp!

Ja, die abgeflachten Spannungsverläufe entstanden dann, wenn bei
grossen Anschnittwinkeln der Effektivstrom auf ca. unter 30mA sank.
Mit einem Triac, der nur 25mA Haltestrom braucht, geschieht dieser
Spannungseinbruch viel Später im Spgs.-Verlauf!

Meine weitere Beobachtung:

Bei einem kleineren OK-Ausgangswiderstand (keine Ahnung, ob das Teil
auch wirklich so genannt wird?) bessert sich die Lage ebenbfalls
spürbar.


>> Der Widerstand vor dem Optotriak muss nicht so stark sein weil nach
dem Zünden fast kein Strom mehr fliesst, er muss aber impulsfest sein.

Hm... bist du dir auch ganz sicher, dass mir nicht die Bude abfackelt,
wenn das Programm aus irgendwelchen Gründen während des Triac-Zündens
hängen bleibt?
Und ich habe auch keine Ahnung, wie man so etwas Programmtechnisch
berücksichtigen kann?

Idee?

Gruß Richard

Autor: crazy horse (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ne, da passiert nichts. Zündet der Haupttriac, ist für den kleinen MOC
keine Betriebsspannung mehr da.
Schlimmstenfalls zünden beide Triacs am Beginn jeder Halbwelle neu, der
Haupttriac bleibt dann die ganze Halbwelle niederohmig, beim Steuertriac
wird sofort nach dem Zünden der Haltestrom unterschritten.

Autor: Uwe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!
Mal so als Tip, Zündimpuls anstehen lassen bis Ue fast 0, also
eigentlich Nulldurchgang, dann klapp's auch mit kleinen Lasten.(mache
ich jedenfalls immer so)

Viel Erfolg, Uwe

Autor: PeterL (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Uwe

braucht aber viel Strom :-)
besser mehrere kurze Zündimpulse setzen

Autor: Uwe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!
Wenn 10mA,für den MOC, viel sind, ist das wohl so.

MFG Uwe

Autor: Richard S. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo und danke für all die Anregungen!

Was haltet ihr denn von meinen jetzigen Oszi-Bildern für die 100%-
Geräteleistung (s. Anhang)?

Wie man gut sehen kann, erreicht man mit einem Phasenanschnitt nie die
100% - Leistungsgrenze, denn anscheinend muss ein Triac immer erst kurz
ausgehen und eine Weile sperren, bevor er wieder "freigezündet" werden
kann!

So, ab ca. 97% Leistung erhöhe ich die Anzahl der Zündimpulse
schrittweise von 1 auf 4.

Folgende Zeiten habe ich mir "aus dem Finger gesogen":

Impulsdauer:   10µs
Impulsabstand: 100µs

Die gesamte Impulsdauer für "100%"-Leistung beträgt dann
10µs x 4 = 40µs

Ist es hoffentlich in Ordnung so?

Meint Ihr, dass der "Sichere Bereich" (30µs)für alle möglichen
Ventilatoren (auch für große) ausreichend breit ist?

Wenn alles stimmt, werde ich mit meinem Grossen Dimmerprojekt endlich
fortfahren können!

Gruß Richard

Autor: Uwe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!
Bei "Zeizung" must du aber auch bei Nulldurchg. zünden. Oder sehe ich
da was falsch? Ind. wirst du wohl nicht besser hinbekommen.

MFG Uwe

Autor: Richard S. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>> Bei "Heizung" must du aber auch bei Nulldurchg. zünden.

Nein, wenn ich noch ein Paar µs früher zünde, dann "verpufft" der
erste Zündimpuls, ohne dass Triac zündet!

Ich habe mich an die 100%-Grenze praktisch "herangetastet"!

Falls ihr aber meint, dass ich noch etwas verbessern kann, dann nichts
wie her mit Vorschlägen!

Mann, was würde ich ohne Internet und euch alle tun?
Es ist einfach nur geil (ein anderes Wort dafür fällt mir im Moment
nicht ein!)

Danke,
Richard

Autor: Michael L. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Richard
Sieht gut aus so!

Ich nehm 3 mal 20µs zünden und dazwischen 50µs Pause..

Immer wieder schön wenn Leute Erfolg haben ;)

Gruß,
Michael

Autor: Michael Wilhelm (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kurze Frage:
was bitte bewirkt denn der NTC in den Schaltungen?

MW

Autor: Richard S. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>> Immer wieder schön wenn Leute Erfolg haben ;)

@Michael L.:

Danke Michael, dafür muss ich mich auch bei dir ganz herzlich bedanken
(s. meine anderen Threads)!


>> Kurze Frage:
was bitte bewirkt denn der NTC in den Schaltungen?

@MW:

hmm... ein NTC ist eigentlich ein Heißleiter -
ein "_N_egative  _T_emperature  _C_oefficient" - Widerstand, der mit
zunehmender Temperatur seinen Widerstand senkt und somit z.B. als ein
Thermometer eingesetzt werden kann - in meinem Schaltplan habe ich aber
keins abgebildet! :-}

Zu den Heißleitern:
-> http://www.elektronik-kompendium.de/sites/bau/0208031.htm

Gruß Richard

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.