Forum: Platinen KiCAD Rulechecker spinnt?


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Andreas R. (df8oe)


Angehängte Dateien:

Lesenswert?

Hallo an alle,

ich bin an einer recht komplexen Platine dran und möchte gerne alle 
eventuellen Fehler meinerseits vor dem in Auftrag geben der PCBs klären 
/ beseitigen. Aktuell habe ich das Problem dass der Rulechecker an 
Stellen meckert an denen ich keinen Fehler sehe. Es geht um 
Spannungseingänge einiger ICs. Diese haben mehrere Spannungseingänge pro 
Spannung und sind alle korrekt an die jeweilige Spannung gelegt (siehe 
Screenshot). Trotzdem meckert der Rulechecker "Pin ist mit anderen Pins 
verbunden, wird jedoch von keinem angesteuert. Pin D1 (Spg.eingang)von 
Bauteil U13 wird nicht angesteuert (Netzxx)". Die einzige Ursache die 
ich mir denken kann ist die dass KiCAD nicht weiß dass dort eine 
Versorgungsspannung reingeht die über Drosseln etc. "von weit her" 
kommt. Nur warum meckert KiCAD nur bei einem der Pins? Ist das sozusagen 
"stellvertretend"? Und wenn ja: wie kann ich die Warnung korrekt (!) 
abstellen? Ich möchte ungerne Warnungen global abstellen weil es 
durchaus sein kann dass sich in den Warnungen irgendwo etwas 
funktionsentscheidendes versteckt.

von Zugvogel (Gast)


Lesenswert?

Da fehlt das Power-FLAG an dem Netz: 
https://techexplorations.com/kicad-4-book/index-p=156.html

von Vancouver (Gast)


Lesenswert?

Auf jeden Fall mussdas Netz mit einem Powerflag versehen sein. Wenn die 
Spannung über Ferrite etc. kommt, ist das für Kicad erstmal nicht 
automatisch ein Power-Netz.

von Andreas R. (df8oe)


Lesenswert?

Das Powerflag ist es - das hat mir gefehlt! Danke für eure schnelle 
Hilfe!

von Zugvogel (Gast)


Lesenswert?

Nur aus Interesse: Haben Sie das Power-Flag direkt an dem Netz 
angeschlossen, an dem das IC hängt oder liegt da noch die Drossel 
dazwischen. Würde mich mal interessieren, kann es aber gerade nicht 
testen.
Vielen Dank im Voraus!

von Vancouver (Gast)


Lesenswert?

Ich hänge mich mal noch mit einer ähnlichen Frage dran: Welchen Typ 
haben korrekterweise die GND-Anschlüsse von Schematic-Symbolen: 
Power-Input oder Passive? Ich deklariere sie immer als Passive. Die 
GND-Leitung braucht dann kein Power-Flag. Aber ist das "Best Practice"?

von Vancouver (Gast)


Lesenswert?

Das Powerflag muss direkt an das IC, weil das Netz logisch gesehen durch 
die Drossel in zwei Teilnetze zerfällt. Dass die elektrisch verbunden 
sind, weiß Kicad nicht, da es keine Information über die Funktion der 
Bauteile hat. Streng genommen gehört auf beide Seiten der Drossel ein 
Powerflag.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.