mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik DS18S20 defekt vom liegen?


Autor: Holger Kratz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich habe vor drei oder vier Monaten mit einem DS18S20 experimentiert.
Hat auch ganz gut geklappt. Brauchte ich im Moment aber nicht, also ab
in den Schrank damit. Nun wird es wieder aktuell und ich habe mir das
gute Stück wieder rausgeholt, mein altes bas - File auf das Board und
was ist das ??? Schreck!!! 0,5 C ??? und keinerlei Reaktion auf
Erwärmung und Abkühlung. Kann dieses "blöde" Teil durch nicht
benutzen defekt gehen? Oder gibts noch eine andere Möglichkeit? Wie
gesagt die Schaltung und der Code wurden nicht geändert!
Vielen Dank schon mal im Voraus.

Gruß Holger

Autor: ??? (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
nun ev. hat sich die Schaltung ja selber geändert...
...z.B. durch Haarrisse...

Autor: Aufreger deluxe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Kann dieses "blöde" Teil durch nicht benutzen defekt gehen?

Langfristig ja, in deinem Fall wird das aber eher nicht so sein.
Höchstens vielleicht ein ESD-Problem. Hast du ihn ordentlich gelagert
in spezieller ESD-Verpackung?

Autor: Holger Kratz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
also "Haarrisse würde ich erstmal ausschließen, da es sich um ein
Experimentierboard handelt und alles andere funktioniert.
Was meinst Du mit ESD-Problem? Gelagert wurde er nicht in einer
speziellen ESD-Verpackung. Aber was ist passiert?

Gruß Holger

Autor: Aufreger deluxe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielleicht schlug mal der Blitz ein...

Autor: Christoph Kessler (db1uq) (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
vielleicht hat in der Nachbarschaft jemand sowas benutzt:
http://en.wikipedia.org/wiki/Explosively_pumped_fl...
aber ein Blitz ist doch wahrscheinlicher
Beim Einschalten könnte das Netzteil einen Überspannungsimpuls
abgegeben haben.
Oder vom Teppichboden aufgeladen eine Entladung beim Anfassen

Autor: Holger Kratz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
also vielen Dank für eure Antworten. Ich hatte eigentlich gehofft er ist
noch irgendwie anders zu testen, ob er wirklich defekt ist. Aber ich
werde jetzt einen anderen einlöten und den mal testen.

Autor: Holger Kratz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So, also habe den nächsten DS eingelötet und das selbe Spiel. Der war
eigentlich auch richtig gelagert. Vielleicht liegts doch am Board oder
am avr. Kann ich das irgendwie testen???

Autor: Jankey (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nachmessen ob alles passt?

uC vl. irgendwie verändert? Versorgungsspannung Ok? Datenleitung in
Ordnung?

Autor: marc989 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
am besten einfach mal oszilloskop an die signalleitung hängen und
schauen, ob sich überhaupt was vom chip/MCU her tut.
dann kannst du möglicherweise hardwarefehler eingrenzen.

Autor: Holger Kratz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Problem hat sich erledigt. Also nicht der DS18S20 ist blöd, sondern
ich. Es lag einfach an den Fuse-Bit Einstellungen im Avr. So etwas
blödes. :-)
Danke an alle die sich beteiligt haben.

Gruß Holger

Autor: inoffizieller WM-Rahul (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Manchmal hilft liegen auch... vor allem, wenn man das lange genug mit
geschlossenen Augen macht ;-)

Autor: Paul Baumann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ganz grünau! Wer schläft, KÜNDIGT nicht. :-))

MfG Paul

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.