mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik M16C Flashen mit 3.3V


Autor: Marcel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallole,
weiß jemand, ob der M30624FGAGP sich mit 3,3V flashen lässt?
Ich benutze das Tool FlashSta.exe, um ein Bootload-Programm über die
serielle Schnittstelle vom PC in den M16C zu laden. Mit dem Tool lässt
sich zwar Blank Check, und Read durchführen. Aber sobald ein Erase oder
Program-Befehl verwendet wird, bricht die Kommunikation ab.
Aus dem Datenblatt geht meiner Meinung nach nicht eindeutig hervor, ob
sich der M16C nur mit 3,3V betreiben, oder auch flashen lässt.

Hat hier jemand Erfahrung?

Gruß Marcel

Autor: Sascha Pypke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Marcel,
ich habe ein Projekt gemacht mit einem LCD Grafik Kontroller und da
lief
alles auf 3.0 Volt.
Es stimmt das Renesas zum Flashen mit 3V keine Angaben macht, denn es
gibt für 3V extra einen Kontroller der dafür freigegeben ist.
Aber bei mir hat es keine Schwierigkeiten gemacht.
Ich habe den Monitor zum debuggen mit dem Flasher-Tool von Mr.Busker
geladen.
Es kann halt sein das der RS232 Baustein probleme macht !
Aber es gibt halt keine Garantie ?

Gruß Sascha

Autor: Marcel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke Sascha,
mittlerweile vermute ich auch, dass es mit dem RS232 baustein
zusammenhängt. Ich werde versuchen, zum Programmieren direkt 5V
anzulegen. Dann sehe ich ja, ob es ein Layout-Problem ist, oder ob es
an der zu niedrigen Spannung lag.
Gruß Marcel

Autor: Sascha Pypke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Da fällt mir noch was ein bei 3 Volt taktet der Prozessor nicht mehr auf
16 MHz. Ich habe damals einen Clock von 8 MHz verwendet.
10 MHz ist laut Datenblatt noch zulässig.

Gruß Sascha

Autor: Marcel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bei mir ist der Clock nur 2 MHz, damit kann man aber immer noch bei 9600
Baud kommunizieren.
Wie es aussieht, lag das Problem in der Spannungsversorgung. Nachdem
ich direkt 3,3V aus einer Normsignalquelle angelegt habe, hat das
Flashen funktioniert! Die andere Spannungsquelle war vermutlich nicht
ganz störungsfrei...

Gruß Marcel

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.