mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik STK500 lässt sich nicht mehr abschalten


Autor: pumpkin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo forum,

ich habe gerade folgendes problem: mein STK500 lässt sich nicht mehr
mit dem POWER schalter abschalten. das board hängt per RS232 am rechner
und am netzteil. ist das normal und ich habe es vorher nur nicht
bemerkt?

pumpkin

Autor: Aufreger deluxe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielleicht holt es sich seinen Strom über die RS232.

Autor: A.K. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Handbuch STK500 Seite 2-2 "Quick Start".

Autor: Sonic (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du noch externe Beschaltung dran, die extra versorgt wird? Falls ja
kann's 'brenzlig' for den Controller werden!

Autor: pumpkin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
nein, alle ports sind 'blank'. einzig auf portA liegt die LED-leiste.
ich hatte vorhin den saudoofen fehler gemacht Vcc und GND an einem port
kurzzuschliessen (der connector war versetzt draufgesteckt  : /  ). die
spannungsregler wurden etwas warm, aber geschmöckt hat nix...

@a.k.  das passt, mein supply ist mit positivem center und mein
netzteil zieht masse auf PE. wieso wird am STK GND geschaltet (hab ich
das richtig gelesen?)? so ein unsinn.

pumpkin

Autor: gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
das STK ist relativ unempflindlich gegenüber port-kurzschlüssen.

Aber das stimmt, irgendwo holt sich das STK seine Masse, und sei es
über den rs232port.

Autor: gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
also einfach mal + und - vertauschen.

Autor: Fred (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

das Problem liegt wahrscheinlich darin, dass Du die "falsche" Leitung
der Stromversorgung über den Schalter laufen läßt. Der Eingebaute
Schalter unterbricht nur eine der Beiden, bei Dir wahrscheinlich Masse.
Über die Verbindung mit dem PC bekommst Du diese Verbindung natürlich
wieder geschlossen, und Dein Schalter hat nix mehr zu sagen. Versuch
mal die Polung des Steckers (Stromzuleitung) zu vertauschen, das sollte
das Problem beheben.
Gruß

Fred

Autor: pumpkin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich mach es mir einfach: die masseverbindung der einzelnen konstanter
untereinander habe ich zum netzteil zum STK hin einfach wieder
rausgenommen. denn der konstanter fürs STK hat doch keine verbindung
zwischen masse und PE. jetzt passts wieder.

danke für die hilfestellungen.

pumpkin

Autor: A.K. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Im STK500 ist ein Brückengleichrichter drin. Geschaltet wird entgegen
der Angabe im Handbuch nicht etwa GND, sondern vor dem Gleichrichter.
Ob das Plus oder Minus ist, hängt vom Stecker ab. Egal welcher Zweig
geschaltet wird, es gibt immer eine Variante, in der dieser Effekt
auftritt.

Autor: Jörn Paschedag (jonnyp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Warum so kompliziert? Häng alles ab, auch den RS-232 Stecker zum PC.
Wenn es sich jetzt abschalten läßt, OK. Wenn nicht hast du ein Problem,
da nützt auch das Tauschen der Polarität nix.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.