Forum: Compiler & IDEs arm-none-eabi-gdb startet nicht mehr


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von J. S. (jojos)


Lesenswert?

Ich habe auf einem Ubuntu Rechner die aktuelle gcc Toolchain 12.2 von 
https://developer.arm.com installiert. Der Compiler läuft, aber der gdb 
will nicht starten. Zuerst kam die Meldung libcurses.irgendwas fehlt, 
daraufhin habe ich nach einigen Hinweisen diverse libcurses installiert. 
Nach mehreren Anläufen war diese Fehlermeldung weg, aber jetzt hängt es 
an irgendeinem Python Ding.
1
jojo@hp-keller:~$ arm-none-eabi-gdb
2
Could not find platform independent libraries <prefix>
3
Could not find platform dependent libraries <exec_prefix>
4
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
5
Python path configuration:
6
  PYTHONHOME = (not set)
7
  PYTHONPATH = (not set)
8
  program name = '/usr/local/bld-tools/bld-tools-virtual-env/bin/python'
9
  isolated = 0
10
  environment = 1
11
  user site = 1
12
  import site = 1
13
  sys._base_executable = '/usr/local/bld-tools/bld-tools-virtual-env/bin/python'
14
  sys.base_prefix = '/usr'
15
  sys.base_exec_prefix = '/usr'
16
  sys.executable = '/usr/local/bld-tools/bld-tools-virtual-env/bin/python'
17
  sys.prefix = '/usr'
18
  sys.exec_prefix = '/usr'
19
  sys.path = [
20
    '/usr/lib/python38.zip',
21
    '/usr/lib/python3.8',
22
    '/usr/lib/lib-dynload',
23
  ]
24
Fatal Python error: init_fs_encoding: failed to get the Python codec of the filesystem encoding
25
Python runtime state: core initialized
26
ModuleNotFoundError: No module named 'encodings'
27
28
Current thread 0x00007f1e42d77c00 (most recent call first):
29
<no Python frame>

dieser /usr/local/bld-tools/ Pfad existiert nicht, python 3.8 auch 
nicht. Ist das im arm-eabi-none-gdb eingebrannt oder wo kommt das her?

von J. S. (jojos)


Lesenswert?

konnte es fixen, durch Installation von Python 3.8. Sch*ß Fehler.

Python 3.8 ist auch nicht mehr in der Distro, muss man manuell ein ppa 
hinzufügen:
https://www.how2shout.com/linux/install-python-3-9-or-3-8-on-ubuntu-22-04-lts-jammy-jellyfish/

von Münchhausen (Gast)


Lesenswert?

Was spricht gegen die Version im Repository? Da bekommst du deine 
Abhängigkeiten direkt mit.

sudo apt install gcc-arm-none-eabi


Welches Ubuntu hast du genau und um welche Toolchain geht es genau? Da 
gibt es einige zur Auswahl...


Die Abhängigkeiten sind übrigens in den Release Notes auf der 
Downloadseite aufgelistet:
Release Note for Downloads 12.2.Rel1


Dir fehlen so halt noch ein paar Pakete, mittels dpkg -S kannst du nach 
Paketen basierend auf dem Dateinamen suchen. bld-tools wir da schon 
wieder lustig, denn das Paket dafür gibt es nur bis bionic. Danach ist 
es wohl wo anders oder gar nicht mehr dabei. Allein schon aus dem Grund 
würde ich auf derart bescheuert ausgelieferte Toolchains verzichten, da 
muss man sich ja auch um Updates manuell kümmern, das ist doch einfach 
nur nervig.

von J. S. (jojos)


Lesenswert?

die Versionen im Repo sind älter und möchte die aktuelle wegen Fehler in 
11.3.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.