mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Altes VFD Display geht nicht mehr


Autor: oldPC (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

ich habe hier einen alten Computer von 1972 (Wang 600) bei dem 
mindestens das VDF Display nicht funktioniert. Wenn ich das Teil 
enschalte erscheinen ca. 1/10 Sekundel lang irgendwelche Sachen auf dem 
Teil wenn ich wieder ausschalte auch dazwischen ist alles dunkel und 
nichts geht. Das er sonst geht erschließe ich daraus dass die lampe 
fehler, wie sie es soll am Anfang aufleuchtet und er auch auf clear und 
so reagiert.

Hat jemand eine Idee warum das display nicht geht?

Vielen Dank für eure Hilfe

Autor: Der Techniker (_techniker_)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
"Hat jemand eine Idee warum das display nicht geht?"

Weil es keine Füße hat? ;)

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
oldPC wrote:
> wenn ich wieder ausschalte auch dazwischen ist alles dunkel und
> nichts geht.

Ist das nicht normal, das alles ausgeht wenn man aus schaltet ?

Beschreib dochmal verständlich welches Problem du hast.

Autor: Michael U. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

http://www.oldcalculatormuseum.com/wang600.html

Das Ding ist ja ein echtes Museumsstück! :-)

Selbst wenn es nur die Display-Ansteuerung ist, dürfte es Arbeit 
machen...

Geht denn der Rest wirklich? Dann müssten ja Berechnungen zumindest auf 
dem Drucker ausgegeben werden.

Wenn das nicht geht, dürfte es eine nette Suche in dem IC-Massengrab 
werden.

Schönes Stück, wer kennt denn noch Ferritkern-Speicher? ;)

Gruß aus Berlin
Michael

Autor: oldPC (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo

@ Benedikt

Wenn ich das Teil
einschalte erscheinen ca. 1/10 Sekundel lang irgendwelche Sachen auf dem
Display wenn ich wieder ausschalte auch.

@ Michael

Der Drucker funktioniert, allerdings weiß ich nicht wie man darüber was 
berechnet, da ich nie damit gearbeitet habe. Zudem erscheint manchmal am 
anfang eine Reihe Nullen (die sofort wieder weg sind).

Ich glaube eher das das Problem in der Spannungsversorgung des Displays 
liegt oder ist das eher unwarscheinlich?


Autor: jojansen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielleicht die 'üblichen Verdächtigen' wie anoxydierte Steckverbinder, 
taube Kondensatoren, kalte /losgewackelte Lötstellen?
seit wann ist der Rechner denn krank? War das was schleichendes oder von 
jetzt auf gleich?
Ein schönes Stück hast du da. Lass ihn nicht verkommen.
:-) Johannes

Autor: Michael U. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Spannungsversorgung ist gut möglich. Die Spannung für das Display kann 
mit einem Wandler erzeugt werden, der nur noch kurz anschwingt und dann 
abreißt.
Taube Elkos dürften bei diesem Baujahr Anwärter für Fehler sein, da 
hilft aber nur messen. Anoden-/Gitterspannung dürften bei 20-30V liegen.

Mach keine Kurzschlüsse, die Heizung des Display ist schneller kaputt, 
als man denkt und evtl. Treiber-ICs dürften als Ersatz kaum noch zu 
beschaffen sein...

Gruß aus Berlin
Michael

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bist du sicher, dass es ein VFD ist ?
Wenn das Ding diese orangfarbenen Anzeigen hat, dann sind das 
Glimmlampen die mit etwa 200V laufen.

Autor: oldPC (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Benedikt K.

Könnte schon sein, sehe dir mal den Link an die Anzeige ist zimlich 
orange.

Der Rechner lief beim letzten Regulären Betrib , soweit mir überliefert 
wurde noch einwand frei.

Der Rechner war seit der Ausmusterung nicht mehr im Betrieb habe ihn 
jetzt auf dem Dachboden entdeckt.

Mit Glimmlampen kenne ich mich überhaupt nicht aus, weshalb könnten die 
denn nicht gehen?

Autor: Michael U. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

aus obiger Webseite:
The Wang 600's Gas-Discharge Display Panel

Steht noch dort, daß es 9-Segment-Zeichen und Dezimalpunkt sind.

Klingt nach Glimmstrecken oder ähnlichem.
Ändert am Problem nur die mögliche Spannung: 120...200V geschätzt.

Das die mit einem Wandler erzeugt wird und dieser nicht mehr richtig 
läuft, bleibt wahrscheinlich.

Gruß aus Berlin
Michael

Autor: oldPC (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
OK ich werde mal versuchen das teil zu öffnen und den Fehler zu finden

Autor: oldPC (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo

ich habe jetzt mal die Spannung nachgemessen. also an den Gittern liegt 
eine Spannung von 60 Volt und an den Dräthen(ich weiß nicht genau was 
das ist ) ca. 100 Volt

wie sieht das bei einem solchem Display aus die spannung scheint ja zu 
bestehen. An den ICs der steuerung liegt bei Low übrigens immer noch 1,5 
Volt und bei High nur 3,6 kann das an der verwendeten Logik (eigentlich 
ja ttl) liegen oder ist da was faul (Spannung ca. 4,6 Volt)

Autor: Michael U. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

H wäre ok bei TTL, L ist entschieden zu hoch.
Ist es wirklich TTL?

Gegen welchen GND-Punkt hast Du gemessen? Direkt auf dem Display-Board?
Könnte ein Steckverbinder oder eine Masseverbindung sein, die oxydiert 
ist. Das würde das GND-Potential dann anheben.
4,6V ist für TTL auch zu niedrieg, 4,75...5,25V sind Pflicht und wurden 
damals eigentlich auch genau eingehalten.

Gruß aus Berlin
Michael

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.