mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Und wieder was gelernt...


Autor: Tobias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich benutze hier einen 74LS245, dessen Eingänge auf einen Bus gehen und 
an dessen Ausgänge 8 low current LEDs über 1k Vorwiderstände 
angeschlossen sind.

Hab das Teil in Betrieb genommen und mich gewundert, warum die LEDs so 
dunkel sind. Hab dann mal die Ausgangsspannung am LS245 gemessen und war 
doch sehr erstaunt, dass da nur 3,25V raus kamen.

Also mal einen Blick ins Datenblatt geworfen und siehe da, beim LS245 
beträgt die Ausgangspannung (high) typ. 3,4V. Hmm, irgendwie ging ich 
von 5V aus.

Naja, der LS ist eh Dreck, zieht tierisch viel Strom. Leider habe ich 
hier bei mir keinen einzigen HC245 oder HCT245 gefunden :(

MfG
Tobias

Autor: Arno H. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
vielleicht kommt dir die Erleuchtung, wenn du die LED zwischen Plus und 
Ausgang hängst. Vergleiche doch einfach mal die Ausgangsströme für 
Source und Sink-Betrieb.
Arno

Autor: Tobias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dann müsste ich aber die Eingänge auf low legen, damit die LEDs 
leuchten. Ich habe aber keinen Einfluß auf die Buspegel.

> Vergleiche doch einfach mal die Ausgangsströme für
> Source und Sink-Betrieb.

für source : -15mA
für sink:    24mA

Und?

Tobias

Autor: inoffizieller WM-Rahul (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
knapp 10mA Unterschied...

>Ich habe aber keinen Einfluß auf die Buspegel.
schade...

Autor: Detlef _a (detlef_a)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Tobias,

einfach mal weiterlernen und die Dioden richtig fett hell machen: 2V 
minimaler Highpegel bei 15mA Strom macht 133 1/3 Ohm minimaler 
Vorwiderstand, selbst mit Flußspannung 0V Deiner Dioden. Mit bekannter 
Flußspannung wird der Vorwiderstand noch niedriger. Deine Auslegung auf 
1k ist also schlapp Faktor 10 daneben, naja, 20dB. Und wenn Du denn 
keinen gültigen Pegel an den Ausgängen benötigts einfach die Dioden ohne 
Vorwiderstand betreiben, das wird das Auge blenden!

LS ist kein Dreck sondern super.

Cheers
Detlef

Autor: Arno H. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
toll, wenn man einzelne Werte aus dem Zusammenhang reisst. Das sind 
nicht nur die 10mA Differenz beim Strom.
z.B. TI 74LS245:
VOH bei IOHmax: min 2V!  entspricht 30mW Pout und 45mW Pv
VOL bei IOLmax: max0.5V  entspricht 108mW Pout und 12mW Pv
Jetzt das Ganze mal 8 plus der normale Versorgungsstrom von max 70mA.
Und du wunderst dich, dass der IC bei dieser Verlustleistung warm wird?
Arno

Autor: Tobias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also gut, langsam...

Ich verwende(te) grüne low current LEDs, die haben laut meinem 
Datenblatt eine Flußspannung von 3V bei 2mA. In meiner Unwissenheit ging 
ich davon aus, das der LS245 ein VOH von ca. 5V hat. Somit errechnet 
sich der Vorwiderstand zu (5V-3V)/2mA=1kOhm => alles im grünen Bereich!

Eine nennenswerte Erwärmung des LS245 konnte ich nicht feststellen, ich 
wollte nur anmerken, das er "systembedingt" einen sehr hohen 
Stromverbrauch hat wie auch im Datenblatt nachgelesen werden kann.

So, nun ist es aber so, dass der LS245 ein VOH von typ. 3,4V hat und für 
die LED war das halt nicht der Bringer in Sachen Helligkeit, da 
0,4V/1kOhm nicht viel ist.

Ich habe die grünen LEDs jetzt durch rote ersetzt, die haben bei 2mA 
eine Flußspannung von ca. 1,75V. Somit ergibt sich mit 1k Vorwiderstand 
ein LED-Strom von ca. 1,65mA. Ich bin nun glücklich da die LEDs 
ausreichend hell sind.

Bei der Lötaktion ist mir aber noch was anderes aufgefallen. Ich hatte 
die LEDs mit der Pinzette in der linken Hand angepackt und mit meiner 
Ersa in der rechten Hand verlötet. Jedesmal wenn die Lötspitze einen 
Kontakt der LED berührte, leuchtete diese ganz schwach auf. Hmm, ich 
mache mir jetzt doch Sorgen um künftige ICs, die ich mit meiner 
Lötstation einlöte. Vielleicht sollte man da doch mal über die 
Verwendung der Potentialausgleichsbuchse nachdenken. Oder?

MfG
Tobias

Autor: A.K. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
TTLs sind nun einmal kein bischen symmetrisch, was Ausgangsspannung und 
-Strom angeht. Ist man in CMOS-Zeiten nicht mehr gewohnt. Und anno TTL 
hat man deshalb LEDs gegen Masse geschaltet.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.