mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Kann meinen 4433er nicht mehr Programmieren


Autor: Björn (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Forum,
Ich kann meinen AT90S4433 nicht mehr Programmieren Ich hab neulich
meinen Programmer (10Polig) falsch herum angeschlossen kann es daran
liegen? Können eigentlich auch einzelne Pins kaputt gehen oder wenn das
ganze Register ich hab nämlich 2 Steuerlietungen für ein LCD an dem
Port. Und das geht noch. Also bitte gebt mir Tipps.

Autor: emil (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
nach ca. 1100 write/erase prozeduren hat auch meiner den geist
aufgegeben; eigentlich geht er noch, aber statt 4k hat er nur mehr
ca. 0.8k speicher :)))

Autor: Björn (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ne mein Problem ist anders. Und ich hab das sch... teil erst ne Woche
oder 2 da kann ich das din unmöglich 1100 mal beschrieben haben.
Außerdem erkennt Ponyprog meinen Controller gar nicht erst.

Autor: Björn (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Weiß den niemand ne Antwort? Soll ich mir einen neuen holen oder ist ein
Fehler an dem Atmel ausgeschlossen?

Autor: emil (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
versuch doch mal mit einem anderen programmersoftware, mit dem
eingebauten progger von bascom oder codevision, bei mir z.b. erkennt
auch einer der progger den controller ab und zu nicht, dann tut es halt
der andere...

habe schon des öfteren diese erfahrung mit 4433 und mega8
(interessanterweise noch nie mit tiny26 oder mega16) gemacht;

du hast vielleicht das ding mit dem 74hc244, versuche doch als
notlösung einen minimal-progger (nur mit den widerständen) aufzubauen,
bei bascom hesst der "sample programmer", bei codevision ist das
dt006, ich habe immer einen als ersatz mit dabei und er programmiert
eigentlich viel zuverlässiger als der mit dem 74hc244, muss man halt
jedes mal ausziehen und anstecken...

emil

Autor: crazy horse (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wenn du den ISP-Adapter falsch herum eingesteckt hast, könnte auch der
Adapter selbst platt sein.

Autor: Björn (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ok so ein minimaladapter geht auch nicht :-( ich hab jetzt PonyProg und
Yaap getestet gehen beide nicht so ein scheiss naja ich werde mal ein
wenig weiterexperimentieren und Sonntag oder Montag bei reichelt gleich
2 neue Exemplare bestellen hab ich noch einen in reserve, wollte
sowieso noch Ätzzeugs bestellen. Das soll jetzt aber nicht heißen das
ihr mir keine Tips mehr geben sollt g Also wenn ihr sagt das einige
Progger manchmal gehen und einige nicht dann werde ich jetzt nochmal
den Bascom testen.

Autor: Björn (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So Bascom habe ich jetzt auch getestet geht leider nicht :-((( Ich bin
am verzweifeln!

Autor: Uwe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!
Teste doch mal die Signale die am Proz. ankommen. Wenn i.O.= Proz. def
sonst Adapter Mist.

MFG Uwe

Autor: Björn (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja wie soll ich das denn machen? Einfach mal messgerät dranhalten oder
wie? Ich bestell mir jetzt mal nen neuen AVR oder gleich 2 bei
reichelt. dann kann ich wieder basteln.

Autor: Uwe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!
LED's sind ein sehr gutes Hilfsmittel, du kann aber auch ein DVM mit
TTL-Test benutzen, oder einen Oszi,oder...oder..

Lasse dir doch mal was einfallen.

MFG Uwe

Autor: Björn (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja also ich hab jetzt gemessen mein AVR scheint kaputt zu sein. Das
komische ist nur das das Programm was gerade drauf ist 1A läuft. Aber
das nutzt auch nicht die Programmierpins. Vielleicht ist ein Pin
Durchgebrannt naja meine reicheltbestellung ist heute rausgegangen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.