mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Hilfe, falschen Spannungsregler erwischt!


Autor: Anfängerfehler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Ich entwickle eine batteriebetriebenen µC-Schaltung die vor allem 
Sensordaten verarbeitet. Für die 3.3V vom µC benutze ich einen step-up 
converter (AS1325) der von der Batteriespannung (2x AA = 3V) auf 3.3 
Volt konstantspannung hochregelt.

WEgen der Sensoren brauche ich eine möglichst konstante Eingangsspannung 
um die Sensorwerte die ohnehin im millivoltbereich liegen nicht zu 
verfälschen.

Idiotischerweise hab ich eben den Step up Konverter verwendet weil er 
eine hohe Effizienz hatte und ich nicht wirklich an die Restwelligkeit 
gedacht habe. Jetzt hat sich aber herausgestellt, dass Vcc mit ca 200mV 
rauscht! Das ist leider für die Schaltung absolut unbrauchbar. Auch mit 
einer viel größeren Entstörkapazität (Cout) komm ich da nicht weiter.


Kann mir bitte jemand helfen nund sagen was ich als Ersatz für den step 
up konverter verwenden kann? Bin leider ziemlich unter Zeitdruck (das 
Projekt sollte längst fertig sein)..

Danke für alle tipps!!

lg

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hänge ein L/C Filter hinter den Converter, also in die Plusleitung eine 
Spule von mind. 100µH und dahinter einen Elko mind. 100µF nach Masse und 
noch einen Keramik-C 100nF parallel zum Elko.

Autor: Anfängerfehler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für den Tipp,

Hab ich mir auch gerade überlegt. das dumme ist nur, das ganze ist schon 
extrem miniaturisiert, der spannungswandler ist blos als letztes 
dazugekommen weil ich jetzt mit anderen batterien arbeiten muss.

die 100µH Spulen und 100µF KOndensatoren sind leider verdammt groß ich 
denke die bekomme ich nicht auf das board...

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die 100µH Spule ist als SMD-Chipelement von MuRata verdammt klein, kann 
aber auch nur 25mA verkraften. Beim Elko kannst Du bei Subminiaturtypen 
Glück haben, muß ja nur 6,3V abkönnen. Probier doch einfach in freier 
Verdrahtung, ob es Deinen Erwartungen bezüglich sauberer Spannung 
entspricht und dann kannst Du passende Bauelemente suchen gehen. 
Vielleicht genügen auch schon kleinere Werte.

Autor: Anfängerfehler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hmm nein doch nicht blödsinn, sorry. 6mm durchmesser geht sich aus. Das 
könnte echt funktionieren! Wie hoch schätzt du die restwelligkeit mit 
dem r-l filter?

Falls jemand noch eine Idee zu einem anderen Spannungswandler hat bitte 
trotzdem schreiben, kann jede Hilfe brauchen.

Danke!

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Alle StepUp-Wandler haben Restwelligkeit. Das Einzige was dagegen noch 
bedingt hilft, ist eine sehr hohe Wandlerfrequenz, bei der die 
Ausgangsspannung dann logischerweise mit kleineren Bauelementen 
geglättet werden kann. Suche also nach einem Wandler mit mindestens 
500kHz Wandlerfrequenz.

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ach und nicht R/L Filter, sondern L/C Filter! Bei vielen 
Spannungs-Wandlern stehen diese als Ergänzung im Datenblatt beschrieben.

Autor: Anfängerfehler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
OK, das mit dem L/C Filter werde ich morgen ausprobieren. Falls ich es 
nicht schaffe das Rauschen soweit zu verringern, dass es nicht stört, 
gibts noch eine Alternative zu dem Step-up Converter?

Bisher hatte ich einen LDO im Einsatz und hab damit von einer höheren 
Spannung runtergeregelt, das war problemlos. Aber mit LDOs komm ich ja 
nicht von 3V weiter rauf. Charge pumps werden mir wohl ein ähnliches 
Rauschproblem bringen (richtig?) Und gibts sonst noch was das ich 
verwenden könnte?

Danke für die Hilfe und lg

Autor: Magnus Müller (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Bisher hatte ich einen LDO im Einsatz und hab damit von einer höheren
> Spannung runtergeregelt, das war problemlos. Aber mit LDOs komm ich ja
> nicht von 3V weiter rauf.

Wenn alle Stricke reissen... mit StepUp noch höher wandeln und danach 
nen 3,3V LDO für die Feinarbeit ;)

Autor: Anfängerfehler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hahaha da wär ich selber nie drauf gekommen, notfalls mach ich das 
wirklich, danke

lg

Autor: unsichtbarer WM-Rahul (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist eine Stanardanwendung, wenn man eine saubere Referenzspannung für 
ADC o.dergl braucht...

Autor: Anfängerfehler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Weil ich so schnell keine geeignete Spule bekommen konnte hab ich das 
mit dem LDO probiert. Hatte sowieso eine LP2981 da.

Nur leider bringt es überhaupt nichts. das Rauschen vom Step-Up 
Converter wird dadurch nicht unterdrückt.

Woran kann es liegen? Step up und LDO arbeiten einwandfrei.

lg

Autor: Marc989 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du dich auch an die Layoutvorgaben des herstellers im datenblatt 
gehalten? das wird auch oft missachtet.

marc989

Autor: Anfängerfehler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja hab ich.

Der LDO selbst rauscht auch kaum, wenn ich ihn an 5V Konstantspannung 
lege. Nur wenn davor der Step up wandler hängt wird das rauschen 
mitübertragen. Etwas gedämpft ist es schon aber ich nehme an das liegt 
am 22µF Cout den ich beim LDO genommen habe.

Seid ihr sicher dass ein LDO das Rauschen wegfiltert?

Danke!

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
LDOs rauschen auch selber etwas. Wenn Du keine Spule hast, nimm halt 
einen Widerstand von 10 Ohm, danach den dicken Elko nach Masse, dann 
noch einen Widerstand von 10 Ohm und wieder einen Elko. Wenn´s dann noch 
rauscht, weiß ich´s nicht. Die Widerstände kannst Du bei gutem Ergebnis 
dann wieder ein wenig verkleinern.

Autor: Anfängerfehler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ok das mit dem LDO klappt so einfach nicht.
Es steht auch extra im Datenblatt des LDO "The input capacitor .... 
should be connected to a clean analog ground."

Ich nehm also an LDOs (zumindest dieser) sind nicht zum entstören 
geeignet.

Dafür klappts jetzt schon ganz gut mit einem reinen RC Filter (100µF)
Selten aber doch messe ich aber mit dem Oszilloskop bis zu 200mV Spikes.

Kann mir jemand sagen woher die normalerweise kommen?
Der µC ist blank und das einzige was noch am Strom hängt ausser dem 
Step-Up Converter ist ein OPV.

lg

Autor: Alex Silver (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hast du nur die standardbeschaltung benutzt ? 100nF direkt vor und 
hinter den regler ? den schaltreglerteil vom schaltplan fänd ich gut ;-)
gruß

Autor: Kopfweh (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Gerne! Hier ist der Schaltplan vom Regler.

Es ist der Referenzschaltplan den ich aus dem Datenblatt habe.

Weil es nach obrigem Schaltplan eben wie verrückt gerauscht hat, habe 
ich mittlerweile C6 (Cout auf 100µF erhöht und paralell 100nF gehängt.

100nF davor werd ich noch anlöten, befürchte aber es wird nichts 
bringen, die Spannung vom Netzgerät ist relativ sauber.

Wenn ich noch einen 10Ohm 100µF Tiefpass dahinterschalte, verschwinden 
auch die letzten Spikes, allerdings hab ich dafür nicht wirklich Platz 
auf der Platine, deswegen versuch ich eigentlich rauszufinden woher die 
Spikes kommen, sie sind nämlich so unregelmäßig, dass ich eigentlich den 
Schaltregler als ursache ausgeschlossen habe.

lg

Autor: crazy horse (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich glaube, deine Probleme kommen hauptsächlich vom Layout, insbesondere 
Masseführung ist in solchen Fällen nicht unkritisch.

Autor: Anfängerfehler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo nochmal ... Du hast wohl recht denn:

Den Spannungswandler konnte ich zwar mit Hilfe von Tiefpässen 
hinbekommen, aber jetzt wo der Prozessor und die Sensorik läuft sehe 
ich, dass es sowieso keinen Sinn hatte.

Der Prozessor rauscht mit locker 500mV und das bei 3.3V 
versorgungsspannung... :-O
Damit ist ohnehin eine komplette Layoutänderung fällig.. nur schade um 
die Ätzarbeit... :(

Wirklich verstehen kann ichs nicht. Wahrscheinlich hätte ich besser auf 
die trennung von analogem und digialem Ground achten müssen, aber ich 
hätte mir nie gedacht, dass das solche Auswirkungen hat.

Ich hab den Bottomlayer mal als Bild angehängt. Wahrscheinlich sieht 
jemand der sich auskennt ohnehin sofort worans liegen muss. Wär super 
wenn mir der dann Tipps geben könnte damit ich nicht nochmal so einen 
Mist baue.

Danke!

Autor: Anfängerfehler (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hier das attachment:

Autor: crazy horse (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
der Idealzustand sieht so aus:
Eingang + Masse_Eingang zum Schaltregler, direkt dort 
low-esr-Eingangselko. Von da aus zum Regler Vin, Masse. Ähnlich am 
Ausgang. Erst vom Ausgangselko geht es zweipolig zur Schaltung. Gibt es 
Analog- und Digital-Gnd, treffen die sich in getrennter Leitungsführung 
erst am Ausgangselko. Gesamt-Masseflächen sind hier völlig fehl am 
Platze, allerdings solltest du natürlich trotzdem die betreffenden 
Masseleitungen ausreichend breit dimensionieren. Versuch einfach zu 
verstehen, wo welche Ströme bei deinem Regler fliessen (und Ströme 
fliessen nicht nur in der "heissen" Leitung, sondern genauso in der 
Masseleitung), dann klappts fast von alleine.
Zu guter Letzt: Layout-Vorlagen vom Chiphersteller sollte man nicht kalt 
vom Tisch wischen - die wissen am besten, wo die Probleme liegen und wie 
man den Chip mit möglichst guten Diagrammen an den Mann/Markt bringt :-)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.