mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Mega644 womit flashen?


Autor: Sascha (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Halli Hallo,
Auch nach Stundenlangem surfen bin ich auf keine Lösung meines Problems 
gestossen...
Ich möchte einen Mega644 via par-isp interface flashen. Leider fehlt bei 
yaap in der ini datei der nötige Eintrag - auch andere Programme wie 
avrdude etc verweigern ihren Dienst...
Bitte um Hilfe, da ich sonst meine erworbenen 644 dem Recycling zukommen 
lassen und mir mega32 kaufen müsste. ;)

Autor: flintstone (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Sieh mal bei www.mikrocontroller.com nach, die haben den ISA-Webserver 
mit einem Mega644 bestückt. Unter Download "Source+Hex V1.40" findest du 
alles. Ich habe es selbst ausprobiert und es hat auf anhieb 
funktioniert.
Hier geht es mit avrdude.

Gruß Guido

Autor: Sascha (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, das scheint tatsächlich zu funktionieren, da die makefile-Datei die 
nötigen Fuse-und LockBits setzt. Nur welche das sind kann ich dem 
Quelltext nicht entnehmen.
Bei yaap sind in der INI-Datei die einzelnen Controller übersichtlich 
sortiert und die besagten bits angegeben. Leider finde ich keine 
Möglichkeit Parallelen zu ziehen und die Einträge des makefiles in die 
ini-Datei zu übertragen...

Werd jetzt auf Mega32 umsteigen und ess die 644 am Besten auf. ;)

Autor: Schorsch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich hab mir die Testhex von mcu-systems.de vom megalearn
board zum testen des LCD genommen.
Musste halt nur mit Ext. Quarz betreiben.

Zum brennen brauchste den AVR910(aktiv) Nachbau.
Ich glaube die passiven ISP mit Ponyprog gehen net sauber.

Mit AVRdude und dem Tool
http://aaa.gmxhome.de/avr8_burn_o_mat_avrdude_gui.html

konnte ich den 644 sauber brennen.

Bootloader drauf (Megaload) und fertisch.



Autor: Sascha (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für den Hinweis,

Bis die Post meine heissersehnten 32'er bringt, habe ich ja noch Zeit 
zum Probieren. ;)

Meld mich, sobald ich irgendetwas zustande bekommen habe...

Tschaui
Sascha

Autor: Sascha (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Leider zeigt mir das Status-Fenster die Fehlermeldung:

unknown option --u

In den Optionen von AVR-Dude kann ich allerdings auch keine derartige 
Option (u) sehen.

Was habe ich denn nun schon wieder falsch gemacht? ;)

Sascha

Autor: Sascha (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Aha, In der Version von AVR-Dude lag der Fehler... ;)
Aber nun mag mein Pony-Adapter nicht... Irgendwie ist immer etwas 
fehlerbehaftet.

Sascha

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.