mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik CKSEL-Bits mit PonyProg setzen


Autor: daniel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Moin. Ich will mein µC ( ATmega16 ) mit einem 16Mhz Quarz betreiben. Ich 
hab noch die 2 Ko's zu je 22pF rangelötet, wie es im Datenblatt 
beschrieben ist, und nun bei PonyProg die Fuse-Bits CKSEL 0-3 und das 
CKOPT-Bit gesetzt. Seit dem will der µC mit PonyProg nicht mehr reden.
Könnte das am Quarz liegen, oder liegt das vielleicht an der Einstellung 
bei PonyProg? Der Haken bedeutet doch "programmed", oder?

Autor: Karl Heinz (kbuchegg) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bei PonyProg muss das dann so aussehen, dass bei CKSEL 0-3
kein Häkchen gesetzt ist.

Wenn dus genau anders rum gemacht hast, dann hast du
den Mega16 auf externen Taktgeber programmiert. Einfach
einen Takt an XTAL1 anschliessen und die Fuses entsprechend
umstellen.

Autor: Philipp (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Um auf einen Exteren Quarz mit 16 MHz umzustellen musst du folgendes 
einstellen

CKSEL0  1
CKSEL1  1
CKSEL2  1
CKSEL3  1
CKOPT   0
SUT0    1
SUT1    1

1 = not Programmed = kein Haken
0 = Programmed = Haken

> Mein Tipp <
Bau dir ein AVR910 Programmer
http://www.mikrocontroller-projekte.de/Mikrocontro...
Dann kannst du AVRDude, AVRProg oder ChipBlaste benutzen.
Sind alles gute bis sehr gute Programme, aber PonyProg ist so 
SCHEISSE!!!

Tschuldigung an Weihnachten Flucht man nicht, aber es ist eben wahr.

Gruss Philipp

Autor: Philipp (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Falls dein AVR nicht mehr Läuft
Falls du einen Frequenzgenerator hast:
   - Rechteckfrequenz (ein paar kHz reichen aus)
   - KEIN Spannugsoffset
   - An XTAL1 anhängen
   - dann umprogramieren

Falls du keinen Frequenzgenerator hast must du dir einen bauen
   - mit NE555 einen aufbauen
   - mit einem andern AVR einen Taktgenerator bauen

Autor: Lord_Vaderli (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

ich glaube ich habe gerade das gleiche problem.

ATTiny2313. Habe in Burn-O-Mat (oberfläche für avrdude) CKSEL0-3 
angemacht + sut0 oder sut1.

Jez gibt es auch nur fehler beim lesen und schreiben.

Wenn ich einen rechteckgen an XTAL1 hänge muss ich das quarz erst 
entfernen?

MfG Vader

Autor: Hubert G. (hubertg)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nein, musst du normalerweise nicht.
Wenn du diesen Programm verwendest sind die Haken immer richtig (wenn du 
das richtige auswählst). http://palmavr.sourceforge.net/cgi-bin/fc.cgi

Autor: Kristian Kuhn (lordvader)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ok vielen dank sowas brauch ich immer ;)

MfG Vader

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.