mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Problem OP Schaltung für induktiven Drehsensor


Autor: Juergen Perthold (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich habe ein Problem mit einer OP Schaltung (siehe Anhang). Zweck der 
Sache ist das Signal eines induktiven Drehzahlgebers in digitale Pulse 
zu wandeln. Das Ausgangssignal des Sensors hat eine positive und 
negative Amplitude. Pro Geberzahn also einmal positiv und einmal 
negativ. Um die richtige Drehzahl zu bekommen und um kompatibel mit 
Hallsensoren zu sein, bin ich nur an der positiven Amplitude 
interessiert. Deshalb habe ich mir eine Schaltung gebaut, die nur die 
positive Amplitude weiterverarbeiten soll. Ein unsymmetrisch versorgter 
OP ist als Komparator mit Hysterese verschaltet.
Nun ja, leider funktioniert das ganze nicht so wie gedacht. Selbst die 
Simulation mit LTspice zeigt mir nicht das entdeckte "Feature": Die 
Schaltung triggert sowohl auf positive als auch auf negative 
Eingangssignale.
Verwendung findet ein OP LM324 (identisch LM318, LM2904).

Kann mir jemand helfen, oder das Verhalten erklären ?

Danke,

 Jürgen

Autor: Bernhard S. (bernhard)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Jürgen,

eigentlich müsste die Schaltung richtig für ein positives Eingangssignal 
dimmensioniert  sein. Müsste eigentlich funktionieren.

Sobald das Eingangssignal eine bestimmte Spannung überschreitet, dann 
kippt der OPV und am Ausgang liegt eine positive Spannung.

Unterschreit das Eingangssignal einen bestimmten Pegel, dann kippt das 
ganze System wieder um und am Ausgang hast Du eine negative Spannung.

Ggf. könnte der Mitkopplungswiderstand etwas erhöt werden, damit sich 
die Hysterese etwas veringert.

Der Spannungsteiler am nichtinvertierenden Eingang bestimmt die 
Schwelle.

Bernhard

Autor: Juergen Perthold (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was soll ich sagen, ich bin auch fest davon ausgegangen, dass der 
Komparator nur im definierten Bereich arbeitet. Allerdings sieht es 
momentan so aus, dass ich beim positiven Eingangssignal ca. 5V am 
AUsgang bekommen, unterhalb der Schaltschwelle 0V und bei negativem 
Eingangssignal dann wieder ca. 5V. Ist das ein undokumentiertes 
Verhalten des OPs oder "normal" ?

Autor: Bernhard S. (bernhard)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>unterhalb der Schaltschwelle 0V und bei negativem Eingangssignal dann wieder ca. 
5V

Achso, am nichtinvertierenden Eingang wird eine kleinere Spannung 
angelegt als die negative Betriebsspannung (GND).

Kann sein, dass der OPV dann undefiniert arbeitet.

Da es Sich bei Dir offenbar um höhere Spannungen handelt,

schalte doch einfach eine Diode davor?

Autor: Juergen Perthold (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Eine Diode geht nicht so einfach, da die Einschaltschwelle bei 0.7V und 
die Ausschaltschwelle bei 0.4V liegt. Vermutlich werden die 
Schaltschwellen im Spannungsabfall der Diode verschwinden.

Autor: Bernhard S. (bernhard)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kann es vielleicht sein, dass dieser OPV in Deinem konkreten Fall nicht 
doch eine negative Btriebsspannung benötigt?

Autor: Wumpie (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Auch wenn dieser Beitrag schon sehr alt ist und ich ihne gerade mal 
zufällig beim suchen gefunden hab wollte ich Dir mal einen heissen Tip 
geben damit das ganze überhaupt funktioniert:
Leg mal eine Spannung an den Indusensor,da muss sich erstmal ein 
eindeutiges Magnetfeld aufbauen, sonst hast du da nur so ein 
undefiniertes stark rauschendes Eingangssignal, dat wird sonst nix !
Der rest sieht ganz gut aus, sollte gehen.

Autor: MaWin (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
> OP ist als Komparator mit Hysterese verschaltet

Nein.

Dafür müsstest du das wie oben gezeigt aufbauen.

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Übrigens bietet es sich an R1 und R2 gleich gross zu machen,
damit die positive und negative Hysterese gleich gross wird.

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Oh nee, ne 6 Jahre alte Leiche (und kein Schwein wusste in den 6 Jahren 
wo der Fehler lag und wie man's macht...)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.