mikrocontroller.net

Forum: Compiler & IDEs AVR-GCC tut nicht


Autor: Christian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!
Ich benutze AVR-GCC und AVR-Studio und jetzt ist folgendes passiert. 
Längere Zeit habe ich nur mit meinem Laptop gearbeitet. Und das ist auch 
die zeit in der ich mit AVRs angefangen habe. Nach langem probieren und 
durch die gute Hilfe hier im Forum habe ich es dann zum Laufen gebracht. 
Es ist Windows 2000 und AVR Studio 3.X, sowie die passende AVR-GCC 
Version. Auf dem Laptop läuft alles wie gesagt (hat nur einen etwas 
langsameren Prozessor). Jetzt habe ich als Administrator (wie auf dem 
Laptop) alles auf C:\ installiert und die Dateien aus dem 
AVR-GCC\..\win2000\-Verzeichnis vom Laptop kopiert und auf dem Desktop 
eingefügt.
Dann habe ich mein aktuelles Projekt auf einen Ordner auf dem Desktop 
kopiert (mit Headerdateien, Makefile, ...) und habe auch in den Settings 
geprüft ob der Pfad passt. Trotzdem weigert sich das Ding mein Programm 
zu compilieren. Tippe ich die Änderungen auf dem Laptop im gleichen 
rojekt ein, tut alles.
Was kann das sein?
Vielen Dank im Voraus.

Chrsitian

Autor: BAB (Kai K.) (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
welche avr-gcc version hast du installiert ??

vergewissere dich dass du den letzten winavr release installiert 
hast..!!

warum arbeitest du mit AVR Studio 3.X und nicht mit der neuen 4er?

Gruss,
BAB

Autor: Christian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Damit ich mit Version 4 arbeiten kann, muss ich die neuste Version des 
AVR-GCC installiert haben und das habe ich auch nach mehreren Stunden 
nicht hinbekommen. Gibt es dazu ein gutes Tutorial, wie man das macht? 
Also auf www.mikrocontroller.net habe ich nichts gefunden, was mir 
geholfen hat (zu dem Problem mit Version 4).
Ich kann mich auch nicht daran erinnern aktiv WinAVR installiert zu 
haben. Wo bekomme ich eine WinAVR-Version her, die genau zu dem passt 
was ich habe (AVR-Studio 3.53 und AVR-GCC 3.77)? Vielleicht ein genauer 
Link? Und muss ich da noch was einrichten, oder nur installieren?
Christian

Autor: BAB (Kai K.) (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
was willst du denn machen mit avr studio ??

nur debuggen oder auch als entwicklungsumgebung ??

winavr gibts hier:
http://winavr.sourceforge.net/

Gruss,

BAB

Autor: Christian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!
Habe es mit WinAVR probiert:
1) Das ist nur ein Editor ohne Simulator und Debugger, etc.
2) Das Problem besteht weiterhin (liegt an AVR-GCC und nicht an AVR 
Studio).
Was könnte es denn noch sein?

Christian

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.