mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik PonyProg


Autor: andy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hu leute!

hab ein problem und hoffe ihr könnt mir helfen..

hab bereits einige posts durchgelesen, brachte mir aber leider nix.

i habe

a) einen mega8
b) folgendes board: 
http://shop.mikrocontroller.net/csc_article_detail...
c) und folgendes kabel: 
http://shop.mikrocontroller.net/csc_article_detail...

d) ponyprog die standardversion und eine erweiterung in deutsch wo der 
mega8 inkludiert ist.


ich möchte NUR die fusebits lesen und setzen können.

2 mal habe ich es hinbekommen (mit deinstallation und neuinstallation 
von ponyprog) die fusebits auszulesen, wenn ich dann jedoch den CKSEL0 
setzen will und auf "schreiben" gehe, bringt er die fehlermeldung: 
fehlendes oder falsches device (-24).

mittlererweile bekomme ich es auch nicht mehr auf die reihe dass ich die 
fuses auslesen kann.

immer nur die gleiche fehlermeldung (s.o.)
Kalibrierung und Harware testen funktionieren..


bitte um hilfe, danke
lg andy

Autor: andy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
folgende ponyprog version verwende ich zum "überschreiben" der standard 
version: Version  2.05a Beta  Feb 24 2002

Autor: Michael U. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

2 Anmerkungen: soviel englisch braucht man doch nicht, um PonyProg 
bedienen zu können.
Also lieber die "aktuell" Version nehmen.

Der Adapter ist mir insofern unsympatisch, weil er eine Verlängerung zum 
Druckerport verlangt oder man sehr sportlich bei einem Tower sein muß...

Ich habe mit Verlängerungen an dieser Stelle mehrmals Probleme gehabt, 
speziell bei moderneren Boards, die es recht großzügig mit den Signalen 
meinen und bei ungenügent geschirmten Kabeln.

Das ISP-Kabel mit 1m Länge hat mir dagegen noch nie Probleme gemacht.

Ganz allgemein: man mag zu PonyProg und Parallelport-Adaptern stehen, 
wie man will.
Auch PonyProg und z.B. ein STK200-Dongle enthalten keine Würfel-Routine!

Wenn also da irgendetwas nur per Zufall geht, ist was faul.

Auch ein einmaliges "geht plötzlich nicht" muß eine Ursache haben und 
bevor die nicht eindeutig gefunden und beseitigt ist, würde ich keinen 
Atmel damit flaschen.

Mir hat diese Kombi noch nie einen AVR ungefragt umprogrammiert 
(90S1200, Tiny2313, Mega8, Mega16, Mega32,8115, Mega8515). Weder auf dem 
Original STK1200 noch per ISP auf eigenen Schaltungen oder auf dem 
Steckbrett bis 16MHz Takt.

Rechner ist ein 3200XP mit W2000 oder ein P166MMX-Notebook mit W98SE.

Gruß aus Berlin
Michael

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.