mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Mögliche Ursachen warum ein AT-SNT schwingt?


Autor: Sepp -o- (sepp_o)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Da ich für ein paar Projekte ziemlich genau 12V bei ein paar A benötige 
habe ich mit ein altes AT-SNT dass ich von einem PC ausgebaut habe etwas 
umgebaut.

Erklährung der Schaltung und was ich gemacht habe:
Die Istspannung wurde vor dem Umbauen über eine gewichtete 
Sumierschaltung ermittelt.

Dass bedeutet dass jeweils vom 12V und vom 5V Zweig ein Widerstand an 
den Pin1 des Regel-IC kommt und von dort Widerstände gegen Masse gehen.
Der Regel-IC regelt die Spannung so, dass am  Pin1 immer 2,44V anliegen.

Diese Regelwiderstände habe ich herausgelötet und durch einen 
Spannungsteiler ersetzt der vom 12V Zweig versorgt wird.
(Der Spannungsteiler ist niederohmiger als die Originalbeschaltung.)

Des Weiteren habe ich den Leistungsteil des 5V Zweiges von der internen 
Elektronik abgetrennt damit die jetzt höhere Spannung die interne 
Elektronik nicht beschädigt.
Die Interne Elektronik die mit den 5V versorgt wird ist einerseits die 
"power good" Erkennung und die Drehzahlsteuerung des Lüfters.
Bei der Drehzahlregelung wird einfach die Lüfterspannung in Abhängigkeit 
der Themperatur des Kühlbleches der Schalttransistoren gesteuert.

Diese Elektronik benötikt insgesammt 1,5mA.
Diese Spannung erzeuge ich mit einem Spannungsteiler aus einem 470R und 
einem 330R Widerstand der mit 12V versorgt wird.

Der 12V Ausgang hat im Leerlauf 12,02V ind bei 50% Auslastung des 12V 
Zweiges 12,01V.
Der 5V Ausgang hat im Leerlauf 5,5V und bei 50% Auslastung des 12V 
Zweiges 5,95V.

Leider habe ich jetzt das Problem, dass sobald ich im Betrieb die Last 
zu schnell ändere (einen der Lastwiderstände hinzu- oder weckschalte) 
fängt dass Netzteil an zu pfeifen und die Spannungen an den Ausgängen 
brechen zusammen.
Kann mir bitte jemand einen Tipp geben woran dass liegen könnte?

mfg Sepp

Autor: Peter Dannegger (peda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Hauptspannung sind die 5V, d.h. da muß auch immer die größte 
Leistung verbraten werden.
Ansonsten passiert eben alles mögliche, sogar ne Selbstzerstörung ist 
drin.


Auch, wenns etwas teurer ist, nimm irgendsoein standard Hutschienen 
12V-Teil, die arbeiten korrekt ab 0% Last.


Peter

Autor: Sepp -o- (sepp_o)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Da ein SNT eine Grundlast haben, dann kann es eigentlich nicht kaputt 
gehen.
Die ATX-Netzteile schalten sich einfach aus wenn die Last zu klein wird.

Die AT Netzteile haben aus diesem Grund alle Grundlastwiderstände.
(In diesem Fall ist am Leistungsteil des 5V Zweiges ein 100R und am 12V 
Zweig  eine Widerstandskombination die zusammen ca. 700R ergibt 
angebracht.)
Dieses Netzteil arbeitet wie die meißten AT-Netzteile mit einer 
gewichteten Summierschaltung.

Dass bedeutet dass die 5V genauer geregelt werden als die 12V.
Und genau diese Regelwiderstandsbeschaltung habe ich so verändert, dass 
jetzt die 5V nicht mehr beachtet werden und nurmehr die 12V zur Regelung 
hergenommen werden.
Da der 12V Zweig und der 5V Zweig mit dem gleichen PWM-Verhältnis 
angesteuert wird kann die Spannung des 5V Zweig nicht abhauen.
Das Einzige worauf man achten muß ist halt dass das Netzteil nicht mehr 
in einen PC eingebaut werden darf, da die 5V nicht mehr so genau sind 
wie es der PV benötigt.

Die interne Beschaltung die die 5V als Versorgung verwendet wird jetzt 
über einen Spannungsteiler stabil mit 4,95V versorgt.

Wenn die Belastung einigermaßen konstant ist, ist die Regelung sehr 
exakt.
Nur beim Ändern der Last spinnt die Schaltung.

Und warum dass so ist will ich wissen, denn laut den Angaben im 
Datenblatt des Regel IC KA7500B kann ich nicht ersehen warum dieses 
Phenomen auftritt.

mfg Sepp

Autor: Jack Braun (jackbraun)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Die interne Beschaltung die die 5V als Versorgung verwendet wird jetzt
>über einen Spannungsteiler stabil mit 4,95V versorgt.

Nimm doch mal probehalber anstatt des einfachen Spannungsteilers einen
7805.

Gruß Jack

Autor: Sepp -o- (sepp_o)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich wollte eigentlich dass mir die P.G. Anzeige bescheid gibt ob die 
Spannung  stimmt.

Ich werde jetzt aber mal schaun ob's was bringt wenn ich den 
Festspannungsregler einlöte.

mfg Sepp

Autor: Stefan Gemmel (steg13)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kann dieses Zusammenbrechen von der Schutzschaltung sein?
Versuch mal eine Grundlast dran zu lassen und zusätzlich eine 
Impulsbelastung. Bei mir geht es so.

Autor: Sepp -o- (sepp_o)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für eure Hilfe.

Ich habe es hinbekommen.

@Stefan Gemmel:
Ich hatte die Grundlast des 5V-Zweiges drangelassen.
Der 12V-Zweig hatte gar keine Grundlast bevor ich eine drangelötet habe.
Das Phänomen ist ja auch aufgetreten wenn ich bevor ich das Netzteil 
eingeschalten habe einen 15R Shunt an den 12V-Zweig angeschlossen habe 
und dann im Betrieb einen 100R parallel gehängt hatte.


Folgendes war der Fehler:

Sobald sich die Last geändert hat, hat sich neben der Spannung am 
Regeleingang auch die Spannung der Versorgung geändert die ich mit dem 
Spannungsteiler hergestellt habe.
Und da die Reverenzspannung aus der 5V Versorgungsspannung erzeugt wird, 
wirken sich kleine Spannungssprünge auch auf die Reverenzspannung aus.
Und wenn der Spannungssprung zu groß ist, kommt man außerhalb des 
Regelbereihes und der Regler spinnt.

Als ich an den Spannungsteiler der die interne Spannung erzeugt 
Pufferkondensatoren provisorisch angelötet habe, hatt die Schaltung 
wunderbar funktioniert.

Da aber ein L78L05 mit Keramikkondensatoren kleiner ist als der 
Spannungsteiler mit seinen Pufferkondensatoren, habe ich den 
Spannungsteiler durch den Festspannungsregler ersetzt.

Das Netzteil funktioniert jetzt einwandfrei.

mfg Sepp

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.