mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Pollin-Eval Board brauchbar?


Autor: Theodore Hindenberg (thindy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Hab zufällig bei Pollin dieses Atmel-Eval-Board entdeck: 
http://www.pollin.de/shop/detail.php?pg=NQ==&a=MTY...

Leider sind die Angaben relativ waage. Würde gerne 8er im DIL28 und 
32iger im DIL40 Gehäuse unter Linux programmieren, ist das Platinchen 
dazu brauchbar?

Danke im Vorraus, Thindy

Autor: andix (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

Ich habe den Vorgänger davon und das ist spitze! Mein Board hat nur 
einen 40-Pin-Sockel und damit funktionieren der mega16 und der mega32 
perfekt.

>Leider sind die Angaben relativ waage.

Hast du dir die PDF die es zum Downloaden gibt angeschaut? Da ist ein 
Schaltplan, eine Bestückungsliste und auch eine Anleitung zum 
Zusammenbauen dabei:

http://www.pollin.de/shop/downloads/D810038B.PDF

Ich kann dir nur raten das Board so schnell wie möglich zu bestellen ;), 
überhaupt wenn man einmal schaut wie viel andere Hersteller für ein 
ähnliches Board haben wollen...

andix

Autor: Thomas Finke (thomas-hn) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich besitze dieses Board auch und kann es für das 
Preis-/Leistungsverhältnis nur weiterempfehlen. Allerdings, tu dir den 
Gefallen und bestelle bei Pollin gleich noch einen 40-pol Textool-Sockel 
mit...dann kannste die 40 poligen AVRs leichter auswechseln. Und der 
Sockel passt von den Abmessungen genau drauf (auch wenn es mit dem Hebel 
des Schließmechanismus bei dem einen Wannenstecker sehr knapp 
wird...aber es passt ;-)

Gruß,

Thomas

Autor: UBoot-Stocki (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Yepp,

habe das Vorgängerboard  -  bin sehr zufrieden. Macht was es soll.

Gruß

Andreas

Autor: Werner B. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bis auf die Idiotie die Taster nach Vcc zu schalten. Jeder Tastendruck 
lässt die Versorgungsspannung kurz einbrechen da der Kondensator geladen 
werden muss. Lass beim Aufbau die Kondensatoren bei den Tastern weg. 
Entprellen per Software.

Autor: n00b (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dann bin ich ja erleichter, hab es mir auch gestern bestellt. Bin 
gespannt, wann es ankommt!

gruß

Autor: Theodore Hindenberg (thindy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Und wie programmiert ihr die atMegas in dem Board?
Kommt avrdude damit zurecht, auch unter Linux?

Danke, Thindy

Autor: J.K. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich hatte die erste version und nur problem :-( ich bekom nach ein paar 
wochen nen brief das ich irgendwelche leiterbahnen auf der rückseite 
durchkratzen und mit drahtbrücken umlöten soll die layoutfehler sollen 
aber inzwischen behoben sein ... also ich war enttäuscht hab mich dann 
hier eingedeckt:

http://www.myavr.de/shop/artikel.php?artID=64

und für 13€ inkl. Controller noch das hie
http://www.myavr.de/shop/artikel.php?artID=2

etwas später hab ich mir das hier geholt:

http://www.myavr.de/shop/artikel.php?artID=42

gruß J.K.

Autor: Theodore Hindenberg (thindy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
und wie hast du den Controller damit Programmiert? (kann das das Board 
überhaupt oder muss ich dazu trotzdem noch einen seperaten Paralell->ISP 
Converter bauen?).

Danke im Vorraus, Thindy

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Jeder Tastendruck lässt die Versorgungsspannung kurz einbrechen da der
> Kondensator geladen werden muss.

Äh was haben die für Cs verbaut? Dass man Taster nach GND schaltet, 
stammt noch aus der Steinzeit. Es ist völlig normal, dass gegen VCC 
geschaltet wird.

Autor: Theodore Hindenberg (thindy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
und mit welcher software programmiert man die AVRs da drinnen?
Schafft das avrdude?

lg Thindy

Autor: Hobbylöt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Entweder mit Ponyprog über den Comport
oder über ISP.

Autor: Theodore Hindenberg (thindy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Entweder mit Ponyprog über den Comport
keine Chance mit avrdude?

Autor: Werner B. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mit avrdude einfach ponyser als programmer. Null Problemo. Sonst kätte 
ich meinen ATmega644 damit nicht Prorammieren können, den den kann 
Ponyprog nicht.

Autor: Werner B. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dein Rechner braucht allerdings eine ECHTE serielle Schnittstelle.

Autor: Hannes (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi, hab mir dieses EVAL Board geholt. Wollte das testprogramm drauf 
laufen lassen. Leider wird es mittels Ponyprog nicht übertragen. Das 
Programm moniert immer, daß es den Schaltkreis nicht findet. Hab nen 
Atmega16 drauf und versuche über die integrierte RS232-ISP Schnittstelle 
zu programmieren. Hab schon einiges probiert. Leider steht nichtmal in 
der Anletung ob ein Serielles oder ein Nullmodemkabel gebraucht wird, 
habs mit beiden probiert, ohne Erfolg. Jemand nen Tip? Pony ist so 
eingestellt wie in der Anleitung.

Hannes

Autor: Steven Wetzel (steven)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> habs mit beiden probiert, ohne Erfolg. Jemand nen Tip?

Ja, Geld investieren und AVRISP kaufen. Spart sehr viel Ärger.

Autor: Frank (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
man braucht ein vollbeschaltetes 1:1 Kabel. Mit den Sparkabeln, also 3 
Adern und Brücken, klappts nicht. Und die richtige Buchse nehmen. NICHT 
Die nehmen die gleich neben dem MAX232 liegt. Ansonsten kann ich über 
beide Boardversionen nix Schlechtes sagen. Ich selbst benutze die erste 
Version und hab schon mehrere Version 2 Boards für Andere 
zusammengebaut. Ponyprog funktioniert völlig problemlos aber ich 
bevorzuge eh den Bootloader hier ausm Forum (zumindest für die grösseren 
AVRs).

bye

Frank

Autor: sb (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

ich hab das board auch, aber mir jetzt das STK500 bestellt, da meins 
praktisch unbrauchbar wurde, nachdem ich (aufgrund eines fehlenden 
steckers) hinten nen Haufen Kabel drangelötet habe. Deswegen würde ich 
gleich eine (oder Zwei) Stecker mitbestellen. Sonst ist das board gut.

Anwendungen auf dem board sind allerdings schlecht machbar, PWM hängt 
(in v 1)z.B. An der LED

Autor: sb (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
In den USA gibt es das STK500 gerade übrigens sehr preiswert

Autor: Hannes (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Frank

Alles so gemacht, 1:1 Kabel, vollbeschaltet, wird jedoch noch über einen 
Adapter gezogen habs aber mit dem Adapter durchgeklingelt. Er meldet 
immer Device missing or unknown device -24  . Gleiches übrigens auch an 
COM2. Der kurze Test in Ponyprog meldet auch jeweils daß der COM OK ist. 
Das KAbel steckt an der ISP Schnittstelle. Werds wohl wirklich mal mit 
einem separaten ISP versuchen müssen.

Hannes

Autor: sb (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo
ich hab am anfang auch den Falschen Srtecker genommen (mit dem IC) und 
nichts ging, als ich dann den richtigen genommen hatte ging immer noch 
nichts. Dann hab ich mir nen neuen Mega gekauft und alles ging.
Wenn du die richtige version von Ponyprog (die Beta) verwendest und das 
Kabel stimmt solltest du das mal mit nem anderen IC ausproieren.

Autor: Hannes (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So, jetzt gehts, war nur ein ranziger Sockel, der keinen Kontakt hatte. 
Hab das Ding gewechselt gegen einen aus meinem Bestand. Die 
Programmierung flutschte nur so durch, das Demo haut auch hin.

Danke, Hannes

Autor: Henk v.d. Wegen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab auch die erste Version und bin sehr zufrieden damit! Liebäugel 
hatlt jetzt mit der 2.0 wegen der ATtiny-Unterstützung. Wenn Du das Ding 
zusammenschweißt, empfehle ich Dir, statt des mitgel. Wannensteckers 
lieber normale 2-reihige Pinleisten zu nehmen. Das macht die us-pins 
leichter von ext. HW aus zugänglich.

Autor: Nemesis (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo,
ich habe sämtliche Probleme mit meine Evaluationsboard von Pollin, Ver2. 
und PonyProg_Vers2.07(beta), und zwar:
 Ich vesruche einem ATiny2313 umzubrennen, mit die volgende 
Einstellungen:
 - Board ausgeschaltet, dann Calibration, dann goto tum "I/O Port Setup
 - hier: COM1 (echte Port), "SI Prog API" , kein CheckBox Aktive in den 
"Select Polarity in the Control Lines"
 - wenn ich über "Probe" anclicke, kommt das Meldung "Test Filed". Also, 
etwas ist wrong hier.
 Hat jemand Ehrfahrung damit?
Ich habe die Lötstelle und alle Bauteile gecheckt, aber ni etwas Falsch 
gefunden
vielen Dank in Voraus, nick

Autor: Christoph S. (mixer) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

hatte auch ein problem mit der seriellen programmierung und pony prog.
Hab dann einen MKII gekauft und ne adapterplatine von 6pol-isp auf 
10pol-isp gebaut. Mit dem AVR Studio funktioniert das super und hab bis 
jetzt noch keine probleme damit!!
Hab damals pollin geschrieben und die haben gesagt, das liegt am pc!

Investiere die 40€ für nen MKII und du hast ruhe!!

MFG Mixer

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Investiere die 40€ für nen MKII und du hast ruhe!!

100% ACK

Autor: Nemesis (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
"Investiere die 40€ für nen MKII und du hast ruhe!!"
---------------------------------------------------------
schon gut, aber was ist MKII und wo kann ich kaufen? Erlich zu sagen, 
ich bin mit den ding mit mein Nerven am Ende. (MKII - es kling in mein 
Kopf wie in Mortal-Kombat-II)

Autor: Sebastian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Damit ist wohl ein AVRISP gemeint. Unter dieser Bezeichnung bei diversen 
Händlern zu finden.

Autor: Holger Krull (krulli) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nemesis wrote:
>  - Board ausgeschaltet, dann Calibration, dann goto tum "I/O Port Setup
Na wenn das so richtig ist. Wie soll denn Ponyprog was finden, wenn du 
das Board ausgeschaltet hast.

Autor: Nemesis (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
erstens,vielen Dank für Vorschlag.
Aber ich habe in Schaltplan angeschaut, sind nur TXD und RXD an die 
RS232 gekoppelt. Wie wird der Test von PonyProg durchgeführt? Am Ende 
der Kabel findet sie sich nur MAX232N - nixt anderes! Wie ist dies 
Calibration getan wenn niemand "beantworten" am Ende des Kabel? Soll ich 
ein bereits gebrannte µC einfügen und danach mit "Probe" prüfen?

Autor: Polliner (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ponyprog wird nicht am seriellen Terminal angeschlossen. Nimm
zum Programmieren den "anderen" seriellen Anschluß.

Autor: Holger Krull (krulli) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
An der Konzeption des Pollin-Boards wird es nicht liegen. Denn das hat 
bei mir auf Anhieb funktionert. Das Kabel sollte man wirklich am Sub 
D-Anschluß J3 mit der Bezeichnung ISP anschließen. Ein AVR-Controller 
(auch unprogrammiert) reinzustecken ist auch keine schlechte Idee.

Autor: Nemesis (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
super!
hat funk_tioniert! Also, ich habe immer die Seriellschnitstelle benutz - 
und das ist natürlich FALSCH! Mit ISP-Konnektor alles bestens, Test->OK, 
Probe->OK.
 Jetzt habe ich ein ATtiny2313 gefläscht mit ein Datei von Elektor, 
(Ethermeter-Prüfgerät) es sieht gut aus, ohne Fehlermeldung.
 Vielen dank, Jungs!
Eine letzte Frege!
 -Ich möchte µC nicht nur brennen, sonder auch verstehen und 
programmieren. Wie kann ich starten? Ins Internet sind vielen Seite mit 
diese Thema, aber..ich kann nicht alle lesen

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.