mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Instrumentenverstärker/DMS


Autor: Timo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe ein Problem mit einem Instrumentenverstärker, ich habe einen 
solchen mit einem Lt1014 aufgebaut(G=200). Jetzt habe ich das Problem, 
das sobald ich die Masse(Gehäuse) berühre es zu einem Sprung im 
verstärketen Signal kommt (ca. 30mV). Ich habe die Schaltung nur mit 
einer positiven Spannung versorgt, könnte das der Grund sein?
Weiterhin schwingt das Siganl so um 10mV. Die Auswertung erfolgt über 
einen Mega16.

Hat jemand eine Idee wie ich das lösen kann?

Vielen Dank für Eure Hilfe.

Timo

Autor: fubu1000 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo,
nett wäre eine schaltung deines verstärkers,ansonsten iss raten 
angesagt!!!
gruss

Autor: Siff (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Ganze sollte nastuerlich schon so aufgebaut sein, das das nicht 
passiert. Ein schema alleine genuegt da nicht. Das ist auch eine Sache 
der Anordnung.

Autor: Timo (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

danke für die Antworten, ich habe mal die Schaltung dür den 
Instrumentenverstärker angehängt, vielleicht reicht das.
Ich kann auch die komplette Schaltung anhängen, ist jedoch sehr 
durcheinander. Vielleicht eher die .brd Datei (Eagle)?

Autor: Timo (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hier nochmal das Board.

Autor: Hegy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Aus eigener Erfahrung kann ich dir sagen, das das ein schwieriges Thema 
ist. An deiner Stelle, so mal als Tip, baue das Ding mit einem fertigen 
Instrumentenverstärker-IC auf, z.b. sind die OPA-typen sind da 
wesentlich einfacher in der Handhabung und sind intern so aufgebaut, wie 
du gemalt hast und sind ebenfalls vom Verstärkungsfaktor frei 
einstellbar oder fest eingestellt. Aber damit ist das Thema einfacher zu 
handlen.

Probier z.B. mal die Gleichtaktunterdrückung aus. Beide Eingänge direkt 
verbinden und dann Spannung draufgeben, mal positiv, mal negativ und am 
Ausgang messen. Tut sich da was? Ideal wäre, wenn sich nix tut. Für 80db 
Gleichtaktunterdrückung brauchst du Widerstände, deren Verhältnis aus 
100k/100k||500k (Wid. am Minus-Eing. des Ausgangs-OP) und 
100k/(100k||330k+Poti) nicht mehr als 0.000133 auseinander liegt. Das 
ist sehr wenig! Außerdem solltest du überlegen, ob kleinere 
Widerstandswerte (alles unterhalb 100k) besser wären bzgl. 
Fremdeinstreuung. Große Widerstandswerte machen die Geschichte 
störempfindlich.

Dann ist da noch das Thema Zuleitung. Diese wird normalerweise 
abgeschirmt und auf die Abschirmung wird vom Instrumentenverstärker ein 
Signal gegeben. Geht den so: An den Ausgängen der 2 Eingangs-OPs, also 
zw. den 47k und 100k Widerständen jeweils ein R von 22k bis 47k 
zusätzlich dran, beide R an einen weiteren OP am +-Eingang dranbringen. 
Den Minus-Eingang an den Ausgang des zusätzlichen OPs (nicht inv. 
verstärker, ß=1) und den Ausgang auf die Abschirmung geben und die 
Abschirmung nirgends an Gehäusemasse verbinden. Nee, ich mal das jetzt 
nicht auf, vielleicht mal später.

- Hegy

Autor: Timo (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert

Hallo Hegy,

vielen Dank für Deine Antwort.

Ich habe eine Schaltung (AD620) gefunden, im Datenblatt sind zwei 
Schaltungen aufgebaut, meinst Du die wären tauglich für meine Anwendung? 
Kann ich die beiden angegeben OP(ad 705/ad548) durch lt1014 oder lm324 
ersetzten? Worauf müßte ich da achten?

Was ist mit negativer Versorgung, der Sensor soll nur auf Druck 
reagieren, also nur positiver Spannungsabfall. Ist die Störanfälligkeit 
geringer mit neg. Versorgung?
Kann ich die mit einem negativen Festspannungsregler erzeugen, oder muß 
eine Ladungspumpe her?
An den AD Wandler soll noch ein externer Poti ran, benötigt der einen 
eigenen Shield Driver, oder darf der am gleichen wie der DMS betrieben 
werden?

Tut mir leid, daß ich Dich mit Fragen bombadiere, aber es gibt leider 
nicht viele Leute, die sich in dieser Materie auskennen.


Danke nochmal.

Timo

Autor: Hegy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kukkich moagen mal.....

Autor: Hegy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
... nun ja, aus moagen mal eben kukken is nix geworden, sitz eben nicht 
jeden tag vorm pezeh. brauchstes noch oder ist's schon erledigt?

Ich vräg lieber vorher, bevor ich mich sinnlos krumm mache.

Autor: Timo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich bin immer noch interessiert. Habe schon versuche mit dem ad620 
unternommen sieht bis jetzt ganz gut aus, nur der Shield Driver funzt 
noch net. Wenn ich den zwischen Rg anlege geht das Ausgangssignal in den 
Keller.
Was ist die einfachste Möglk. eine negative Spannungsversorgung 
herzustellen? Kennst Du den ad8555, ist der besser als ad620?

Wieder viele Fragen! Sorry.


Gruß
Timo

Autor: Hegy (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Habe mal in meiner Datenversammlung nachgekukkt, was ich damals so 
gemacht habe. Ersma, die Anschlußleitugen zum Meßverstärker waren kurz, 
nur ein paar cm. Ich wollte damals den Strom über einen Shunt (0,1 Ohm) 
messen, nur das der Strom im mA Bereich lag bzw. auch mal runter bis 50 
µA ging. Dann wollen 5µV verstärkt werden, und dazu brauchte ich einen 
Verstärker, der exakt mit den Faktor 1000 verstärkt. Dazu habe ich mir 
mal die programmierbaren Meßverstärker angekukkt, wie PGA204 und PGA104. 
vorteil von diesen Teilen ist, daß die mit einfacher Versorgung 
auskommen, also nix mit +Vs und -Vs und GND, sondern nur +Vs und GND und 
der Shield Driver kann auch relativ simpel aufgebaut werden, kuxdu 
Anhang. Und noch Vorteil ist, daß du den Verstärkungsfaktor von 1 in 
10er Potenzen digital! bis 1000 hochschrauben kannst (PGA204). Der PGA 
hat Verstärkungsfaktoren im 2er Potenzbereich, also 1, 2, 4, und 8, auch 
digital einstellbar. Generell kukk dir mal die PGA-Serie an. PGA = 
Programmable Gain Amplifier.

Für den Faktor 200 könntest du Faktor 100 einstellen und nach dem PGA 
nochmal fest um den Faktor 2 verstärken, evtl. wegen Störungen nochmal 
einen Tiefpaß reinbringen und, falls die Verstärkung nicht passen 
sollte, mit dem ATmega automatisch, eben voll digital, den 
Verstärkungsfaktor des PGA anpassen. Oder ne Feinmessung dranhängen.

Der AD620, weswegen wohl die Spannung zusammenbricht, braucht definitiv 
eine  duale Spannungsversorgung. Alternativ, ohne dual Vs sind z.B. 
AD8220, AD8230,  AD8555!!!! (digitally programmable gain (span) and 
output offset voltage), AD8556, sofern du umbedingt auf AD rumreiten 
willst. Allerdings kenne ich deine Specs nicht, keine Ahnung
a) wie lang die Leitung von/zur der Wiege-Waage ist
b) die Höhe der Spannung des Wägemechanismusses ist
c) wie hoch die Störungen durch die Umgebung sind
d) wie genau es sein soll
e) vom Offsetverhalten
f) vom Temperaturbereich

Der Vorteil vom AD8556 ist, daß der gegenüber dem AD8555 an den 
Eingangspins ein EMI-Filter eingebaut hat, könnte ja wichtig sein.

An deiner Stelle würde ich mir mal den AD8555 und den AD8556 mal genauer 
ankukken (PDF durchstudiern) und dann den Typ mal probieren.

Autor: eProfi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Empfehlung: den ersten Verstärker / Wandler direkt neben den DMS 
anbringen.

Evtl. genügt es auch, einen empfindlichen 24bit-AD zu nehmen (z.B.
ADS1252 & Co), ohne Verstärker.
Es gibt auch den MSC1210 (8051 mit eingebautem 24bit-SigmaDelta und 
Thermometer, kann gleich die TempKompensation übernehmen).
suche auch nach   SBAA092B Application Report

Wichtig ist das (digitale) Filtern!

Wenn Du 50Hz Signal messen willst, wirst Du Probleme mit dem Netzbrumm 
bekommen.

Autor: Timo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

vielen dank für die Antworten. Also ich habe jetzt mit dem AD620 weiter 
probiert, da ich den nun schon da habe. Der Shielddriver funzt, jedoch 
kann ich über seine wirksamkeit wenig aussagen, die Funkmaus an meinem 
PC stört das Signal trotzdem, aber vielleicht wirds besser wenn das Ding 
im Gehäuse ist.
Ich habe den Ad620 wie im Datenblatt angeschlossen(s. post oben), nur 
das ich nur mit 0-5V Spannungsversorgung benutze. Es geht soweit, ich 
habe eine Vertärkung von G=500 und das Signal schwankt so +- 500µV also 
weit unterhalb der AD-Messschwelle(2,56V/1024=2.5mV).

Das Kabel ist ca. 1 Meter lang, vom Sensor werden max 5mV ausgegeben, 
d.h 5µV/N. Ideal wäre eine Auflösung von 1N aber 10N tun es zur Not 
auch.

Das einzige Problem ist, das ich den AGND nicht an meinen 
Mikrocontroller anschließen kann, da der Mega16 nur ein gemeinsames GND 
hat. Aber ich habe noch einen ltc1286 eingebaut und ich kann ja agnd auf 
den ADC2 legen und dann auf Differnez messen.

Ich muß jetzt nur noch die Platine fertig stellen und dann hoffen das 
alles so geht.

Den Ad8555 habe ich auch da, jedoch scheue ich mich noch vor dem 
Programmieraufwand.

Vielen Dank für Deine Hilfe, ich melde mich wenn die Platine so weit 
ist.

Gruß Timo

Autor: gaba (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo ich brauche bitte sofort eine schaltung für einen 
Instrumentenverstärker mit einer 4-leiter schaltung!!!!!!!!!!!!!!111

Autor: Norgan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Hallo ich brauche bitte sofort eine schaltung für einen
> Instrumentenverstärker mit einer 4-leiter schaltung!!!!!!!!!!!!!!111

Und ich brauche sofort einen Lottogewinn. Nun rate mal, wer von uns 
beiden grössere Chancen hat?

Autor: hans (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hoffe natürlich ich!!

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: hans (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
danke für diesen link, aber ich habe schon eine schaltung gefunden die 
für mich besser passt. Aber nochmals danke an "gast"!

Autor: Morco (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Guten Abend miteinander,

ich habe da auch ein recht kompliziertes Problem.
Ich messe an ziemlich EMV-Versuchten  Gegenden (es wird Strom in 
Mega-Watt-Bereich erzeugt) und habe das Messsystem soweit, dass ich 
prinzipiell sehr kleines Rauschen habe, auch während der Stromerzeugung. 
Nun habe ich über einen längeren Zeitraum trotzdem Offsetsprünge, ohne 
erkennbaren Grund oder dazu passenden Störeinfluss, wie z.B. schalten 
eines Schützes oder ähnliches. So ein Offsetsprung kommt über einen 
längeren Zeitraum z.B. Monate(also kein erkennbares Kriechen) bis der 
nächste Offsetprung kommt der auch in die entgegengesetzte Richtung 
gehen kann. Das dynamische Signal (z.B. die Amplituden) ändert sich 
nicht, also DMS kleben alle noch.
Ich arbeite mit einen System: Vollbrücke auf CANNSAS müB1 Modul (imc), 
dann per CAN-Bus zum Cronos und vom Cronos zum Mess-PC (Abtastrate 
200Hz). Die Verbindung Vollbrücke zum Modul ist als Sechsleitertechnik 
ausgelegt. Die Module werden über ein Galvanisch getrenntes Netzteil mit 
24V betrieben. Die Brücken sind mit normalen 4&6 Adrigen geschirmten 
Kabel verschaltet (sehr lange Strecken, ca. 4m), der Schirm liegt für 
das ganze System auf einen Potential.
Meiner Meinung nach kann ich mir diese Sprünge nur in der 
Brückenschaltung einfangen, da der Rest CAN-Bus ist. Doch arbeiten 
Brücken ja mit einer Vergleichsspannung, also ist so ein dauerhafter 
Offsetsprung durch Einstrahlung doch eher unlogisch,oder? Also die 
Vermutung: Potentialverschiebung, doch dagegen sprechen die Galvanisch 
getrennten Netzteile.
Hat irgend jemand Erfahrung was solch einen Offsetsprung verursachen 
kann oder welche Testmessungen ich machen kann?

Vielen Dank im Voraus!

Autor: was_is_mit_du (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Guten Abend!

Warum nicht eine kleine Sensor-Messauswertung direkt an den DMS ->
Vorverstärkung + U/F-Umsetzer + Optokoppler und dann zu einer weiteren
Auswerteeinheit. Hat man schon seit Ewigkeiten (z.B.: in Schiffen bei
sehr hohen Potentilverschiebungen bis zu 100 V gemacht).
Wär auch nicht so viel Aufwand.

mfg

Autor: Gebhard Raich (geb)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vorschlag: schließ mal den Verstärkereingang kurz und schau ob das 
Offsetproblem noch immer auftritt.Wenn nicht, sind DMS bzw. deren 
Montage zu hinterfragen. Sonst mußt du wohl im Siggnalweg suchen.

Grüße

Autor: Morco (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielen Dank für die Tipps!
Habe beschlossen die Versorgungsspannung mit zu messen, evtl. lassen 
sich da auch Rückschlüsse ziehen. Das mit den Verstärkereingängen 
kurzschließen werde ich auch machen.
Des weiteren habe ich mir Gedanken gemacht eine USV in Reihe 
anzuschließen und das Messsystem quasi von Batterie zu betreiben mit der 
Hoffnung so eine Stärkere Netzdämpfung zu erhalten, hat da jemand 
Erfahrung ob das was bringt?

Autor: Michael Lenz (hochbett)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

> Vielen Dank für die Tipps!
> Habe beschlossen die Versorgungsspannung mit zu messen, evtl. lassen
> sich da auch Rückschlüsse ziehen. Das mit den Verstärkereingängen
> kurzschließen werde ich auch machen.
> Des weiteren habe ich mir Gedanken gemacht eine USV in Reihe
> anzuschließen und das Messsystem quasi von Batterie zu betreiben mit der
> Hoffnung so eine Stärkere Netzdämpfung zu erhalten, hat da jemand
> Erfahrung ob das was bringt?

_Elektrische Checkliste:_
- Verwendest Du auf der Leiterplatte einen Linearregler wie einen 7805 
(empfehlenswert, weil er eine saubere Versorgungsspannung erzeugt)
- Betreibst Du den Linearregler eingangsseitig und ausgangsseitig mit 
100µF (Elko) ||100nF (Keramik). (empfehlenswert, damit er nicht 
schwingt)
- Entstörst Du jede Versorgungsspannung an jedem IC mit 100nF gegen 
Masse. (solltest Du, damit die Spannung in Ordnung ist)
- Vermeidest Du Masseschleifen?
- Verdrillst Du die Anschlußleitungen (solltest Du), oder verwendest Du 
Koaxialkabel (geht auch).
- Verwendest Du zur Messung ein ratiometrisches Verfahren, bei dem die 
Brückenspannung zur Versorgungsspannung ins Verhältnis gesetzt wird (wie 
beispielsweise im ADS1232 von TI integriert).

Gruß,
  Michael

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.