mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Problem mit dem LM317


Autor: Munir Husseini (zuluu)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Forum,

schon den ganzen Tag sitze ich hier und verzweifel. Dabei bin ich 
sicher, dass die Antwort ganz einfach ist - ich bin nur zu blöde.

Also: ich möchte einen LM317 so dimensionieren, dass am Ausgang eine 
Spannung von knapp unter 30V steht. Nach Datenblatt komme ich dabei auf 
R1 = 470 Ohm, R2 = 12k Ohm --> Vout = 27,8V. Das ganze habe ich als SMD 
verbaut.

Nun tut die Schaltung aber nicht, was sie soll. Ich kann am Ausgang des 
LM317 eine Spannung von nur 3,7V messen. Ich habe die LM317 
ausgetauscht, die Widerstände auch. Ich habe auch testweise andere 
Widerstandswerte eingebaut und bekomme immer diese 3,7V.

Hat irgendwer eine Ahnung, wo das herkommt?

Danke und Gruß,
Munir

PS: eine kurze Beschreibung der Grafik im Anhang: U2 stabilisiert über 
R1 und R2 die Spannung auf 30V. U3 begrenzt den Strom auf 50mA für den 
Optokoppler U1.

Autor: zonendoedel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Moin moin,

vielleicht nen ordentliches Multimeter kaufen?

R1 ist für 30 Volt aber verdächtig klein und R2 verdächtig gross dafür.
Ich würd die kleien Kerlchen mal die Plätze tauschen lassen.

Und wech...

Autor: Peter Dannegger (peda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Munir Husseini wrote:

> Nun tut die Schaltung aber nicht, was sie soll. Ich kann am Ausgang des
> LM317 eine Spannung von nur 3,7V messen.

Dann miß doch mal am Eingang.


> R1 und R2 die Spannung auf 30V. U3 begrenzt den Strom auf 50mA für den
> Optokoppler U1.

Hui, das ist aber heftig, 5mA finde ich besser.


Peter

Autor: f7ziukcj aka sdfsd (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
na wenn da mal nicht die 100nF fehlen! die kiste schwingt sich wohl tot 
würde ich mal behaupten !  also wie es im datasheet steht die 
kondenstatoren rein !

Autor: zonendoedel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Moin moin,

mancher Optokoppler ist mit 500u auch schon glücklich.

Und wech...

Autor: Björn Wieck (bwieck)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Munir Husseini wrote:

> Also: ich möchte einen LM317 so dimensionieren, dass am Ausgang eine
> Spannung von knapp unter 30V steht. Nach Datenblatt komme ich dabei auf
> R1 = 470 Ohm, R2 = 12k Ohm --> Vout = 27,8V. Das ganze habe ich als SMD
> verbaut.
>
> Nun tut die Schaltung aber nicht, was sie soll. Ich kann am Ausgang des
> LM317 eine Spannung von nur 3,7V messen. Ich habe die LM317
> ausgetauscht, die Widerstände auch. Ich habe auch testweise andere
> Widerstandswerte eingebaut und bekomme immer diese 3,7V.
>

Hallo Munir

Im meinem Datenblatt des LM317 steht direkt drin das R1 nicht grösser 
als 240
Ohm werden sollte... (sonst könnte es evtl. schwingen)
Mit deiner Kombination 240R und 12k kommst Du übrigens auf 33,2V

Wie gross ist denn die Eingangspannung von dem ersten LM317 ?

Du hast die kleinen 100nF Kondensatoren von in nach GND und von out nach 
GND vergessen...

Ich glaube das dein Aufbau am schwingen ist. Wenn der erste LM317 schön 
warm wird ohne das Du Strom verbrauchst ist es so.

Grüße
Björn

Autor: zonendoedel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Moin moin,

grad nochmal geguckt. Die Widerstände R1 und R2 sind nach
Datenblatt doch richtig rum. Sorry...

Und wech...

Autor: Munir Husseini (zuluu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Im meinem Datenblatt des LM317 steht direkt drin das R1 nicht grösser
> als 240
> Ohm werden sollte... (sonst könnte es evtl. schwingen)
In meinem Datenblatt steht, dass ich eine Mindestlast von 5mA brauche. 
1,25V / 5mA = 250 Ohm...

> Mit deiner Kombination 240R und 12k kommst Du übrigens auf 33,2V

Da habe ich mich wohl vertippt. Ich meinte 10k.

>
> Wie gross ist denn die Eingangspannung von dem ersten LM317 ?

Etwa 37V.

>
> Du hast die kleinen 100nF Kondensatoren von in nach GND und von out nach
> GND vergessen...
>
> Ich glaube das dein Aufbau am schwingen ist. Wenn der erste LM317 schön
> warm wird ohne das Du Strom verbrauchst ist es so.
>

Wenn ich den LM317 berühre, fühlt er sich nach Raumtemperatur an. Aber 
ich werde wohl mal ein paar Kondensatoren reinbauen.

Autor: Munir Husseini (zuluu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Björn Wieck wrote:

> Du hast die kleinen 100nF Kondensatoren von in nach GND und von out nach
> GND vergessen...
>
> Ich glaube das dein Aufbau am schwingen ist. Wenn der erste LM317 schön
> warm wird ohne das Du Strom verbrauchst ist es so.
>
> Grüße
> Björn

Hallo Björn,

ich habe nochmal nachgeschaut und der LM317 wird doch recht warm. Im 
Datenblat steht was von 0.1uF und 1uF. Leider hat der Einbau dieser 
keine Verbesserung gebracht.

Viele Grüße,
Munir

Autor: Munir Husseini (zuluu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Björn,

wenn es nicht so spät wäre, hätte ich auch lesen können ;-) Ich habe 
statt 100nF 10nF eingebat, deshalb hat's nichts gebracht. Mit den 100nF 
geht's super.

Viele Dank,
Munir

Autor: Reutron (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

erfahrungsgemäß funktionieren einige LM317 mit R1 größer 400 Ohm nicht 
mehr richtig....

Gruß Reutron

Autor: Björn Wieck (bwieck)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Munir Husseini wrote:
> Hallo Björn,
>
> wenn es nicht so spät wäre, hätte ich auch lesen können ;-) Ich habe
> statt 100nF 10nF eingebat, deshalb hat's nichts gebracht. Mit den 100nF
> geht's super.
>
> Viele Dank,
> Munir

Hallo Munir,

Ansonsten würde ich es so machen:









                               __
   In>33V                     |    |                      Out 30,0V
    ---------------------o----|317 |----o-----o---------------
                         |    |____|    |     |
                         |      |       |     |
                         |      |      .-.    |
                         |      |      | |    |
                         |      | 220R | |    |
                         |      |      '-'    |
                         |      |       |     |
                         |      o--o----'     |
                         |      |  |          |
                         |      |  |          |
                         |     .-..-.         |
                         |  5k1| || |680k     |+
                        ---    | || |        ===
                 100nF  ---    '-''-'        /-\ 1µF
                         |      |  |          |
                         |      |  |          |
    o--------------------o------o--o----------o--------------o
(created by AACircuit v1.28.6 beta 04/19/05 www.tech-chat.de)


Grüße
Björn

Autor: Munir Husseini (zuluu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Björn,

Ja, das habe ich mir heute auch schon überlegt und wollte gerade damit 
anfangen. 1000 Dank! Ich habe aber noch folgende Frage: muss das am 
Ausgang ein Elko sein?

Viele Grüße,
MUnir

Autor: Björn Wieck (bwieck)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Munir Husseini wrote:
> Hallo Björn,
>
> muss das am
> Ausgang ein Elko sein?

Nö, muss nicht. Kann auch ein KerKo oder FolienKo sein.
Ein Elko wird aber kleiner und billiger sein.


Grüße
Björn

Nachtrag: Denk daran den 100nF so dicht wie möglich an den Regler 
anzuschließen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.