mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AD-Wandler raucht ab


Autor: Christian B. (opacer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

folgende Schaltung macht mir derzeit Kopfschmerzen:


Thermoelement Eingang -> Verstärkt mit Instrumentenverstärker -> 
Tiefpass -> AD-Wandler

Im Detail werden die Thermoelemente mit einem AD620 verstärkt (Vss = 
-12V Vdd = +12V), anschließend kommt ein Tiefpassfilter (RC-Glied) und 
gehen dann in einen AD7327 AD-Wandler (Vss -12V Vdd +12V, gleich dem 
Verstärker). Der kann dann von +10 - -10V messen. Das ganze funktioniert 
eigentlich gut, nur habe ich jetzt schon ein paar mal das Problem 
gehabt, das der AD-Wandler kaputt geht. Das Digital-Interface klappt 
noch, ein Schluss nach Masse an den Eingängen liegt nicht vor.. Die 
interne Spannungsreferenz klappt jedoch nicht mehr und generiert keine 
Spannung.

Ich bin bislang davon ausgegangen, das ESD und der gleichen nicht bis 
zum AD-Wandler durchdringen können, da der OpAmp ja nur bis knapp 
Vss/Vdd verstärken kann (richtig?). Aber dieser geht nicht kaputt. Durch 
den RC-Filter ist der Strom ja auch begrenzt (470R) der zum AD-Wandler 
geht. Ich muss gestehen, das ich nach dem OpAmp allerdings auch keine 
Schutzdioden mehr eingebaut habe. Die Kondensatoren sind allerdings auch 
alle noch in Ordnung (max. 16V). Alle Leiterbahnen ebenfalls.

Bislang kann ich das Problem nicht nachvollziehen/selber hervorrufen, es 
ist jedoch schon 4 mal aufgetreten (AD-Wandler wechseln und gut war), 
daher bestimmt kein Zufall.

Könnte es am Eingang liegen (Thermoeingang) oder könnte es an Stromstöße 
etc. durch die Versorgung kommen, die dann die Vref zerstören? Sonst ist 
alles noch in Ordnung. Die anderen Analogeingänge (direkt am Prozessor) 
sind auch noch ganz, Digital-Eingänge ebenfalls. Wenn ich das Gerät am 
Schreibtisch tagelang an habe ist bislang nichts passiert. Wo kann ich 
suchen? Hat jemand eine Idee?

Als Stromversorgung kommt übrigens ein geregelter DC/DC Wandler mit 
galvanischer Trennung zum Einsatz. Der wird durch ein Kondensator etwas 
geglättet (10µF)

Hoffe ihr habt Ideen...

Grüße

Autor: mr.chip (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

Wuerde mal pruefen, ob der AD-Wandler eventuell einen hoeheren 
Eingangswiderstand bzw. kleineren Strom moechte.

Es koennte auch daran liegen, dass du irgendwelche Bezugspotentiale 
falsch verbindest, so dass eben doch etwas verpolt wird oder aber die 
Spannung zu gross.

Gruss

Michael

Autor: Christian B. (opacer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja sowas habe ich mir auch schon gedacht. Aber wenn ich zwischen Gerät 
und Umwelt z.B. 1000V Massedifferenz hätte und ein Thermoelement 
schließt diese Differenz mit dem äußeren Metall (Minus-Pol), dann würde 
der OpAmp ja mal kurz die 1000V bekommen und die versuchen zu Verstärken 
mit Faktor 250. Das kann er aber doch nicht mit "nur" 12V 
Versorungsspannung. Oder schleust er die 1000V dann einfach so durch 
(davon bin ich bislang nicht ausgegangen)?? Dann könnte ich mir das ja 
noch erklären..

Bei 470R und 12V gehen 26mA durch, was der ADC abkann. Die internen 
Dioden sollten außerdem 2.5kV aushalten bzw. 10mA dauerhaft ableiten 
können ohne Schaden zu nehmen.

Autor: Frank (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

habe nur zwei Ideen:

1) Sind nicht verwendete Eingänge terminiert (Masse)
2) Hast Du die analoge und die digitale Masse miteinander verbunden?

Gruss Frank

Autor: Christian B. (opacer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
1) Ja Eingänge sind terminiert auf Masse (AGND)
2) Thermomasse ist an einem Punkt mit der normalen Masse verbunden.

Autor: Thomas S. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie sieht die Stromversorgung aus ? Evtl. Labornetzteil, welches 
Spannungsspitzen erzeugt ?

Autor: Christian B. (opacer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Spannungsversorung ist ein DC/DC Wandler. Am Oscar sieht die gut aus 
ohne spitzen ..

Autor: ----- (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe auch schon mal einige ADC geröstet bis ich gemerkt habe, dass die 
Spannungen für vdd und vcc nicht gleichzeitig eingeschalten wurden.

Autor: Jankey (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wieviele Geräte die an der Steckdose hängen sind in deinem Laborbereich?

Autor: Thomas S. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist das ein gereglter DCDC Wandler ? Die ungeregelten haben schon ne 
etwas erhöhte Spannung und wenn dann der Baustein diesbezüglich etwas 
empfindlich ist.....Einschaltspitzen ? Ist recht schwierig sowas zu 
messen ohne passendes Equipment.

Autor: Thomas O. (kosmos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
probier doch mal vollen Programm an der Anschlußen wo die 
Versorgungsspannung drankommt, Wiederstand in Reihe, Drossel in Reihe, 
Kondensator gegen Masse und parallel dazu ne Z-Diode gegen Masse und das 
ganze so nah wie möglich an den ADC.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.