mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik mega8 h-bridge


Autor: Chris (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Folgender Aufbau:

mega8 steuert eine H-Brücke (vnh2sp30 oder so...)...Taster 1 lässt 
Gleichstromotor in die eine Richtung drehen...Taster 2 entsprechend in 
die andere...


Folgendes Problem:

Alles funktioniert perfekt, nur habe ich gestern die Kabel an den 
Tastern verlängert (auf 1,5m) und plötzlich dreht der Motor langsamer 
????? Kabel wieder kürzer...Motor wieder schneller...stufenlos 
einstellbar sozusagen ;)...

Das ergibt fü mich wenig Sinn...Anfänger...weiß jemand von euch was da 
los ist bzw. wie man dieses Problem beheben kann...???

Wäre genial...

Beste Grüße

Chris

Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich würde dir ja sagen, was an deiner Schaltung vermutlich nicht stimmt, 
aber ich kann sie aufgrund meiner defekten Glaskugel nicht erkennen...

Autor: Chris (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
smile...sorry...hab gedacht das ich irgeneinen einfachen anfängerfehler 
gemacht hab..

Der Aufbau ist relativ einfach:

Spannungsregler für den Mikrocontroller aus dem AVR Tutorial

Spannung für den Motor über die Brücke aus einer 12V Autobatterie

Mikrocontroller über 1000 ohm wiederstände mit der Brücke verbunden

Wie gesagt, alles funtkioniert, nur unterschiedliche Wiederstände in den 
Leitungen zum Taster wirken sich auf die Motorleistung aus.

Beste Grüße

Chris

Autor: BaFH (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
häng doch mal ein layout und dein programm an, vielleicht hilft das beim 
beantworten ;-)

Autor: Joey5337 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nichts genaues weiß man nicht...

Hast du an den Tastereingängen einen Tiefpass/Kondensator dran? z.B. 
100nF möglichst nahe am AVR.
Vermutung: du fängst dir irgendwas auf deinen Tasterleitungen ein. Ich 
weiß, das kanns eigentlich nicht sein aber aus Erfahrung würd ich da 
trotzdem als erstes schauen.

Grüße, Joey

Autor: Rahul Der trollige (rahul)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es könnte natürlich auch ein Software-Problem sein...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.