mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Merkwürdiges Verbindungsproblem STK500 <-> PC


Autor: Christoph Budelmann (Firma: Budelmann Elektronik GmbH) (christophbudelmann) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Guten Abend,

ich habe gerade folgendes Problem mit meinem STK500:

Ich habe einen Atmega8 eingesetzt und unter AVR-Studio programmiert. 
Nach dem Programmieren (Flashen und Verify), konnte angeblich keine 
Verbindung mehr zum STK500 aufgebaut werden. Atmega8 entfernt und es 
ging wieder. Mit einem zweiten Atmega das gleiche Problem, einmal 
programmiert, dann keine Verbindung mehr. Atmega16 eingesetzt, gleiches 
Problem. Atmega8515 in den Sockel: Lässt sich programmieren, auch 
mehrmals, immer ist die Verbindung da. Ich habe das an zwei Rechnern, 
mit zwei STK500, mit zwei unterschiedlichen USB-Seriell-Adaptern und mit 
zwei unterschiedlichen AVR-Studio-Versionen (die neueste und die davor) 
probiert, immer das gleiche.

Woran kann das bitte liegen?

Gruß
Christoph

Autor: Christoph Budelmann (Firma: Budelmann Elektronik GmbH) (christophbudelmann) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe noch einmal weiter geforscht und dabei folgendes 
herausgefunden: Ich kann den Chip mit usbisb ohne Probleme beschreiben, 
löschen, etc. Setze ich ihn dann in das STK500 ein, wird das STK500 nur 
noch erkannt, wenn der Chip leer ist. Das Programm, was ich auf den 
Atmega8 geflasht habe, hat SPI, ADC, UART und PWM in Betrieb, aber all 
das sollte ja eigentlich kein Grund dafür sein, dass das STK500 auf 
einmal nicht mehr erkannt wird.

Hatte jemand mal ähnlich Probleme oder kann noch Hinweise geben?

Autor: Thomas Krayenborg (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hatte das gleiche Problem nachdem ich das Bit 6 vom ADMUX gesetzt 
habe. Dann habe ich mal im ADC Bereich gesucht und den AREF Jumper 
abgezogen und schon geht es wieder.

Gruß Thomas

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.