mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik ATmega128 im ATMEL Himmel?


Autor: AVRli (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe ein kleines Problem wo ich erstmal nicht weiter weiß.
Es geht um einen ATmega 128 der auf mehrere Platienchen seine Arbeit 
hervorragend macht. Nur eine die spinnt.

Bevor ich nun den Chip austausche frag ich mal ob es wirklich ein 
Anzeichen dafür ist oder ob es doch was anderes ist.

1.
Mit einer Taste kann festlegen ob man nach dem Einschalten im Bootloader 
sein möchte oder nicht.
Hier geht er manchmal ca. alle 5x einschalten allein in den Bootloader 
owohl die Taste nicht gedrückt war.

2.
Wird beim Start der externe SRAM mit einem Muster beschrieben und dieses 
verglichen. Dieser Vergleich schlägt auch gelegendlich fehl. Bei 3 von 
10 Versuchen in etwa.

Ich habe schon nach Brücken und kalten Lötstellen gesucht...
...vielleicht doch was im Halbleiterhimmel?

Das es vom Prinzip funktionieren muß beweisen die anderen 3 Platinen 
aber warum die eine nun zuckt weiß ich nicht... hab ihr einen Rat?

MfG AVRli

Autor: Sebastian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du mal gemessen??

Betriebsspannung, etc?

Autor: AVRli (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja schon, sind 4,95V auch habe ich alle PIN's nochmal nachgelötet, dann 
ging alles erstmal wieder.

10min später das gleiche Bild.

Den Taster habe ich auch schon getauscht, ohne Erfolg.

Wie kann man nun ausschließen das es nicht der µC ist... garnicht oder?



Gruß AVRli...

Autor: Pete11 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
<\Orakel on>
Sind irgendwelche Störquellen in der Nähe ?
Ist die Stromversorgung zuverlässig ?
Abblockkondensatoren verwendet ?
Fuses-Einstellungen korrekt ?
Taster entprellt ?
Reset-Leitung ok ?
Leiterplattenriss ?
<\Orakel off>

Autor: AVRli (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Fehler ist gefunden, es ist unglaublich... ;-)
Der olle Taster war es... selbst der neu eingelötete war defekt.
Also es scheint so als ob der Kontakt nicht 100% in Nullstellung ging.

Also nochmal ausgetausch nun geht es wieder.

Manchmal denk man wohl zu kompliziert... ;-)

THX!

MfG AVRli...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.