mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Computer findet µC nicht


Autor: loki (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hey,

Also ich hatte die ganze Zeit ein selbstgelötetes Board mit nem 
AT-SL8535. Jetzt hab ich mir ein Board von Olimex geholt, dazu nen 
Atmega16 und nen neuen Programmer(10Poig damit das zum Board passt). Hab 
vorher noch nen LCD drangelötet und dacht jepp auf geht's aber NIX!!!

Der Computer erkennt den µC nicht und gibt mir beim verbinden immer 
Error aus.

Was könnt ich vergessen haben?

Wie gesagt is ein neuer Controller, externer Quarz, Betriebssystem is 
WindowsNT und versucht habe ich es mit AVR Prog und YAAP.

Danke schon mal
Loki

Autor: avr-kenner (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Loki,

ja, scheint alles Richtig zu sein, an Deinem Aufbau wird's wohl nicht 
liegen. Probier mal einen neuen Controller oder einen anderen 
Programmer.

Autor: Rooney Bob (rooney)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Versuchs mal mit einem neueren Betriebssystem. WindowsNT ist zwar net, 
aber mag auch sein, dass deine Software nicht drauf läuft.

Autor: loki (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hey,

Danke für die Antworten....

Ich habe schon bissi erfahrung mit Bauteilen und daher gleich 2 µC 
bestellt. Leider läuft es mit beiden nicht. Das mit dem Betriebssystem 
ist auch nciht so leicht.
Hab nur so ne alte Kiste zum Programieren. Die ist sonst immer gut 
gelaufen und meine anderen Rechner (XP und Vista) haben beide keinen 
Druckerport!

Wie könnte es denn sein das NT nicht läuft? gibt es da gründe für? Wäre 
nett wenn mir das einer erklären könnte.

ICh versuche es die Woche mal mit nem Rechner im Institut. Viellleicht 
geht das.

Bis dahin hoffe ich auf noch paar Vorschläge?
MfG
Loki

Autor: Rooney Bob (rooney)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ein Rechner ohne Druckerport? Wo gibt's denn so etwas?

Naja NT ist eben so eine Geschichte... Wenn deine Windows Programm nicht 
für NT entwickelt wurde, dann wirds eben auch nicht funktionieren, 
zumindest nur teilweise nicht funktionieren. Genauere Erklärung habe ich 
nicht dafür, weil auf dem Gebiet kenn ich mich selbst nicht wirklich 
aus.
Aber was ich weiß ist, dass NT immer Probleme macht, deswegen ist es 
auch so gut wie ausgestorben ;-)

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
NT ist nicht ausgestorben, es erfreut sich nach wie vor bester 
Gesundheit. Allerdings hat die Marketing-Idioten-Abteilung es schon 
mehrfach umbenannt.

Das letzte so genannte NT war 4.0, dann folgte "Windows 2000" (NT 5.0), 
"Windows XP" (NT 5.1) und schließlich "Windows Vista" (6.0).

Man sollte mittlerweile annehmen können, daß die Entwickler von 
Programmiersoftware über den 16-Bit-Pseudo-Windows-Frickel-Tellerrand 
('95, '98 und ME) hinwegschauen können und unter NT laufende Software 
liefern.

Autor: Rooney Bob (rooney)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Windows NT und Windows 2000 sind aber zwei andere paar Schuhe!!!!

Ich nehme an, dass Loki das klassische NT, also <= 4.0, gemeint hat.
Diese abgewandelten NT Versionen sind keineswegs kompatibel!!!

Windows NT 4.0 wird vielleicht noch vereinzelt auf Servern verwendet, 
aber ansonsten ist es TOT.

Von Win 95 und 98 braucht man gar nicht erst anfangen... die waren schon 
immer ein Fehlgriff.

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Auch wenn es den Thread mehr und mehr entführt:
Windows 2000 ist Windows NT, wesentliche Neuerung gegenüber NT 4.0 war 
das WDM-Treibermodell, das USB, Firewire und andere Plug&Play-Dinge 
ermöglichte. Und natürlich knapp vier Jahre "Fortschritt" in der 
Benutzeroberfläche. Daher hat ja die Versionsnummer auch so einen großen 
Sprung getan, von 4.0 nach 5.0

Der für Parallelportprogrammieradapter essentielle Devicetreiber 
givelpt.sys oder giveio.sys (oder Derivate davon) musste jedenfalls 
bislang nicht angepasst werden (er stammt aus NT4.0-Zeiten), ich muss 
aber gestehen, das unter NT 6.0 noch nicht untersucht zu haben, weil ... 
ich das ziemlich furchtbar finde.

Autor: Rooney Bob (rooney)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also ich seh das nur von Anwendersicht...

Auf Windows NT 4.0 geht nix... auf Windows 2000 geht alles.

Ist meine Erfahrung, aber da bin ich vielleicht allein was das betrifft.
Aber ein anderes Betriebsystem ausprobieren kann er es ja mal.

Autor: Jörg B. (manos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was ist die "Anwendersicht"? Spielen oder Arbeiten? Arbeiten 
funktioniert auch auf NT4-Systemen noch wunderbar....

Zurück zum Problem...
Wenn kein Druckerport vorhanden ist (was ich schon ungewöhnlich finde) 
gibt es die ISP-Adapter auch noch als serielle- oder USB-Variante.

Von wo kommt die Versorgungsspannung für das Board? Das kann zum 
Programmieren und bei kleineren Schaltungen über das ISP-Kabel kommen, 
kann aber auch nicht belegt/geschaltet sein.

Autor: Rooney Bob (rooney)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
PCs sind nicht zum Spielen da... abgesehen davon verblödet spielen...

Also wenn du auf NT 4.0 arbeiten kannst, ist das schön für dich. Die 
Hälfte meiner Entwicklunsumgebungen funktioniert dort nicht.

Aber egal, dass ist jetzt auch nicht das Thema from Thread.

Autor: loki (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So mal wieder zurück zum Thema??

Also ich habjetzt mal ne Version von ME drauf gespielt. Weiß nicht 
welche aber ich weiss, dass es immer noch nicht funktioniert.

Das mit dem Druckerport ist so weil ich ausser dem alten Ding auf dem 
jetzt ME  ist und das sehr wohl einen Druckerport hat nur 2 Laptops habe 
die leider KEINEN Druckerport mehr haben.

Ich hab noch mal bissi gestöbert und weiß nicht genau was ich mit dem 
Nichtwissen meinerseits jetzt anfangen soll:

Also ich wollte den ISP Programmer hier aus dem shop benutzen. Hab jetzt 
irgendwas von STK12 gelesen und das s´das so nicht geht.... Man sollte 
so was wie STK200 nehmen??? ABER WAS IST DAS??

Heißt das das der Programmer aus dem Shop STK12 ist? Konnte das niergens 
finden..... Und was ist denn an STK200 so anders?

Man da bin ich auf nen Thema gestoßen von dem ich mal keinen Plan habe


Loki

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
"Der Programmer hier aus dem Shop" dürfte ein STK200-Programmieradapter 
sein. Also muss Deine Software den auch unterstützen; PonyProg gehört 
wohl dazu.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.