mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AVR (8515) mit ULN2003


Autor: Stephan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen

Ich bin gerade mal wieder am verzweifeln.

Vielleicht ne blöde Frage, jedoch ich kann doch einen ULN2003 ohne
Vorwiederstand, PullUp oder sonstiges an einen Port hängen, oder?

Folgendes Problem:
Ich steuere über PortD den ULN2003 an, dieser steuert ein Relais (2
Wechsler, 5V) an, über diese 2 Wechsler werden weitere bistabile Relais
(2x7 und 1x6 parallel) angesteuert. Und nun das Problem, Relais 1 (das
Unistabile) läßt sich ohne Probleme ein und ausschalten, wenn ich
jedoch nun die bistabile mit dem unistabilen ansteuere, wird mein 8515
verdammt heiß und stürzt ab. Hat hierfür jemand eine Erklärung?
Bei mir gibts gerade nur Fragezeichen.
Danke

MfG Stephan

Autor: Markus Kaufmann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

ja, den ULN2003 kann man direkt anschließen.

Wenn der AVR heiß wird, dann könnte das ein Latch-Up sein. Hast Du
Freilaufdioden an den Relais? Tritt das Problem mit oder ohne ULN auf?

Markus

Autor: Stephan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Markus

Das Problem tritt mit ULN auf.
Wegen denn Freilaufdioden, ich dachte es ist eine im ULN integriert
(Pin 9 habe ich auf Versorgung unistabiles Relais gelegt). An die
Wechsler des unistabilen Relais habe ich jeweils 2 1N4002
angeschlossen

               +

               |
               -
               ^
+ -----\       |
        -------|---- bistabile Relais
- ------       |
               -
               ^
               |

               -

Dies solle einen Wechsler des unistabilen Relais darstellen mit den
beiden Freilaufdioden und den Ausgang für die bistabilen Relais.
Schaltung ist natürlich doppelt vorhanden.

MfG Stephan

Autor: Stephan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen

Habe nun festgestellt, warum der 8515 so heiß wird.
Sobald das unistabile Relais mit den bistabilen belastet wir, mess ich
am Eingang (also Basis) des ULN 0V, jedoch der 8515 versucht zu Treiben
 -> Kurzschluss, jedoch warum und woher wird der Eingang des ULN auf 0V
gezogen?

MfG Stephan

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.