mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Erfahrung mit ICE200?!


Autor: Sven Lübke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Ich habe mir fürs Debuggen endlich ein ICE200 gekauft und hatte
gehofft, daß jetzt alles gut wird, aber entweder bin ich zu blöd, oder
das Ding funktioniert mit avr-gcc super besch.....:

1. AVR Studio 3.56 schleicht unter Windows 2000 und macht die
Entwicklung zu einer Qual (ein Steppen zum nächsten Befehl dauert ca.
3-5 Sekunden :-(( ) (das hat wahrscheinlich nichts mit avr-gcc zu tun)

Also bin ich auf Studio 4.07 umgestiegen...

2. AVR Studio 4.07 läuft angenehm schnell, aber Watches enthalten
-gleich nach dem Initialisieren- den falschen Wert. Beispiel:

char string[10] = "ICE-Test";

Wenn ich jetzt die Variable "string" in den Watches überprüfe, dann
steht dort alles drin, aber nicht "ICE-Test"! Woran liegt das?

Ich benutze das aktuelle winavr und avrcoff und habe auch ein extended
coff erzeugt! Muß man da noch irgendwas einstellen oder
ist der Fehler normal? Liegt das evtl. an dem Konvertieren von elf zu
coff? Wie kann ich diese Konvertierung umgehen? Habe ich das gleiche
Problem auch beim IAR Compiler?

Es wäre super, wenn Ihr mir ein paar Tips geben könntet!

Danke!

Grüße,

Sven

Autor: Frankl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie schon mehrmal hier im Forum berichtet ist Studio 4.7 noch nicht mal
Beta wert. Siehe auch www.atmelfreaks.net.<forum> <Studio>.

Autor: crazy horse (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich lass den ICE200 mit Studio 3.54 laufen, problemlos. Allerdings sind
die Ports vom pod nicht so belastbar wie beim AVR selbst, habe schon 2
zerschossen. Witzigerweise kostet eine neue pod-Platine fast
genausoviel wie ein kompletter ICE200 :-(

Autor: Joerg Wunsch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
README zum Beta nicht gelesen:

http://www.sax.de/~joerg/README.coff-avr-patch

(Kurz vor dem Ende, unter ``Known issues''.)

Das ist ein Problem mit AVR Studio 4, das Atmel in den aktuellen
Quellen bereits korrigiert hat.  Leider haben sie seit Monaten
keine Updates mehr herausgebracht.  Leute, wenn Ihr AS4 benutzen
wollt/müßt/dürft, dann nervt Atmel bitte.  Ich habe zwar den COFF
patch gemacht, aber ich benutze kein Windows und damit auch kein
AVR Studio, also bin ich auch nicht die richtige Person, Atmel hier
aufs Schwein zu gehen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.