mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik LCD


LCD
Autor: Sun-da (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi, ich Habe ein 4X20 Display. Mein Problem ist mir Fehlen von der 1 und 
2 Zeile am Anfang jeweils 8 Zeichen!

Autor: András (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Ich kenn zwar leider nicht die Speicheraufteilung des 4x20 Displays, 
aber dein Problem liegt irgendwo hier begraben. Da die gleichen 
Controller für verschiedene Displays verwendet werden, weiß dieser nicht 
von alleine wie lang eine Zeile ist. Der Controller ist also von Haus 
aus für längere Zeilen ausgelegt. Wenn du also den Cursor nicht in die 
nächste Zeile setzt oder an die falsche Stelle, dann verschwinden die 
ein paar zeichen im Nirwana bzw. sitzen an unsichtbaren Speicherstellen. 
Such also nach der Speicheraufteilung für dein Display dann wirst du das 
problem schnell beheben.

cu András

Autor: Sun-da (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab ein KS0066 Controller. kannst mir das mal genauer erläutern?

Autor: András (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!

Noch was: Vielleicht schaust du auch mal ob das Display überhaupt in 
Ordnung ist. Dazu verbindest du einfach Pin 1 und 3 mit Masse und Pin2 
mit +5V. Beim einschalten sollte die ganze erste Zeile mit schwarzen 
Quadraten gefüllt sein sprich alle Punkte schwarz.

cu András

Autor: András (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi !

Markus schrieb in einem anderen Thread:

Hi,
dazu sollte man vielleicht noch folgendes ergänzen: diese Displays 
kennen normalerweise nur einen ein- und einen zweizeiligen Modus. Jede 
Zeile hat 40 Zeichen, auch wenn sie nicht angezeigt werden. Bei den 
vierzeiligen wird jetzt der nicht angezeigte Teil in der dritten und 
vierten Zeile angehängt. Damit alles funktioniert muß das Display in den 
zweizeiligen Modus geschaltet werden. Die erste Zeile wird ab Adresse 
$00 angesprochen, die dritte beginnt praktisch am Ender der ersten. Die 
zweite Zeile beginnt wie Meiserl gesagt hat ab $28 (dezimal 40) und die 
vierte Zeile beginnt am Ende der zweiten.


cu András

Autor: Sun-da (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also das Dispaly Macht keinen Schwarzen Balken! ich seh nur die 1 und 3 
Zeile etwas heller. habs wieder normal angeschlossen aber warum sind die 
2 anderen Zeilen in ordung? Ach ja es flackert ganz leicht!

Autor: András (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
welches Display hast du denn genau?

hast du schon das datenblatt angeschaut?

cu András

Autor: Sun-da (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So jetzt hab ich das problem fast behoben der kontrast is nur bei den 16 
zeichen die vorher fehlten jetzt ziehmlich mager kannst mir dabei 
helfen?

Autor: Sun-da (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich hab ein displaytech 204A    -   KS0066  20X4 1/16 Duty 1/5 Bias

Autor: András (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!

Sorry das sagt mir nichts :-(

cu András

Autor: Sun-da (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
:( OK na ja ich kauf mir nen neues !! :)

Autor: ERDI - Soft (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

scheint so, als wäre Dein Display kaputt. Das Display ist von Reichelt, 
oder?
Egal, auf jeden Fall ist der Controller zum 44780 kompatibel. Von daher 
sollte also nicht die Ansteuerung das Problem sein.
Falls Du das Datenblatt suchst, dann schaue mal unter dem 
internationalen Yahoo (würg) und suche doch einfach nach Displaytech. 
Kann dir leider die HP-Adresse nicht sagen, weil ich sie nicht auswendig 
weiß. (Vorsicht, auf der Homepage von denen kommst Du nur über etwas 
rumgeklicke und mit Geduld an die Dateblätter ran. Hat mich fast ne 
halbe Stunde gekostet, das Datenblatt des 128x64 Pixel-Grafikdisplays zu 
bekommen.)

Viel Glück.

Bye, ERDI - Soft.

Autor: Sun-da (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es funzt doch! :) Das Display ist von Glyn da wars günstiger und mit 
blauer Beleuchtung! :) Die software hat die ersten zeichen nur alle 
600us gesendet nicht alle 100 also nur 1/6 Kontrast!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.