mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik two panel display mit SED 1330 / 1335


Autor: Rockclimber (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

habe mir eine Displayplatine mit einem SED1335 gebaut. Mit einem
320x240 Display funktioniert es einwandfrei. Ich möchte aber ein
Optrex-Display 256x128 anschließen. Hier ist der Link zu diesem schönen
Stück:
http://www.optrex.co.jp/us/product/catalog/pdf_dmf...

Das ist ein sogenanntes 'two panel display', das heißt, die
Displayfläche ist Treiberseitig in zwei Teile unterteilt. Der SED 1335
hat für solche Displays einen extra init-parameter W/S. Dieses bit muß
auf 1 gesetzt sein für 'Dual-panel drive'.

Das Problem ist aber, daß in der zweiten Displayhälfte nichts angezeigt
wird. Ich habe schon alle möglichen init-Parameter ausprobiert - leider
ohne Erfolg.

Ist das Display defekt? oder muß ich beim Anschließen noch etwas
beachten? Oder ist gar der SED ungeeignet für dieses Display?

hoffe, daß ich das Display bald 'ganz' betreiben kann.

Clemens

Autor: Rockclimber (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hochschieb

hat denn keiner einen Tip?
Oder bin ich mit meiner Frage im falschen Forum?

Gibt es noch andere Informationsquellen speziell zu diesem Thema?

Clemens

Autor: Andreas Franke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Clemens,
ich hab dir zwar keinen Tipp, aber dafür eine Frage:
Woher hast du den SED ?

Und noch eine:
Woher hast du die Displayplatine (selbst gemacht)?

Und noch eine:
WIe erzeugst du die negative Kontrastspannung ?


Gruß,
Andreas

Autor: Rockclimber (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Andreas,

3 Stück vom SED hab ich vor Jahren mal bei Spezial bestellt (bin mir
aber nicht mehr ganz sicher). Ging aber nur, weil die gerade noch ein
paar lose da hatten. Normalerweise bekommt man die dort nur in
Stückzahlen >50.

Die Display-Platine habe ich in Anlehnung an das Lamepage-Design selber
entwickelt und geäzt.

Die -22V sind auch so wie bei Lamepage beschrieben, allerdings gleich
'onboard'. Jetzt zeigt sich aber, daß das doch nicht so optimal ist,
da mein 256x128-Display eine andere Spannung braucht (-12 mit Basis an
VCC und nicht an VSS)
Na ja, da muß erst mal das Labor-Netzteil aushelfen...

Clemens

Autor: Rockclimber (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

hier nochmal ein Bild von dem Display. Da kann man sehen, daß in der
unteren Hälfte ein Teil (genau 16 Pixel) von der oberen Hälfte mehrfach
mit dargestellt wird. Dieser Effekt ist auch zu sehen, wenn man den
gesamten Speicher vom SED mit z.B. $0F beschreibt. Dann sieht man ein
Streifenmuster, nur leider nur in dem Bereich, wie auf dem Bild.
Eigentlich müßte das gesamte Display ein Streifenmuster darstellen.
Was kann das sein?

Dankbar für jede Hilfe,
Clemens

Autor: Rockclimber (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

heute zeigte das Display durch Zufall die obere Hälfte korrekt an. Die
untere Hälfte war allerdings eine exakte Kopie der oberen Hälfte.
Nach einem Display-refresh war dann aber wieder alles beim alten :-(

Na ja, jetzt weiß ich wenigstens, daß die Treiber auf dem Display
wahrscheinlich in Ordnung sind.

Kann es sein, daß durch ungünstige Leiterbahnführung, bzw. falsch
angeordneter Puffer-Kondensatoren die Init-Befehle durch den SED 133x
nicht immer richtig interpretiert werden?

Clemens

PS: so richtig schlau werde ich nicht daraus, zumal die
controller-Platine mit einem 320x240-Display einwandfrei läuft. Oder
liegt es vielleicht an der Verkabelung vom controller zum Display? Das
ist der einzige Unterschied, der mir jetzt noch einfällt.

Autor: Thoralt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Falls noch jemand nach der Bezugsquelle für SED1335 fragen
sollte: http://www.segor.de vertreibt noch welche davon.
Das Stück kostet 17,80 €. Viel Spaß damit!

Autor: koen verstappen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Herr,
Könnst du mich sagen wie du die platine gebaut hast...ich habe auch ein
sed1335 un optrex6104NB (LCD) und möchte es auf bauen..aber wenn du mir
sagen kannst welche anfang fehler dabei moglich sind, mache ich den
fehler nicht mehr..
gruss
koen verstappen
niederlande

Autor: Mark de Jong (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Rockclimber,

Poste mal deine init werte?

Grüße Mark,
P.S. S1D13305 Controller Platine ünter www.mdejong.de

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.