mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AVRISP funktioniert nicht :(


Autor: Timo (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
Habe meinen ISPASP heut bekommen. Es ist einer, den es auch hier im shop 
gibt. Habe ihn installiert.

Nun habe ich in AVR Studio folgenden Fehler:

siehe Anhang.

Was kann da schief laufen?

Autor: Martin K. (spyro07)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
flashe den mc doch lieber mit pony prog.
das ist einfach

Autor: Timo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja aber da funktioniert der USB Programmer doch net.

Autor: Martin K. (spyro07)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
das weis ich nich.
ich hab mir einfach son ding selber gebaut. das geht, ist sehr eifach.

Autor: Timo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Lesen läuft fehl ebenso wie das Programmieren.

Autor: Andreas Schwarz (andreas) (Admin) Benutzerseite Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Problem ist wohl eher deine Schaltung, nicht der Programmer. Hast du 
dir mal die Hinweise in der Fehlermeldung durchgelesen? Oder die 
AVR Checkliste?

Autor: Timo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe alles überprüft. Nix. Er geht nicht :( Ist grad frisch aus der 
Verpackung. Also Neu.

Autor: Simon K. (simon) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sicher, dass der Mikrocontroller richtig verdrahtet ist?

Autor: Timo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ja. Muss irgendwie an der Software liegen :( ...

Außerdem bin ich noch auf der Suche nach einer passenden Buchse ... also 
6 Pol ...

Autor: Bratensosse (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
kannst du im avr studio die programmierfrequenz einstellen?
wenn ja, dann kommuniziert er ja schon fleissig mit dem programm.

hast du den gnd pin vom programmer auch mit gnd vom target verbunden

grüße
ich

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn es ein AVR_ISP MkII ist, dann muß RESET am Controller richtig 
beschaltet sein. Vcc vom zu programmierenden Controller muß mit Pin2 des 
ISP-Kabels verbunden werden. Die Status-LED am AVR-ISP muß grün 
leuchten, wenn alles korrekt angeschlossen ist. In der Online-Hilfe vom 
AVR-Studio ist zu dem Tool alles erklärt. Bitte lesen.

>flashe den mc doch lieber mit pony prog. das ist einfach

Das war ja wohl ein Scherz. 60% der Themen hier handeln von verflashten 
oder verfusten Controllern, die mit Ponyprog geflasht wurden.

Autor: Timo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Und wo bekomme ich die passende 6 Pol Buchse her ...

Autor: Holger Krull (krulli) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Reichelt PFL6

Autor: Timo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sorry, suche dass Gegenstück dazu :( .. verwechselt.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.