mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Ausschaltspikes gehen nicht weg


Autor: Jim (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe einen kleinen Lautsprecher mit 8 Ohm folgendermaßen beschaltet:
http://www.picotech.com/applications/pwm_drivers/g...
(Speaker statt Motor)
Als Diode habe ich eine 2N4007 und eine 4148 probiert. us irgendwelchen 
Gründen, sind aber immer noch Ausschaltspikes von 100 ns Dauer und etwa 
50 V Amplitude da. Der Transistor ist ein 2N7000. Was mache ich falsch? 
Schottkydidode bringt auch nix.

Autor: Chrisi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bedenke, dass auch die Zuleitungen zum Lautsprecher eine (kleine) 
Induktivität darstellen. Daher sollte zum Schutz des MOSFETs die Diode 
nahe am Drainanschluss angeschlossen sein.

Autor: Jim (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sie ist direkt dort. Kürzere Leitungen bringen auch nix...

Autor: Jim (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ein Kondensator von Drain zu Gnd reduziert sie recht gut. Wenn ich eine 
kleine Spule statt des Lautsprechers verwende wird das Problem noch 
ärger. Wollte hier nicht jemand einen Elektroschocker bauen?
Kann es sein dass meine Dioden nicht die richtigen sind? Das ist ja dann 
ein generelles Problem...

Autor: Thomas O. (kosmos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
deine Dioden sind warscheinlich zu langsam. Aber mit dem Kondensator 
sollte es gehen wenn der Transistor durchschaltet wird dieser ja 
entleert und wenn er abschaltet nimmt er denn Spike auf zumindestens 
flacht er ihn ab so das der Spikes nicht so steilflankig ist und die 
Diode dann mit zurechtkommt.

Ansonsten schau mal nach schnellschaltenden Dioden wie sie in 
Schaltnetzteilen zum Einsatz kommen.

Autor: Jim (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Eine Schottky sollte doch so schnell schalten, oder? Ich hab gerade 
nochmal eine 10 V Z-Diode von Drain nach Source gelegt und siehe da: sie 
kappt die Spannungspeaks effektiv. Nur recht warm wird sie. Anscheinend 
wird da richtig was verheizt! Ob das eine Rolle spielt bei den anderen 
Dioden? Verkraften die den Strom nur nicht? Ist ja nur ein paar ns 
lang...

Autor: Jim (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ahaja: Spannung: 9V Strom: 400 mA im Mittel (800 mA 50% der Zeit bei 10 
kHz)

Autor: Jim (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Und ne dicke Diode aus einem Schaltnetzteil tut es auch nicht...

Autor: Jim (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kennt sich niemand mit solchen Fällen aus?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.