mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Mega32 L mit 5 V geht 3,6V nicht.


Autor: Megaboy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also Ich habe einen Mega32L der mit 5 V
ohne Quarz funktioniert. Aber bei 3,6V
gehts nicht, habe mehrere Mega32 L getestet einer funk. sogar an 3,6V.
Woran könnte das liegen ??.

Autor: The Devil (devil_86)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tja, irgendwann ist die Versorgungsspannung halt zu gering...

Autor: Megaboy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
das ist aber ein L typ

Alle AVRs, werden bevor sie  versendet werden ,
für unseren Kunden geprüft, und es gibt mehrere Tests.
Einige mega32s werden nur in der Stromspannungsreihe 4.5 zu 5.5 Volt,
 aber bis zu 16 MHz geprüft. Diese  werden ATmega32 gekennzeichnet.
Andere  werden bis zu 2.7 Volt geprüft, aber nur bis zu 8 MHz,
Diese  werden ATmega32L gekennzeichnet.

Autor: Nanoboy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielleicht der brown-out zu niedrig eingestelllt?

Autor: Holger Krull (krulli) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielleicht ist deine Takfrequenz zu hoch..

Autor: Megaboy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
brown-out  ist auf 2,7 Volt eingestellt.

Autor: sakrament (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wenn ich schon lese für unsere kunden

Autor: Nailpainter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Geht nicht - wodurch aeussert sich das ?

Autor: mr.chip (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Für die Chips müssen 3.6 V ja problemlos reichen. Kann es sein, dass 
deine Spannungsquelle irgendwie nicht richtig funktioniert bei 3.6 V? 
Miss mal die VCC/GND-Pins am Mega in der Schaltung. Oder hast du 
irgendwelche 'gröberen' Dinger an 3.6 V, die Spannungsschwankungen 
verursachen können?

Könnte irgendwelche externe Peripherie zicken? Entweder, da sie bei 3.6 
V abstürzt oder aber, da sie erst auf 3.6 V unten zugeschaltet wird?

Bist du sicher, dass du die Brown-Out-Fuses richtig konfiguriert hast? 
(Bei ALLEN getesteten Geräten!) Schalte den Detektor doch mal ganz ab, 
und schaue dann nach, was passiert.

Kannst du Probleme mit Fehlern im Layout / in der Schaltung 
ausschliessen? (Beispielsweise ein Kontaktunterbruch in der 3.6 
V-Versorgungsspannung?

Autor: Megaboy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
LCD  Dog serie EA Dog M mit Beleuchtung. funktioniert super auffen 
steckbrett bei 5 V sobald ich auf 3,6 V runter gehe ist alles weg.
Das komische ist einer von den Mega 32 L funktioniert
Super.Fuse bits sind alle gleich eingestellt.
Ist schon komisch.

Autor: Megaboy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Fuse: 1 Bodlevel 2,7 V
      1 Boden
  987 1 int.RC 1 Mhz
      1 Ocden
      0 Jtag
      0 seriell enable
      1 osc option no
      1 Preseve EEProm no
      00 2048 word
      1 reset

Autor: Holger Krull (krulli) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Na vielleicht kann dein LCD nicht mit 3,6V umgehen...

Autor: Holger Krull (krulli) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
sakrament wrote:
> wenn ich schon lese für unsere kunden

Das ist ein übersetztes Zitat von Atmel... Bist du da kein Kunde?

Autor: Nanoboy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hauptsache mal die Leut verarscht. Wenn nix mehr uffem Display ist, 
warum bitte ist der µC dann im Arsch?

Mannomann, kann doch nicht so schwer sein, mal verständliche Fakten zu 
schreiben, so, dass jeder sofort erkennt, worum es geht.

Thread kann gelöscht werden!

Autor: Megaboy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nanoboy Mach eine Entziehungskur.

Autor: Nanoboy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
EA DOG M, jetzt müsste man nur noch wissen, welcher Typ genau. 
Schließlich gibt es die für 5 V und 3,3 V. Aber wenn du keine Infos 
preisgibst, kannst du auch keine Hilfe erwarten. Einfache Sache...

Autor: Udo Z. (Firma: keine) (udoz)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Moin,

Nanoboy wrote:
> EA DOG M, jetzt müsste man nur noch wissen, welcher Typ genau.

Die (implizite) Frage ist sinnfrei, weil es bezüglich der 
Spannungsversorgung nur einen Typ gibt.


> Schließlich gibt es die für 5 V und 3,3 V.

Es gibt sie nur als 3,3V-Displays, die man aber auch an 5V betreiben 
kann.


>Aber wenn du keine Infos
> preisgibst, kannst du auch keine Hilfe erwarten. Einfache Sache...

Äh, ja...


UdoZ

Autor: Tom (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du jetzt deinen Namen gewechselt?

Autor: Wetzel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo !

hänge mich mal in die Diskussion rein.
1.µC ist 32 L
2.habe Schaltung mit Display Displaytech 162 von Reichelt ( 5 V )
3.hänge ich µC daran ( 5 V ) läuft alles .
4. regele ich die Spannung runter auf 2,3 V geht zwar das LCD aus aber 
der
   µC läuft weiter, denn wenn er reseten würde würde er beim hochregeln 
der
   Spannung ein Reset ausführen aber er bleibt in der Stellung und 
erwartet
   die Eingabe.Es ist ein starkes Indiz das der µC L auch mit 3,3 V wie
   beschrieben im Datenblatt zurecht kommt.
   Nur an den EA DOG-M 162E-A mit 3,6 V zeigt er auf den LCD nichts an.

Frage: muss beim Einstellen des LCD DOG beim progg. was beachtet werden 
?
Oder ganz normal an 4 Bit Modus programmieren ?
Habe bei www.lcd-module.de nicht gefunden.

panzer4000

Autor: M.A.N (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.